[PATCH] gnu: dehydrated: Declare cURL's native search paths.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 15 Mar 2020 01:25
(address . guix-patches@gnu.org)
20200315002556.12076-1-me@tobias.gr
* gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.
---

Posted because I'm not sure what the worst way to handle the recursion
is. Or why it happens.

Kind regards,

T G-R

gnu/packages/tls.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c8eea9c928..1cd6487e4a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;;
@@ -988,6 +988,13 @@ coding footprint.")
(native-inputs
`(("gzip" ,gzip)
("tar" ,tar)))
+ (native-search-paths
+ ;; XXX Using (package-native-search-paths curl) here recurses infinitely.
+ (list (search-path-specification
+ (variable "CURL_CA_BUNDLE")
+ (file-type 'regular)
+ (separator #f)
+ (files '("etc/ssl/certs/ca-certificates.crt")))))
(home-page "https://dehydrated.io/")
(synopsis "Let's Encrypt/ACME client implemented as a shell script")
(description "Dehydrated is a client for signing certificates with an
--
2.23.0
L
L
Ludovic Courtès wrote on 24 Mar 2020 18:50
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 40065@debbugs.gnu.org)
87pnd1lk0s.fsf@gnu.org
Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (2 lines)
> * gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.

LGTM!

Toggle quote (3 lines)
> Posted because I'm not sure what the worst way to handle the recursion
> is. Or why it happens.

Recursion is expected here: loading tls.scm would require loading curl’s
module first, which itself depends on tls.scm.

Ludo’.
M
M
Maxim Cournoyer wrote on 3 Aug 2021 21:49
Re: bug#40065: [PATCH] gnu: dehydrated: Declare cURL's native search paths.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87tuk68g1a.fsf_-_@gmail.com
Hi!

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>
>> * gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.
>
> LGTM!
>
>> Posted because I'm not sure what the worst way to handle the recursion
>> is. Or why it happens.
>
> Recursion is expected here: loading tls.scm would require loading curl’s
> module first, which itself depends on tls.scm.
>
> Ludo’.

Pushed with commit 77e2df870bdd3605925b78642661e252a83b2369.

Closing.

Maxim
Closed
?