[PATCH 1/2] gnu: bitlbee-discord: Fix build failure

  • Done
  • quality assurance status badge
Details
4 participants
  • Adrian Fullmer
  • Leo Famulari
  • Christopher Baines
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Adrian Fullmer
Severity
normal
A
A
Adrian Fullmer wrote on 14 Mar 2020 19:57
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
1327954942.3272829.1584212270035@mail.yahoo.com
The old package definition fails to build due to attempting to create a help file in the bitlbee store location. This patch corrects the data directory in which the help file is placed to be in the bitlbee-discord output.
Attachment: file
From f031b1999c22294455c6ca55dc76d34e016ffdb4 Mon Sep 17 00:00:00 2001
From: Adrian Fullmer <adrianfullmer@yahoo.com>
Date: Sat, 14 Mar 2020 11:59:58 -0500
Subject: [PATCH 1/2] gnu: bitlbee-discord: Fix build failure

---
gnu/packages/messaging.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f8b743f766..72c505c6d9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -248,6 +248,9 @@ identi.ca and status.net).")
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(invoke "./configure"
+ (string-append "--with-bdatadir="
+ (assoc-ref outputs "out")
+ "/share/bitlbee/")
(string-append "--with-plugindir="
(assoc-ref outputs "out")
"/lib/bitlbee/")))))))
--
2.25.1
A
A
Adrian Fullmer wrote on 14 Mar 2020 20:34
[PATCH 2/2] gnu: bitlbee-discord: update to working version
(name . 40063@debbugs.gnu.org)(address . 40063@debbugs.gnu.org)
38089017.3258274.1584214496561@mail.yahoo.com
The latest stable version of bitlbee-discord is partially incompatible with discord as it exists now, so i upgraded to the latest git version which functions correctly.
Attachment: file
From f53eb6bc1f9659430617a3232239411e1792549d Mon Sep 17 00:00:00 2001
From: Adrian Fullmer <adrianfullmer@yahoo.com>
Date: Sat, 14 Mar 2020 12:42:06 -0500
Subject: [PATCH 2/2] gnu: bitlbee-discord: update to working version

---
gnu/packages/messaging.scm | 78 +++++++++++++++++++-------------------
1 file changed, 40 insertions(+), 38 deletions(-)

Toggle diff (97 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 72c505c6d9..75cf5375c6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -223,50 +223,52 @@ identi.ca and status.net).")
(license (list license:gpl2+ license:bsd-2))))
(define-public bitlbee-discord
- (package
- (name "bitlbee-discord")
- (version "0.4.2")
- (source
- (origin
+ (let ((commit "3061edd283b4e886384e5e8cad10f92dc45f3ee7")
+ (revision "0"))
+ (package
+ (name "bitlbee-discord")
+ (version (git-version "0.4.2" revision commit))
+ (source
+ (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/sm00th/bitlbee-discord.git")
- (commit version)))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-autogen
- (lambda _
- (let ((sh (which "sh")))
- (substitute* "autogen.sh" (("/bin/sh") sh))
- (setenv "CONFIG_SHELL" sh))
- #t))
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "./configure"
- (string-append "--with-bdatadir="
- (assoc-ref outputs "out")
- "/share/bitlbee/")
- (string-append "--with-plugindir="
- (assoc-ref outputs "out")
- "/lib/bitlbee/")))))))
- (inputs `(("glib" ,glib)))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("texinfo" ,texinfo)
- ("libtool" ,libtool)
- ("bitlbee" ,bitlbee) ; needs bitlbee headers
- ("bash" ,bash)))
- (synopsis "Discord plugin for Bitlbee")
- (description "Bitlbee-discord is a plugin for Bitlbee witch provides
+ (base32 "1d6nkr7wfrhra09ql258hvhr6q8kmnigcr14hjbwk10kqcb277y6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-autogen
+ (lambda _
+ (let ((sh (which "sh")))
+ (substitute* "autogen.sh" (("/bin/sh") sh))
+ (setenv "CONFIG_SHELL" sh))
+ #t))
+ (replace 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (invoke "./configure"
+ (string-append "--with-bdatadir="
+ (assoc-ref outputs "out")
+ "/share/bitlbee/")
+ (string-append "--with-plugindir="
+ (assoc-ref outputs "out")
+ "/lib/bitlbee/")))))))
+ (inputs `(("glib" ,glib)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("texinfo" ,texinfo)
+ ("libtool" ,libtool)
+ ("bitlbee" ,bitlbee) ; needs bitlbee headers
+ ("bash" ,bash)))
+ (synopsis "Discord plugin for Bitlbee")
+ (description "Bitlbee-discord is a plugin for Bitlbee witch provides
access to servers running the Discord protocol.")
- (home-page "https://github.com/sm00th/bitlbee-discord/")
- (license license:gpl2+)))
+ (home-page "https://github.com/sm00th/bitlbee-discord/")
+ (license license:gpl2+))))
(define-public hexchat
(package
--
2.25.1
L
L
Leo Famulari wrote on 15 Mar 2020 18:32
(name . Adrian Fullmer via Guix-patches via)(address . guix-patches@gnu.org)(name . 40063@debbugs.gnu.org)(address . 40063@debbugs.gnu.org)
20200315173226.GC26892@jasmine.lan
On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
Toggle quote (2 lines)
> The latest stable version of bitlbee-discord is partially incompatible with discord as it exists now, so i upgraded to the latest git version which functions correctly.

Is there a link to any upstream bug reports about this?
C
C
Christopher Baines wrote on 20 Nov 2020 22:37
(name . Adrian Fullmer)(address . adrianfullmer@yahoo.com)(address . 40063@debbugs.gnu.org)
875z5zk8vt.fsf@cbaines.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (7 lines)
> On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
>> The latest stable version of bitlbee-discord is partially
>> incompatible with discord as it exists now, so i upgraded to the
>> latest git version which functions correctly.
>
> Is there a link to any upstream bug reports about this?

Not sure you got this previous email Adrian, but is this Bitlbee fix
something you're still interested in getting merged?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+4NwZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf8LxAAsPoDlIR+Y4owaqMDbkyzlWabbTnxTMTY
JGkBp0ehiUMDdw/ITvbgjaKXzINMr68Ks7KUoud/ARbVyGyv7q39tbsDAwaboPDV
Cpnxmbu/tNvRcDyFumSQR1JzhsnUI26pEJ0VH98U654Pp/hoFwXf/ilpOnsJjdhR
2YXqLix627qqSSOtwwaWfaovLDMu/PNclxNrRGv3cfd2BitgS5+xgYL27opQg7G/
RJwk/NaQAjIFUI8RMVXtQLHyU5uL8kW9+vU4R8oGh2z98b658j529q5fVfGZjtAh
soKLvH2QP4Fui8lM5eJfWjnFV+ZrSxsJ3jrFynj+RhkZbCLo8MgqearbWE66WE1K
9Ri8+Z/Hxv6j7q5oqOHnsjujP0pB2V/Ina7UC1rMKTWK3MLmbvPWicSJnAKryHbi
SXmY1nBWQ9d/YTsBoDfaEoRquw4e2zWeAnL2Gr4I6sWaUOJS2GEalzrEytdNCRGw
QEBSA8z2D/dYBoOczTu5CNs+Ul1RQG/3NGeBeKMMl5BicBrffJY/i3GiwfRHkecM
05AVRYT34sutBoZPLfTazhWsaJExj0IeeQcqwIwC/eJGQtJZpSLcw/jj7wkBM0Xx
vPR0y7hy3Q3LyTn0uHCW1MoC13tCfB0IfE2CxPd418U8dXiNrUIkXVyK3cXcSao6
w5r2a+CJQHM=
=eexz
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 14 Jul 2021 15:05
Re: bug#40063: [PATCH 1/2] gnu: bitlbee-discord: Fix build failure
(name . Christopher Baines)(address . mail@cbaines.net)
87h7gxoxjq.fsf_-_@gmail.com
Hello,

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (12 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Sat, Mar 14, 2020 at 07:34:56PM +0000, Adrian Fullmer via Guix-patches via wrote:
>>> The latest stable version of bitlbee-discord is partially
>>> incompatible with discord as it exists now, so i upgraded to the
>>> latest git version which functions correctly.
>>
>> Is there a link to any upstream bug reports about this?
>
> Not sure you got this previous email Adrian, but is this Bitlbee fix
> something you're still interested in getting merged?

I've merged the fix to the build failure as
a6a4d4b843e8fcf35009ca556d9ed25a700b52d5, and updated the package to
0.4.3 in e69e0c43f867f23127029fd6959534f6a130bcfe. Let me know if
something still needs to be done!

Closing.

Maxim
Closed
?