[PATCH 0/2] Update avr-gcc

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Malte Frank Gerdes
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 4 Mar 2020 21:02
(address . guix-patches@gnu.org)
20200304200209.6309-1-arunisaac@systemreboot.net
Hi,

This patchset updates our avr-gcc to version 7, same as the version of gcc in
Guix. I have tentatively deleted other older versions of the avr-toolchain and
replaced our avr-libc and avr-toolchain functions with package variables. Do
we need to keep all older versions of the avr-toolchain? WDYT?

Regards,
Arun.

Arun Isaac (2):
gnu: avr-gcc: Update to 7.4.0.
gnu: avr-toolchain: Replace functions with package variables.

gnu/packages/avr.scm | 67 +++++++++++++++-----------------------------
1 file changed, 22 insertions(+), 45 deletions(-)

--
2.25.1
A
A
Arun Isaac wrote on 4 Mar 2020 21:09
[PATCH 2/2] gnu: avr-toolchain: Replace functions with package variables.
(address . 39918@debbugs.gnu.org)
20200304200945.6657-2-arunisaac@systemreboot.net
* gnu/packages/avr.scm (avr-gcc-7): Rename to avr-gcc.
(avr-libc): Replace function with variable.
(avr-toolchain): Replace function with variable.
---
gnu/packages/avr.scm | 43 ++++++++++++++++++++-----------------------
1 file changed, 20 insertions(+), 23 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 8a964b9b17..e6f8c36bd1 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -41,8 +41,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-7
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
+(define avr-gcc
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -79,10 +79,10 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc" ,gcc-7)
+ `(("gcc" ,gcc)
,@(package-native-inputs xgcc))))))
-(define (avr-libc avr-gcc)
+(define avr-libc
(package
(name "avr-libc")
(version "2.0.0")
@@ -107,30 +107,27 @@ for use with GCC on Atmel AVR microcontrollers.")
(license
(license:non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))
-(define (avr-toolchain avr-gcc)
+(define-public avr-toolchain
;; avr-libc checks the compiler version and passes "--enable-device-lib" for avr-gcc > 5.1.0.
;; It wouldn't install the library for atmega32u4 etc if we didn't use the corret avr-gcc.
- (let ((avr-libc (avr-libc avr-gcc)))
- (package
- (name "avr-toolchain")
- (version (package-version avr-gcc))
- (source #f)
- (build-system trivial-build-system)
- (arguments '(#:builder (begin (mkdir %output) #t)))
- (propagated-inputs
- `(("avrdude" ,avrdude)
- ("binutils" ,avr-binutils)
- ("gcc" ,avr-gcc)
- ("libc" ,avr-libc)))
- (synopsis "Complete GCC tool chain for AVR microcontroller development")
- (description "This package provides a complete GCC tool chain for AVR
+ (package
+ (name "avr-toolchain")
+ (version (package-version avr-gcc))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments '(#:builder (begin (mkdir %output) #t)))
+ (propagated-inputs
+ `(("avrdude" ,avrdude)
+ ("binutils" ,avr-binutils)
+ ("gcc" ,avr-gcc)
+ ("libc" ,avr-libc)))
+ (synopsis "Complete GCC tool chain for AVR microcontroller development")
+ (description "This package provides a complete GCC tool chain for AVR
microcontroller development. This includes the GCC AVR cross compiler and
avrdude for firmware flashing. The supported programming languages are C and
C++.")
- (home-page (package-home-page avr-libc))
- (license (package-license avr-gcc)))))
-
-(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
+ (home-page (package-home-page avr-libc))
+ (license (package-license avr-gcc))))
(define-public microscheme
(package
--
2.25.1
A
A
Arun Isaac wrote on 4 Mar 2020 21:09
[PATCH 1/2] gnu: avr-gcc: Update to 7.4.0.
(address . 39918@debbugs.gnu.org)
20200304200945.6657-1-arunisaac@systemreboot.net
* gnu/packages/avr.scm (avr-gcc-7, avr-toolchain-7): New variables.
(avr-gcc-4.9, avr-gcc-5, avr-toolchain-4.9, avr-toolchain-5): Delete
variables.
(avr-libc)[arguments]: Remove custom fix-cpath phase.
---
gnu/packages/avr.scm | 32 ++++++--------------------------
1 file changed, 6 insertions(+), 26 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 608e487b93..8a964b9b17 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,8 +41,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-4.9
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-4.9 #:xbinutils avr-binutils)))
+(define-public avr-gcc-7
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -78,18 +79,9 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc" ,gcc-5)
+ `(("gcc" ,gcc-7)
,@(package-native-inputs xgcc))))))
-(define-public avr-gcc-5
- (package
- (inherit avr-gcc-4.9)
- (version (package-version gcc-5))
- (source (origin
- (inherit (package-source gcc-5))
- (patches (append (origin-patches (package-source gcc-5))
- (search-patches "gcc-cross-environment-variables.patch")))))))
-
(define (avr-libc avr-gcc)
(package
(name "avr-libc")
@@ -104,18 +96,7 @@
(build-system gnu-build-system)
(arguments
'(#:out-of-source? #t
- #:configure-flags '("--host=avr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'unpack 'fix-cpath
- (lambda _
- ;; C_INCLUDE_PATH and CPATH pose issues for cross-building,
- ;; leading to failures when building avr-libc on 64-bit systems.
- ;; Simply unsetting them allows the build to succeed because it
- ;; doesn't try to use any of the native system's headers.
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPATH")
- #t)))))
+ #:configure-flags '("--host=avr")))
(native-inputs `(("avr-binutils" ,avr-binutils)
("avr-gcc" ,avr-gcc)))
(home-page "https://www.nongnu.org/avr-libc/")
@@ -149,8 +130,7 @@ C++.")
(home-page (package-home-page avr-libc))
(license (package-license avr-gcc)))))
-(define-public avr-toolchain-4.9 (avr-toolchain avr-gcc-4.9))
-(define-public avr-toolchain-5 (avr-toolchain avr-gcc-5))
+(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
(define-public microscheme
(package
--
2.25.1
M
M
Malte Frank Gerdes wrote on 27 Oct 2020 20:14
Re: [bug#39918] [PATCH v2 0/2] gnu: avr-toolchain: Replace functions with package variables.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 39918@debbugs.gnu.org)
86imavlbvb.fsf_-_@gmail.com
Hi Arun,

i just wanted to try your patches, they don't apply anymore. I
recreated them on top of current master. It builds fine.


Malte
M
M
Malte Frank Gerdes wrote on 27 Oct 2020 20:15
[PATCH v2 1/2] * gnu/packages/avr.scm (avr-gcc-7, avr-toolchain-7): New variables.
(address . 39918@debbugs.gnu.org)(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)
20201027191529.12537-1-malte.f.gerdes@gmail.com
(avr-gcc-4.9, avr-gcc-5, avr-toolchain-4.9, avr-toolchain-5): Delete variables.
(avr-libc)[arguments]: Remove custom fix-cpath phase.
---
gnu/packages/avr.scm | 32 ++++++--------------------------
1 file changed, 6 insertions(+), 26 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 76af6fdef1..3925297253 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,8 +42,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-4.9
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-4.9 #:xbinutils avr-binutils)))
+(define-public avr-gcc-7
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -94,18 +95,9 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc@5" ,gcc-5)
+ `(("gcc@5" ,gcc-7)
,@(package-native-inputs xgcc))))))
-(define-public avr-gcc-5
- (package
- (inherit avr-gcc-4.9)
- (version (package-version gcc-5))
- (source (origin
- (inherit (package-source gcc-5))
- (patches (append (origin-patches (package-source gcc-5))
- (search-patches "gcc-cross-environment-variables.patch")))))))
-
(define (avr-libc avr-gcc)
(package
(name "avr-libc")
@@ -120,18 +112,7 @@
(build-system gnu-build-system)
(arguments
'(#:out-of-source? #t
- #:configure-flags '("--host=avr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'unpack 'fix-cpath
- (lambda _
- ;; C_INCLUDE_PATH and CPATH pose issues for cross-building,
- ;; leading to failures when building avr-libc on 64-bit systems.
- ;; Simply unsetting them allows the build to succeed because it
- ;; doesn't try to use any of the native system's headers.
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPATH")
- #t)))))
+ #:configure-flags '("--host=avr")))
(native-inputs `(("avr-binutils" ,avr-binutils)
("avr-gcc" ,avr-gcc)))
(home-page "https://www.nongnu.org/avr-libc/")
@@ -165,8 +146,7 @@ C++.")
(home-page (package-home-page avr-libc))
(license (package-license avr-gcc)))))
-(define-public avr-toolchain-4.9 (avr-toolchain avr-gcc-4.9))
-(define-public avr-toolchain-5 (avr-toolchain avr-gcc-5))
+(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
(define-public microscheme
(package
--
2.29.1
M
M
Malte Frank Gerdes wrote on 27 Oct 2020 20:15
[PATCH v2 2/2] * gnu/packages/avr.scm (avr-gcc-7): Rename to avr-gcc.
(address . 39918@debbugs.gnu.org)(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)
20201027191529.12537-2-malte.f.gerdes@gmail.com
(avr-libc): Replace function with variable.
(avr-toolchain): Replace function with variable.
---
gnu/packages/avr.scm | 43 ++++++++++++++++++++-----------------------
1 file changed, 20 insertions(+), 23 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 3925297253..c113707283 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -42,8 +42,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-7
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
+(define avr-gcc
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -95,10 +95,10 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc@5" ,gcc-7)
+ `(("gcc" ,gcc)
,@(package-native-inputs xgcc))))))
-(define (avr-libc avr-gcc)
+(define avr-libc
(package
(name "avr-libc")
(version "2.0.0")
@@ -123,30 +123,27 @@ for use with GCC on Atmel AVR microcontrollers.")
(license
(license:non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))
-(define (avr-toolchain avr-gcc)
+(define-public avr-toolchain
;; avr-libc checks the compiler version and passes "--enable-device-lib" for avr-gcc > 5.1.0.
;; It wouldn't install the library for atmega32u4 etc if we didn't use the corret avr-gcc.
- (let ((avr-libc (avr-libc avr-gcc)))
- (package
- (name "avr-toolchain")
- (version (package-version avr-gcc))
- (source #f)
- (build-system trivial-build-system)
- (arguments '(#:builder (begin (mkdir %output) #t)))
- (propagated-inputs
- `(("avrdude" ,avrdude)
- ("binutils" ,avr-binutils)
- ("gcc" ,avr-gcc)
- ("libc" ,avr-libc)))
- (synopsis "Complete GCC tool chain for AVR microcontroller development")
- (description "This package provides a complete GCC tool chain for AVR
+ (package
+ (name "avr-toolchain")
+ (version (package-version avr-gcc))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments '(#:builder (begin (mkdir %output) #t)))
+ (propagated-inputs
+ `(("avrdude" ,avrdude)
+ ("binutils" ,avr-binutils)
+ ("gcc" ,avr-gcc)
+ ("libc" ,avr-libc)))
+ (synopsis "Complete GCC tool chain for AVR microcontroller development")
+ (description "This package provides a complete GCC tool chain for AVR
microcontroller development. This includes the GCC AVR cross compiler and
avrdude for firmware flashing. The supported programming languages are C and
C++.")
- (home-page (package-home-page avr-libc))
- (license (package-license avr-gcc)))))
-
-(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
+ (home-page (package-home-page avr-libc))
+ (license (package-license avr-gcc))))
(define-public microscheme
(package
--
2.29.1
M
M
Malte Frank Gerdes wrote on 27 Oct 2020 20:30
[PATCH v3 1/2] gnu: avr-gcc: Update to 7.5.0.
(address . 39918@debbugs.gnu.org)(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)
20201027193019.15927-1-malte.f.gerdes@gmail.com
* gnu/packages/avr.scm (avr-gcc-7, avr-toolchain-7): New variables.
(avr-gcc-4.9, avr-gcc-5, avr-toolchain-4.9, avr-toolchain-5): Delete variables.
(avr-libc)[arguments]: Remove custom fix-cpath phase.
---
gnu/packages/avr.scm | 32 ++++++--------------------------
1 file changed, 6 insertions(+), 26 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 76af6fdef1..573a5e089c 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>;
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,8 +42,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-4.9
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-4.9 #:xbinutils avr-binutils)))
+(define-public avr-gcc-7
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -94,18 +95,9 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc@5" ,gcc-5)
+ `(("gcc" ,gcc-7)
,@(package-native-inputs xgcc))))))
-(define-public avr-gcc-5
- (package
- (inherit avr-gcc-4.9)
- (version (package-version gcc-5))
- (source (origin
- (inherit (package-source gcc-5))
- (patches (append (origin-patches (package-source gcc-5))
- (search-patches "gcc-cross-environment-variables.patch")))))))
-
(define (avr-libc avr-gcc)
(package
(name "avr-libc")
@@ -120,18 +112,7 @@
(build-system gnu-build-system)
(arguments
'(#:out-of-source? #t
- #:configure-flags '("--host=avr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'unpack 'fix-cpath
- (lambda _
- ;; C_INCLUDE_PATH and CPATH pose issues for cross-building,
- ;; leading to failures when building avr-libc on 64-bit systems.
- ;; Simply unsetting them allows the build to succeed because it
- ;; doesn't try to use any of the native system's headers.
- (unsetenv "C_INCLUDE_PATH")
- (unsetenv "CPATH")
- #t)))))
+ #:configure-flags '("--host=avr")))
(native-inputs `(("avr-binutils" ,avr-binutils)
("avr-gcc" ,avr-gcc)))
(home-page "https://www.nongnu.org/avr-libc/")
@@ -165,8 +146,7 @@ C++.")
(home-page (package-home-page avr-libc))
(license (package-license avr-gcc)))))
-(define-public avr-toolchain-4.9 (avr-toolchain avr-gcc-4.9))
-(define-public avr-toolchain-5 (avr-toolchain avr-gcc-5))
+(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
(define-public microscheme
(package
--
2.29.1
M
M
Malte Frank Gerdes wrote on 27 Oct 2020 20:30
[PATCH v3 2/2] gnu: avr-toolchain: Replace functions with package variables.
(address . 39918@debbugs.gnu.org)(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)
20201027193019.15927-2-malte.f.gerdes@gmail.com
* gnu/packages/avr.scm (avr-gcc-7): Rename to avr-gcc.
(avr-libc): Replace function with variable.
(avr-toolchain): Replace function with variable.
---
gnu/packages/avr.scm | 43 ++++++++++++++++++++-----------------------
1 file changed, 20 insertions(+), 23 deletions(-)

Toggle diff (77 lines)
diff --git a/gnu/packages/avr.scm b/gnu/packages/avr.scm
index 573a5e089c..4ad4bb03ba 100644
--- a/gnu/packages/avr.scm
+++ b/gnu/packages/avr.scm
@@ -42,8 +42,8 @@
(inherit (cross-binutils "avr"))
(name "avr-binutils")))
-(define-public avr-gcc-7
- (let ((xgcc (cross-gcc "avr" #:xgcc gcc-7 #:xbinutils avr-binutils)))
+(define avr-gcc
+ (let ((xgcc (cross-gcc "avr" #:xgcc gcc #:xbinutils avr-binutils)))
(package
(inherit xgcc)
(name "avr-gcc")
@@ -95,10 +95,10 @@
(variable "CROSS_LIBRARY_PATH")
(files '("avr/lib")))))
(native-inputs
- `(("gcc" ,gcc-7)
+ `(("gcc" ,gcc)
,@(package-native-inputs xgcc))))))
-(define (avr-libc avr-gcc)
+(define avr-libc
(package
(name "avr-libc")
(version "2.0.0")
@@ -123,30 +123,27 @@ for use with GCC on Atmel AVR microcontrollers.")
(license
(license:non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))
-(define (avr-toolchain avr-gcc)
+(define-public avr-toolchain
;; avr-libc checks the compiler version and passes "--enable-device-lib" for avr-gcc > 5.1.0.
;; It wouldn't install the library for atmega32u4 etc if we didn't use the corret avr-gcc.
- (let ((avr-libc (avr-libc avr-gcc)))
- (package
- (name "avr-toolchain")
- (version (package-version avr-gcc))
- (source #f)
- (build-system trivial-build-system)
- (arguments '(#:builder (begin (mkdir %output) #t)))
- (propagated-inputs
- `(("avrdude" ,avrdude)
- ("binutils" ,avr-binutils)
- ("gcc" ,avr-gcc)
- ("libc" ,avr-libc)))
- (synopsis "Complete GCC tool chain for AVR microcontroller development")
- (description "This package provides a complete GCC tool chain for AVR
+ (package
+ (name "avr-toolchain")
+ (version (package-version avr-gcc))
+ (source #f)
+ (build-system trivial-build-system)
+ (arguments '(#:builder (begin (mkdir %output) #t)))
+ (propagated-inputs
+ `(("avrdude" ,avrdude)
+ ("binutils" ,avr-binutils)
+ ("gcc" ,avr-gcc)
+ ("libc" ,avr-libc)))
+ (synopsis "Complete GCC tool chain for AVR microcontroller development")
+ (description "This package provides a complete GCC tool chain for AVR
microcontroller development. This includes the GCC AVR cross compiler and
avrdude for firmware flashing. The supported programming languages are C and
C++.")
- (home-page (package-home-page avr-libc))
- (license (package-license avr-gcc)))))
-
-(define-public avr-toolchain-7 (avr-toolchain avr-gcc-7))
+ (home-page (package-home-page avr-libc))
+ (license (package-license avr-gcc))))
(define-public microscheme
(package
--
2.29.1
A
A
Arun Isaac wrote on 30 Oct 2020 08:03
Re: [bug#39918] [PATCH v2 0/2] gnu: avr-toolchain: Replace functions with package variables.
(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)(address . 39918@debbugs.gnu.org)
871rhgjiur.fsf@systemreboot.net
Hi Malte,

Thank you for your feedback! This patchset has been stuck so long
because I didn't know if it was ok to collapse the package functions
into package variables, and whether we really needed all the old
versions. I'll try raising this on guix-devel.

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl+buswbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzv24IAJoCJG+WGNJFV5ELjtPm
PKcPLqc7W25C/Ev7j7Myfld3Zr72UwRhW6+SHFZsVwkRB5/JxloQi1yiWps6hKki
8B+ZqdFA0TmXpMKK19jdfRIW5yhAKEHfkOZBJ4u2pYDWENkrmukE8LzvpTWcUAu9
QI8XBqRAM3LUBadXisTx2zDzbut2hMI5oE97sRWtFgX4LzlAL7/Y5EO1ySPy1igk
on9yS64CDHomTVoU7O40Ob1JgQBL6lrATBpUPFlfFV9XXEH5d7BDIHdtUQDMj4qm
9ERxb3B+lmcjP/EAEqGvJ0rgjY+nCIwDnpabUf7Vc4tmg+khSgKgaUaUfnJpC4TX
7lM=
=gzwb
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 1 Nov 2020 20:19
(name . Malte Frank Gerdes)(address . malte.f.gerdes@gmail.com)(address . 39918-done@debbugs.gnu.org)
87y2jklwav.fsf@systemreboot.net
Hi Malte,

I've pushed this patchset to master after consulting with guix-devel.

Cheers!
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl+fCjgbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzYh8H/0iKtPgolgKPcIFCiGUe
x65ebq95vgfZzgWoe3qlWG5ZE/FshdXAoohcC5qyMxn9fwduQYFHrPgptEl6gi/s
mhq/lx1v97RRcdhL11S51QL7U9f/eLTsFpHZ6IqbUK0uR07g0tNoX/Cog/ghE3Dw
M4boxshyqD5xPrasgDZWv4XYRIrNHxCoDb80alF+XwksgiMA1JXNhuTdX1nAXURF
XUmC0SSMVgZ8yIBrRYnozZ1R0p/QSQkqJdMvJ00rIxEN7ptsMlYrYJmtD/HYLPz5
YjnZ9rQdJZ73mdjZTDxT5jw2vs9BgUExaJJfyy2fmn1bMgMMNZ1z5zW/otPjm1LD
9Hk=
=B8dy
-----END PGP SIGNATURE-----

Closed
?