[PATCH] website: Update Guix manifest.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • sirgazil
Owner
unassigned
Submitted by
sirgazil
Severity
normal
S
S
sirgazil wrote on 15 Feb 2020 23:22
(address . guix-patches@gnu.org)(name . sirgazil)(address . sirgazil@zoho.com)
20200215222222.15081-1-sirgazil@zoho.com
* website/README (Development environment): Use the manifest.
* website/guix.packages: Use specifications->manifest.
---
website/README | 12 ++++++++----
website/guix.packages | 26 +++++++++++++-------------
2 files changed, 21 insertions(+), 17 deletions(-)

Toggle diff (63 lines)
diff --git a/website/README b/website/README
index d3a3a78..180eee9 100644
--- a/website/README
+++ b/website/README
@@ -9,14 +9,18 @@ files of the website.
* Development environment
-This website is developed using the [[https://www.gnu.org/software/guix/download/][GNU Guix]] package manager. Run the
-following command to install all the software needed to build the
-website:
+Assuming you already have [[https://www.gnu.org/software/guix/download/][GNU Guix]] installed, you can use the manifest
+file provided with the source, ~guix.packages~, to create a separate
+Guix profile with all the software required to work on the website.
+For instance:
#+BEGIN_EXAMPLE
-$ guix package -i git glibc-locales gnutls guile guile-json guile-syntax-highlight guix haunt
+$ guix package -m guix.packages -p path/to/development/profiledir/profile
#+END_EXAMPLE
+See [[https://guix.gnu.org/cookbook/en/html_node/Guix-Profiles-in-Practice.html#Guix-Profiles-in-Practice][Guix Profiles in Practice]] for more information about creating and
+using profiles.
+
* Running the website
To try out the website locally while you work on it, run the following
diff --git a/website/guix.packages b/website/guix.packages
index 386307c..2f05e65 100644
--- a/website/guix.packages
+++ b/website/guix.packages
@@ -1,16 +1,16 @@
-;;; Packages required to develop the website.
-;;; (See guix package --manifest option for more details on this file).
+;;; This file is a GNU Guix manifest file. You can use it with the
+;;; "guix package" command to install all the packages necessary to
+;;; develop the website.
-(use-modules (guix profiles)
- (gnu packages))
+(use-modules (gnu packages))
-(define dev-packages
- (list "glibc-locales"
- "guile@2.2"
- "guile-syntax-highlight"
- "guix"
- "haunt"))
-
-
-(map specification->package dev-packages)
+(specifications->manifest
+ (list "git"
+ "glibc-locales"
+ "gnutls"
+ "guile"
+ "guile-json"
+ "guile-syntax-highlight"
+ "guix"
+ "haunt"))
--
2.25.0
B
B
Brett Gilio wrote on 25 Jul 2020 03:54
(name . sirgazil)(address . sirgazil@zoho.com)(address . 39625@debbugs.gnu.org)
87h7tw4awm.fsf@gnu.org
sirgazil <sirgazil@zoho.com> writes:

Toggle quote (5 lines)
>
> -(use-modules (guix profiles)
> - (gnu packages))
> +(use-modules (gnu packages))

I think manifests require the (guix profiles) module.

Toggle quote (21 lines)
>
>
> -(define dev-packages
> - (list "glibc-locales"
> - "guile@2.2"
> - "guile-syntax-highlight"
> - "guix"
> - "haunt"))
> -
> -
> -(map specification->package dev-packages)
> +(specifications->manifest
> + (list "git"
> + "glibc-locales"
> + "gnutls"
> + "guile"
> + "guile-json"
> + "guile-syntax-highlight"
> + "guix"
> + "haunt"))

Could I inquire why you opted to remove the function for dev-packages?
:)

Thanks!

Brett Gilio
S
S
sirgazil wrote on 26 Jul 2020 18:03
(name . Brett Gilio)(address . brettg@gnu.org)(name . 39625)(address . 39625@debbugs.gnu.org)
1738bdd38a3.befad90566115.7484601208603565376@zoho.com
---- On Fri, 24 Jul 2020 20:54:10 -0500 Brett Gilio <brettg@gnu.org> wrote ----
> sirgazil <sirgazil@zoho.com> writes:
>
> >
> > -(use-modules (guix profiles)
> > - (gnu packages))
> > +(use-modules (gnu packages))
>
> I think manifests require the (guix profiles) module.

Hmm, my manifests work without importing "(guix profiles)".

This was a long time ago, but the reason I imported that module is that in the beginning I was thinking on providing a manifest that would create a profile generation that was the union of the packages installed in the current user profile plus the packages required to develop the website. I was going to use "(profile-manifest %user-profile-directory)" for that, which comes from "(guix profiles)". But that was before I knew you could use different Guix profiles for different projects instead of polluting your user profile, so I changed my mind and forgot to delete "(guix profiles)".


> > -(define dev-packages
> > - (list "glibc-locales"
> > - "guile@2.2"
> > - "guile-syntax-highlight"
> > - "guix"
> > - "haunt"))
> > -
> > -
> > -(map specification->package dev-packages)
> > +(specifications->manifest
> > + (list "git"
> > + "glibc-locales"
> > + "gnutls"
> > + "guile"
> > + "guile-json"
> > + "guile-syntax-highlight"
> > + "guix"
> > + "haunt"))
>
> Could I inquire why you opted to remove the function for dev-packages?
> :)

I was thinking on separating package requirements with variables such as "dev-packages", "test-packages", "production-packages", etc., but then I thought it was unnecessary at this point because the website does not currently have that many requirements...
S
S
sirgazil wrote on 20 Oct 2020 02:14
[PATCH] website: Update Guix manifest.
(name . 39625-done)(address . 39625-done@debbugs.gnu.org)
175435b595f.e6dd906175508.9195246225100101591@zoho.com
Spoiled patch. There is a recent update to the website manifest (see commit 05e384e811ab58f8d7f37ab92cf9dac416317af5).
Closed
?