[PATCH] Add rticles R package

  • Done
  • quality assurance status badge
Details
3 participants
  • Rafael Luque Leiva
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Rafael Luque Leiva
Severity
normal
R
R
Rafael Luque Leiva wrote on 5 Feb 2020 17:07
(address . guix-patches@gnu.org)(name . Rafael Luque Leiva)(address . rafael.luque@osoco.es)
20200205160723.6098-1-rafael.luque@osoco.es
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 58ceed06d0..c31d9dd8a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
+;;; Copyright © 2020 Rafael Luque Leiva <rafael.luque@osoco.es>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -79,6 +80,32 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xorg))
+(define-public r-rticles
+ (package
+ (name "r-rticles")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rticles" version))
+ (sha256
+ (base32
+ "1377fib4asazhhki4aajvld0wa35vd3zjvyl3lf2hjm2qk3vyak7"))))
+ (properties `((upstream-name . "rticles")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-xfun" ,r-xfun)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/rstudio/rticles")
+ (synopsis "Article Formats for R Markdown")
+ (description
+ "This package provides a suite of custom R Markdown formats and templates
+for authoring journal articles and conference submissions.")
+ (license license:gpl3)))
+
(define-public r-clipr
(package
(name "r-clipr")
--
2.25.0
Z
Z
zimoun wrote on 7 Feb 2020 14:42
(name . Rafael Luque Leiva)(address . rafael.luque@osoco.es)(address . 39442@debbugs.gnu.org)
CAJ3okZ1D7X1wncbFOERQt7X-+CTdDW+QssLrjzNcGatqET8d7A@mail.gmail.com
Dear Rafael,

Thank you for your contribution.


Two minor things to be compliant. :-)


Could you please add a commit message along these lines:

gnu: Add r-rticles.

* gnu/packages/cran.scm (r-rticles): New variable.

?

Could you use the indenting style?



Note that if you use Emacs, the coding style is enforced and there is
(yas) snippets doing the commit message job for you. ;-)



Please let us know. :-)

All the best,
simon
R
R
Ricardo Wurmus wrote on 4 Aug 2020 16:22
[PATCH] Add rticles R package
(address . rafael.luque@osoco.es)(address . 39442-done@debbugs.gnu.org)
87ft92fq38.fsf@elephly.net
Hi Rafael,

thank you for your patch!
I just applied it with the changes that simon suggested.

--
Ricardo
Closed
?