[PATCH] gnu: Add FIM.

  • Done
  • quality assurance status badge
Details
3 participants
  • Jonathan Brielmaier
  • Jakub K?dzio?ka
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 31 Jan 2020 23:51
(address . guix-patches@gnu.org)
0be1c20da4fab4533541600882fc383ab2f59a84.1580511103.git.leo@famulari.name
* gnu/packages/image-viewers.scm (fim): New variable.
---
gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (85 lines)
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 85d3a153e7..51f584dfbb 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -40,11 +41,13 @@
#:use-module (guix build-system python)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
@@ -56,6 +59,7 @@
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages maths)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
@@ -63,7 +67,10 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
#:use-module (gnu packages))
@@ -596,3 +603,37 @@ with tiling window managers. Features include:
@end itemize\n")
(home-page "https://github.com/eXeC64/imv")
(license license:expat)))
+
+(define-public fim
+ (package
+ (name "fim")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.savannah.nongnu.org/releases/"
+ "fbi-improved/fim-" version "-trunk.tar.gz"))
+ (sha256
+ (base32
+ "124b7c4flx5ygmy5sqq0gpvxqzafnknbcj6f45ddnbdxik9lazzp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("flex" ,flex)
+ ("bison" ,bison)
+ ("perl" ,perl)))
+ (inputs
+ `(("aalib" ,aalib)
+ ("alsa-lib" ,alsa-lib)
+ ("giflib" ,giflib)
+ ("libexif" ,libexif)
+ ("libjpeg" ,libjpeg-8)
+ ("libpng" ,libpng)
+ ("libtiff" ,libtiff)
+ ("libxrandr" ,libxrandr)
+ ("libxrender" ,libxrender)
+ ("readline" ,readline)
+ ("sdl" ,sdl)))
+ (synopsis "Image viewer with framebuffer support")
+ (description "FIM is an image viewer that supports both X and the Linux
+framebuffer.")
+ (home-page "https://www.nongnu.org/fbi-improved/")
+ (license license:gpl2+)))
--
2.25.0
J
J
Jonathan Brielmaier wrote on 1 Feb 2020 00:27
1580513229.1958.3.camel@Nokia-N900
----- Ursprüngliche Mitteilung -----
Toggle quote (87 lines)
> * gnu/packages/image-viewers.scm (fim): New variable.
> ---
>  gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/image-viewers.scm
> b/gnu/packages/image-viewers.scm index 85d3a153e7..51f584dfbb 100644
> --- a/gnu/packages/image-viewers.scm
> +++ b/gnu/packages/image-viewers.scm
> @@ -13,6 +13,7 @@
>  ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
>  ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
>  ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
> +;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -40,11 +41,13 @@
>      #:use-module (guix build-system python)
>      #:use-module (gnu packages autotools)
>      #:use-module (gnu packages algebra)
> +  #:use-module (gnu packages bison)
>      #:use-module (gnu packages boost)
>      #:use-module (gnu packages check)
>      #:use-module (gnu packages compression)
>      #:use-module (gnu packages curl)
>      #:use-module (gnu packages documentation)
> +  #:use-module (gnu packages flex)
>      #:use-module (gnu packages fontutils)
>      #:use-module (gnu packages freedesktop)
>      #:use-module (gnu packages gettext)
> @@ -56,6 +59,7 @@
>      #:use-module (gnu packages graphics)
>      #:use-module (gnu packages image)
>      #:use-module (gnu packages imagemagick)
> +  #:use-module (gnu packages linux)
>      #:use-module (gnu packages maths)
>      #:use-module (gnu packages perl)
>      #:use-module (gnu packages perl-check)
> @@ -63,7 +67,10 @@
>      #:use-module (gnu packages pkg-config)
>      #:use-module (gnu packages python)
>      #:use-module (gnu packages python-xyz)
> +  #:use-module (gnu packages readline)
> +  #:use-module (gnu packages sdl)
>      #:use-module (gnu packages qt)
> +  #:use-module (gnu packages video)
>      #:use-module (gnu packages xdisorg)
>      #:use-module (gnu packages xorg)
>      #:use-module (gnu packages))
> @@ -596,3 +603,37 @@ with tiling window managers.  Features include:
>  @end itemize\n")
>          (home-page "https://github.com/eXeC64/imv")
>          (license license:expat)))
> +
> +(define-public fim
> +  (package
> +      (name "fim")
> +      (version "0.6")
> +      (source (origin
> +                          (method url-fetch)
> +                          (uri (string-append
> "http://download.savannah.nongnu.org/releases/" +                                           
>                    "fbi-improved/fim-" version "-trunk.tar.gz")) +                       
> (sha256 +                            (base32
> +                           
> "124b7c4flx5ygmy5sqq0gpvxqzafnknbcj6f45ddnbdxik9lazzp")))) +   
> (build-system gnu-build-system) +      (native-inputs
> +        `(("flex" ,flex)
> +            ("bison" ,bison)
> +            ("perl" ,perl)))
> +      (inputs
> +        `(("aalib" ,aalib)
> +            ("alsa-lib" ,alsa-lib)
> +            ("giflib" ,giflib)
> +            ("libexif" ,libexif)
> +            ("libjpeg" ,libjpeg-8)
> +            ("libpng" ,libpng)
> +            ("libtiff" ,libtiff)
> +            ("libxrandr" ,libxrandr)
> +            ("libxrender" ,libxrender)
> +            ("readline" ,readline)
> +            ("sdl" ,sdl)))
> +      (synopsis "Image viewer with framebuffer support")
> +      (description "FIM is an image viewer that supports both X and the
> Linux +framebuffer.")

Maybe add to the description that it's quite leightweight still supporting many image formats.

Toggle quote (8 lines)
> +      (license license:gpl2+)))
> --
> 2.25.0
>
>
>
>
L
L
Leo Famulari wrote on 2 Feb 2020 07:05
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 39378@debbugs.gnu.org)
20200202060537.GB13786@jasmine.lan
On Sat, Feb 01, 2020 at 12:27:09AM +0100, Jonathan Brielmaier wrote:
Toggle quote (6 lines)
> > +� � � (synopsis "Image viewer with framebuffer support")
> > +� � � (description "FIM is an image viewer that supports both X and the
> > Linux +framebuffer.")
>
> Maybe add to the description that it's quite leightweight still supporting many image formats.

Perhaps, but I measured some of the image viewers int the same module,
and FIM is in the middle of the pack in terms of being lightweight.
J
J
Jakub K?dzio?ka wrote on 10 Jul 2020 23:38
Re: [PATCH] gnu: Add FIM.
(name . Leo Famulari)(address . leo@famulari.name)(address . guix-patches@gnu.org)
20200710213802.djp7swkyypxqesyv@gravity
On Fri, Jan 31, 2020 at 05:51:51PM -0500, Leo Famulari wrote:
Toggle quote (5 lines)
> * gnu/packages/image-viewers.scm (fim): New variable.
> ---
> gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
> 1 file changed, 41 insertions(+)

Thanks!

Toggle quote (7 lines)
> + (inputs
> + `(("aalib" ,aalib)
> + ("alsa-lib" ,alsa-lib)
> + ("giflib" ,giflib)
> + ("libexif" ,libexif)
> + ("libjpeg" ,libjpeg-8)

libjpeg-8 doesn't exist anymore. The package builds fine when this is
replaced by libjpeg-turbo, and it seems to work, too, in my limited
testing. Is such a change reasonable in your opinion?

From the build log:

| use 'inkscape' for SVG files : no
| use 'fig2dev' for FIG files : no
| JP2 (JPEG-2K) file support (JasPer) : no

Is there a specific reason we don't want support for these formats?

Regards,
Jakub K?dzio?ka
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8I37oACgkQ4xWnWEYT
FWRBuBAA3ZaXhpAUt8fF5Z9WsCctDhRCPwKgDG390hKW7CPkqX99Hrsqrx7jTr/9
5JlyyyA7iUuHKGG7ZXs+0flS5ModkCzW+J8N6mnGkqvGjyGzjUZQ/qlDTRm2x3wR
iJR1F+6CJL3DvTbTAx76qGcDc23T0najOnk+LO2ktGVBCd3T29TJtv4QuNp1a4IN
1JR8qBoMMh5mABk+KWtK93vcvDN0cqRDxHdSRHd7e25FDtwPqbpQLSO4lsCK9eDX
jx+zWi5Z0cEDvX5jzC1vrCE8C/173bz4CLp8g5vO04EujCmigjAjgyVsmSfqAmSo
+98NsUoSbLTTCeEF01d/xIEdYR/uBIhszJbWf+dX48Qc1M1v33spjiQ0c8hrrftS
Tu+g1dsMPpMVdJhYeSRf7k+T6PCiHsGto3PyBxlqmTaZ4iOx4ZX63Z3UQbNb+O9k
u6cRdA3fQ8bDFBGufOsjEO5/H0gbv30adIbzgh0hVIgWvbzxIVZ8Nxlldn8pnAxt
8ucHFjgvUTkCcTH7qL+wgZv2syXpTWUWF+q5sxCoM2l8jIByY3Vpx33i2ur/8MaP
WnP9IFfBXYWyVHS+ZnnxvhvONNypfwjG2qKzrpt/6WRTmb9xmUQji5LtPyGfT1Ue
O2PhRuZXJyMnF/0XnVmvR7bQjjB9nxgxqDHzspFZXVuPxwiUgrc=
=eLI0
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 29 Dec 2021 20:40
(address . 39378-done@debbugs.gnu.org)
Ycy5rBOuHtO/QGJM@jasmine.lan
I decided not to continue with this patch, so I'm closing this ticket.
Closed
?