[PATCH] gnu: Add ghc-http-reverse-proxy.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Alexandru-Sergiu Marton
  • Christopher Baines
Owner
unassigned
Submitted by
Alexandru-Sergiu Marton
Severity
normal
A
A
Alexandru-Sergiu Marton wrote on 3 Jan 2020 12:28
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
20200103112800.18791-1-brown121407@member.fsf.org
* gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable.
---
gnu/packages/haskell-web.scm | 43 ++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..f0dd72cdcf 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -377,6 +378,48 @@ contents of the HTTP connection. It also provides higher-level functions
which allow you to avoid direct usage of conduits.")
(license license:bsd-3)))
+(define-public ghc-http-reverse-proxy
+ (package
+ (name "ghc-http-reverse-proxy")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/http-reverse-proxy/"
+ "http-reverse-proxy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1a6i5njf85b2lhg8m83njagcf09wih5q2irnyb2890s724qr277v"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-network" ,ghc-network)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-wai-logger" ,ghc-wai-logger)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-http-conduit" ,ghc-http-conduit)))
+ (home-page
+ "https://github.com/fpco/http-reverse-proxy")
+ (synopsis
+ "Reverse proxy HTTP requests, either over raw sockets or with WAI")
+ (description
+ "Provides a simple means of reverse-proxying HTTP requests. The raw
+approach uses the same technique as leveraged by keter, whereas the WAI
+approach performs full request/response parsing via WAI and http-conduit.")
+ (license license:bsd-3)))
+
(define-public ghc-wai
(package
(name "ghc-wai")
--
2.24.1
B
B
Brett Gilio wrote on 4 Jan 2020 05:29
(name . Alexandru-Sergiu Marton)(address . brown121407@gmail.com)
87mub3zvxs.fsf@gnu.org
Alexandru-Sergiu Marton <brown121407@gmail.com> writes:

Toggle quote (67 lines)
> * gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable.
> ---
> gnu/packages/haskell-web.scm | 43 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
>
> diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
> index 5888e8542e..f0dd72cdcf 100644
> --- a/gnu/packages/haskell-web.scm
> +++ b/gnu/packages/haskell-web.scm
> @@ -7,6 +7,7 @@
> ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
> ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
> +;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -377,6 +378,48 @@ contents of the HTTP connection. It also provides higher-level functions
> which allow you to avoid direct usage of conduits.")
> (license license:bsd-3)))
>
> +(define-public ghc-http-reverse-proxy
> + (package
> + (name "ghc-http-reverse-proxy")
> + (version "0.6.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://hackage.haskell.org/package/http-reverse-proxy/"
> + "http-reverse-proxy-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1a6i5njf85b2lhg8m83njagcf09wih5q2irnyb2890s724qr277v"))))
> + (build-system haskell-build-system)
> + (inputs
> + `(("ghc-case-insensitive" ,ghc-case-insensitive)
> + ("ghc-http-types" ,ghc-http-types)
> + ("ghc-word8" ,ghc-word8)
> + ("ghc-blaze-builder" ,ghc-blaze-builder)
> + ("ghc-http-client" ,ghc-http-client)
> + ("ghc-wai" ,ghc-wai)
> + ("ghc-network" ,ghc-network)
> + ("ghc-conduit" ,ghc-conduit)
> + ("ghc-conduit-extra" ,ghc-conduit-extra)
> + ("ghc-wai-logger" ,ghc-wai-logger)
> + ("ghc-resourcet" ,ghc-resourcet)
> + ("ghc-unliftio" ,ghc-unliftio)
> + ("ghc-streaming-commons" ,ghc-streaming-commons)))
> + (native-inputs
> + `(("ghc-hspec" ,ghc-hspec)
> + ("ghc-warp" ,ghc-warp)
> + ("ghc-http-conduit" ,ghc-http-conduit)))
> + (home-page
> + "https://github.com/fpco/http-reverse-proxy")
> + (synopsis
> + "Reverse proxy HTTP requests, either over raw sockets or with WAI")
> + (description
> + "Provides a simple means of reverse-proxying HTTP requests. The raw
> +approach uses the same technique as leveraged by keter, whereas the WAI
> +approach performs full request/response parsing via WAI and http-conduit.")
> + (license license:bsd-3)))
> +
> (define-public ghc-wai
> (package
> (name "ghc-wai")

Hey again! Similarly with this one, we need to ensure that we are double
spacing after each punctuation in the description. :) Thanks for dealing
with our pickiness!

--
Brett M. Gilio
GNU Guix, Contributor | GNU Project, Webmaster
[DFC0 C7F7 9EE6 0CA7 AE55 5E19 6722 43C4 A03F 0EEE]
<brettg@gnu.org> <brettg@posteo.net>
A
A
Alexandru-Sergiu Marton wrote on 4 Jan 2020 09:52
[PATCH v2] gnu: Add ghc-http-reverse-proxy.
(address . 38891@debbugs.gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@member.fsf.org)
20200104085206.5425-1-brown121407@member.fsf.org
* gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable.
---
Fix linter errors.

gnu/packages/haskell-web.scm | 43 ++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..bf96ca88ca 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -377,6 +378,48 @@ contents of the HTTP connection. It also provides higher-level functions
which allow you to avoid direct usage of conduits.")
(license license:bsd-3)))
+(define-public ghc-http-reverse-proxy
+ (package
+ (name "ghc-http-reverse-proxy")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/http-reverse-proxy/"
+ "http-reverse-proxy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1a6i5njf85b2lhg8m83njagcf09wih5q2irnyb2890s724qr277v"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-word8" ,ghc-word8)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-network" ,ghc-network)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-wai-logger" ,ghc-wai-logger)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-http-conduit" ,ghc-http-conduit)))
+ (home-page
+ "https://github.com/fpco/http-reverse-proxy")
+ (synopsis
+ "Reverse proxy HTTP requests, either over raw sockets or with WAI")
+ (description
+ "Provides a simple means of reverse-proxying HTTP requests. The raw
+approach uses the same technique as leveraged by keter, whereas the WAI
+approach performs full request/response parsing via WAI and http-conduit.")
+ (license license:bsd-3)))
+
(define-public ghc-wai
(package
(name "ghc-wai")
--
2.24.1
C
C
Christopher Baines wrote on 20 Nov 2020 21:34
(name . Alexandru-Sergiu Marton)(address . brown121407@gmail.com)(address . 38891-done@debbugs.gnu.org)
87mtzbkbsu.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@gmail.com> writes:

Toggle quote (69 lines)
> * gnu/packages/haskell-web.scm (ghc-http-reverse-proxy): New variable.
> ---
> Fix linter errors.
>
> gnu/packages/haskell-web.scm | 43 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 43 insertions(+)
>
> diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
> index 5888e8542e..bf96ca88ca 100644
> --- a/gnu/packages/haskell-web.scm
> +++ b/gnu/packages/haskell-web.scm
> @@ -7,6 +7,7 @@
> ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
> ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
> +;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -377,6 +378,48 @@ contents of the HTTP connection. It also provides higher-level functions
> which allow you to avoid direct usage of conduits.")
> (license license:bsd-3)))
>
> +(define-public ghc-http-reverse-proxy
> + (package
> + (name "ghc-http-reverse-proxy")
> + (version "0.6.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://hackage.haskell.org/package/http-reverse-proxy/"
> + "http-reverse-proxy-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1a6i5njf85b2lhg8m83njagcf09wih5q2irnyb2890s724qr277v"))))
> + (build-system haskell-build-system)
> + (inputs
> + `(("ghc-case-insensitive" ,ghc-case-insensitive)
> + ("ghc-http-types" ,ghc-http-types)
> + ("ghc-word8" ,ghc-word8)
> + ("ghc-blaze-builder" ,ghc-blaze-builder)
> + ("ghc-http-client" ,ghc-http-client)
> + ("ghc-wai" ,ghc-wai)
> + ("ghc-network" ,ghc-network)
> + ("ghc-conduit" ,ghc-conduit)
> + ("ghc-conduit-extra" ,ghc-conduit-extra)
> + ("ghc-wai-logger" ,ghc-wai-logger)
> + ("ghc-resourcet" ,ghc-resourcet)
> + ("ghc-unliftio" ,ghc-unliftio)
> + ("ghc-streaming-commons" ,ghc-streaming-commons)))
> + (native-inputs
> + `(("ghc-hspec" ,ghc-hspec)
> + ("ghc-warp" ,ghc-warp)
> + ("ghc-http-conduit" ,ghc-http-conduit)))
> + (home-page
> + "https://github.com/fpco/http-reverse-proxy")
> + (synopsis
> + "Reverse proxy HTTP requests, either over raw sockets or with WAI")
> + (description
> + "Provides a simple means of reverse-proxying HTTP requests. The raw
> +approach uses the same technique as leveraged by keter, whereas the WAI
> +approach performs full request/response parsing via WAI and http-conduit.")
> + (license license:bsd-3)))
> +
> (define-public ghc-wai
> (package
> (name "ghc-wai")

Looks good to me, sorry for the long delay!

I've gone ahead and pushed to master as
7e5580bd81ca6586268fe49fcf4aec0153d160d4.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+4KEFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xe/eRAAsDt97oWOHzKI+qtUul89x9EsWHlP/iFQ
vjhyeDScBERrrHC4UCrB4zNro8FeLqg69dpj8D5UuL9wDQZ+Z6tmrXwvxSIbZDqw
cBw0JkAsLDNFIB6H4EZbGn32+oNuX21xax6DAPCBj3HbePt+2crLxbZGARdlMCkU
n0QpPDWYv8XslTWL4eCf4t5TilBX8XpyJyNQi1PRW5OqmmioZAtwFWD6pelEhJsX
FMmSoUA3KKKXqwTOpVOPqRD+KsvBWdG1pF8SFMspzG51UNGKSQTVbDt884LRjk7y
ruFwdjbRPQy2f2BWasLTsFwWLZosZo11/Fv+Fo6IyKxzggpWjjfjxvuVjJMG4ADy
zcEu+l+ute000WJx4sxAZ7/KG9mv5qT8E4xUm93i8WSxtk4/z2xJnAqWbfBNsQMR
88RSeRVHMHwizIEWyPxx9PFyBU83K1HX/lp31w5yzk5iACwy5cw0i8KE8KwUDA7z
X1RtrUNYTn3mTnYVWo0hSXUhJH+TJKBgt9Kab6DiLxcBrhSW1Nri3ALPlq+bPifl
bPD2is/MmdUENbOujNH0+SGZLMsE50nrIaLMX9om8gujNkMTojufyZ15a5KVyx07
hcFe8YpLXeejqkINdPu+M0CprEe1kO46eolHFcUk4+qWqphuoX7X6RTQKHZA8yA/
04aXFaDHwGI=
=G8rX
-----END PGP SIGNATURE-----

Closed
?