[PATCH] gnu: Add scanbd.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Maxim Cournoyer
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 24 Nov 2019 01:42
(address . guix-patches@gnu.org)
20191124004219.16428-1-me@tobias.gr
* gnu/packages/scanner.scm (scanbd): New public variable.
---
gnu/packages/scanner.scm | 65 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)

Toggle diff (89 lines)
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 98f7fd203a..25389f19aa 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -24,10 +24,13 @@
#:use-module (gnu packages)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages libusb)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages textutils)
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -154,6 +157,68 @@ proving access to any raster image scanner hardware (flatbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
package contains the library and drivers.")))
+(define-public scanbd
+ (package
+ (name "scanbd")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/scanbd/releases/"
+ "scanbd-" version ".tgz"))
+ (sha256
+ (base32 "0pvy4qirfjdfm8aj6x5rkbgl7hk3jfa2s21qkk8ic5dqfjjab75n"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-debug"
+ "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (conf (string-append out "/etc/scanbd")))
+ (apply invoke "make" "install"
+ ;; Install example configuration to the store, not /etc.
+ ;; These don't inherit from each other, so we need both.
+ (string-append "scanbdconfdir=" conf)
+ (string-append "scannerconfdir=" conf "/scanner.d")
+ make-flags)
+ #t)))
+ (add-after 'install 'install-extra-documentation
+ ;; The README provides more detailed set-up instructions than the
+ ;; man page.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/"
+ ,name "-" ,version)))
+ (install-file "doc/README.txt" doc)
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus" ,dbus)
+ ("libconfuse" ,libconfuse)
+ ("sane-backends" ,sane-backends)
+ ("udev" ,eudev)))
+ (home-page "https://scanbd.sourceforge.io")
+ (synopsis "Configurable scanner button monitor")
+ (description
+ "Scanbd stands for scanner button daemon. It regulary polls scanners for
+pressed buttons, function knob changes, or other events such as (un)plugging
+the scanner or inserting and removing paper. Then it performs the desired
+action(s) such as saving, copying, or e-mailing the image.
+
+Actions can be fully customised through scripts, based on any combination of
+switch or knob settings. Events are also signaled over D-Bus and scans can
+even be triggered over D-Bus from foreign applications.
+
+Scanbd talks to scanners through the @acronym{SANE, Scanner Access Now Easy}
+back-end library. This means that it supports almost all existing scanners,
+provided the driver also exposes the buttons.")
+ (license licence:gpl2+)))
+
(define-public xsane
(package
(name "xsane")
--
2.23.0
L
L
Ludovic Courtès wrote on 11 Dec 2019 11:58
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 38355@debbugs.gnu.org)
877e33ku2b.fsf@gnu.org
Hi!

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (2 lines)
> * gnu/packages/scanner.scm (scanbd): New public variable.

LGTM! :-)

Ludo’.
M
M
Maxim Cournoyer wrote on 10 Jan 2021 23:09
Re: bug#38355: [PATCH] gnu: Add scanbd.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87k0sk4f75.fsf_-_@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (10 lines)
> Hi!
>
> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>
>> * gnu/packages/scanner.scm (scanbd): New public variable.
>
> LGTM! :-)
>
> Ludo’.

Ping! It seems it hasn't reached the repo yet :-)

Maxim
M
M
Maxim Cournoyer wrote on 3 Aug 2021 21:16
(name . Ludovic Courtès)(address . ludo@gnu.org)
87a6ly9w4c.fsf_-_@gmail.com
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (18 lines)
> Hello,
>
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi!
>>
>> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>>
>>> * gnu/packages/scanner.scm (scanbd): New public variable.
>>
>> LGTM! :-)
>>
>> Ludo’.
>
> Ping! It seems it hasn't reached the repo yet :-)
>
> Maxim

I added zlib as an input (it wouldn't build otherwise), fixed a typo,
and pushed as c40516a567.

Thanks!

Closing.

Maxim
Closed
?