[PATCH] gnu: Add x42-plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 11:55
(name . Guix patches)(address . guix-patches@gnu.org)
452ecadc3842a20e4e6c768649855525@posteo.net
NOTE: this patch depends on

From ee2e983068b3dd11aaed7c703388904749e77a44 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:54:00 +0000
Subject: [PATCH] gnu: Add x42-plugins.

* gnu/packages/music.scm: (x42-plugins): New variable.
---
gnu/packages/music.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..a6caf4d0ff 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,57 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public x42-plugins
+ (package
+ (name "x42-plugins")
+ (version "20191013")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://gareus.org/misc/x42-plugins/x42-plugins-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "18kn1bmc0s6dp834kc51ibifzzn3bxwya4p8s8yq9f4mpmkghi24"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "LIBZITACONVOLVER=-lzita-convolver"
+ (string-append
+ "FONTFILE=" (assoc-ref %build-inputs "font-dejavu")
+ "/share/fonts/truetype/DejaVuSans-Bold.ttf"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("fftwf" ,fftwf)
+ ("jack" ,jack-1)
+ ("fftw" ,fftw)
+ ("ftgl" ,ftgl)
+ ("glib" ,glib)
+ ("glibc" ,glibc)
+ ("glu" ,glu)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libsamplerate" ,libsamplerate)
+ ("libx11" ,libx11)
+ ("libltc" ,libltc)
+ ("pango" ,pango)
+ ("zita-convolver" ,zita-convolver)))
+ (native-inputs
+ `(("help2man" ,help2man)
+ ("liblo" ,liblo)
+ ("lv2" ,lv2)
+ ("font-dejavu" ,font-dejavu)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
+ (description "x42-plugins is a collection of over 80 cross-platform
LV2
+audio and MIDI plugins that can also run as standalone JACK
applications.")
+ (home-page "https://x42-plugins.com/x42/")
+ (license license:gpl2+)))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:00
87a793l7do.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (10 lines)
> NOTE: this patch depends on
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121 and
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38126
> From ee2e983068b3dd11aaed7c703388904749e77a44 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:54:00 +0000
> Subject: [PATCH] gnu: Add x42-plugins.
>
> * gnu/packages/music.scm: (x42-plugins): New variable.

The patch LGTM overall, but indentation seems to be off. Can you run
this through "./etc/indent-code.el"?

[...]

Toggle quote (8 lines)
> + (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
> + (description "x42-plugins is a collection of over 80 cross-platform
> LV2
> +audio and MIDI plugins that can also run as standalone JACK
> applications.")
> + (home-page "https://x42-plugins.com/x42/")
> + (license license:gpl2+)))

I notice in the FAQ that "Some binaries are provided as demo. A
license/signature file is required to remove the evaluation
restrictions".

If there are such binaries in the source tarball, they must be removed
with a source 'snippet' to ensure 'guix build --source' contains only
free software.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IiGMACgkQoqBt8qM6
VPqj8Af/fXhbg4Lkx1lt/UJQzPjVNTpnZQgA+BrbjwU6IffJYGc3NQ4S0r57tRNC
J88IeL35ZGADTAjeVcZtDFNgEmbKzQMdpbYiShxXZM7xEp0HGU1VIyFk0xJKOUUC
L3XIkAKdZqc+HaelXtMQ6FUPxHVpjg90RWJ/vLzlaoEHi/5QempeWRubVK8paUij
pR1EjWMrovVjm40cJumYs9hRsGM/kSpQS2q2mJEfgqnD+VNpxKSiNj9YKiArV9IO
0JDOW2pija3n7cHO+qmdabsGoy/LfoirSBjAF5Nyob47FS5tYz2JX97HGGymQL2L
RoyWTJF52TOV7B057AOlyaLorMPmJQ==
=MzV1
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 11 Nov 2019 02:53
fe14cfe5e1a154548162f85e2f5c4f1a4df5f00f.camel@zrythm.org
Thanks for the pointers!

Toggle quote (2 lines)
> The patch LGTM overall, but indentation seems to be off. Can you run
> this through "./etc/indent-code.el"?
That script gives me weird indentation that I don't see in any
packages, like:
(define-public dpf-plugins
(package
(name
^ missing space

Hopefully the updated patch looks better, I tried to match the other
packages in music.scm.

Toggle quote (13 lines)
> > +audio and MIDI plugins that can also run as standalone JACK
> > applications.")
> > + (home-page "https://x42-plugins.com/x42/")
> > + (license license:gpl2+)))
>
> I notice in the FAQ that "Some binaries are provided as demo. A
> license/signature file is required to remove the evaluation
> restrictions".
>
> If there are such binaries in the source tarball, they must be
> removed
> with a source 'snippet' to ensure 'guix build --source' contains only
> free software.
This tarball only contains sources and is specifically targeted at
distro packagers (see https://github.com/x42/x42-plugins).I believe
the binaries are provided as separate downloads on the website.
From 05ffc94c834f99b3cb56a9ebc97096958a07981e Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:54:00 +0000
Subject: [PATCH] gnu: Add x42-plugins.

* gnu/packages/music.scm: (x42-plugins): New variable.
---
gnu/packages/music.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..5efdae31e4 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,58 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public x42-plugins
+ (package
+ (name "x42-plugins")
+ (version "20191013")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://gareus.org/misc/x42-plugins/x42-plugins-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "18kn1bmc0s6dp834kc51ibifzzn3bxwya4p8s8yq9f4mpmkghi24"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "LIBZITACONVOLVER=-lzita-convolver"
+ (string-append "FONTFILE="
+ (assoc-ref %build-inputs "font-dejavu")
+ "/share/fonts/truetype/DejaVuSans-Bold.ttf"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _
+ (setenv "CC" "gcc")
+ #t))
+ (delete 'configure))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("fftwf" ,fftwf)
+ ("jack" ,jack-1)
+ ("fftw" ,fftw)
+ ("ftgl" ,ftgl)
+ ("glib" ,glib)
+ ("glu" ,glu)
+ ("hicolor-icon-theme" ,hicolor-icon-theme)
+ ("libsamplerate" ,libsamplerate)
+ ("libx11" ,libx11)
+ ("libltc" ,libltc)
+ ("pango" ,pango)
+ ("zita-convolver" ,zita-convolver)))
+ (native-inputs
+ `(("help2man" ,help2man)
+ ("liblo" ,liblo)
+ ("lv2" ,lv2)
+ ("font-dejavu" ,font-dejavu)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
+ (description "x42-plugins is a collection of over 80 cross-platform LV2
+audio and MIDI plugins that can also run as standalone JACK applications.")
+ (home-page "https://x42-plugins.com/x42/")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3Ivv4ACgkQAi6uQjE9
cPMiTQgApRWNAGTZz5Jf8nkZj6kR1WdzaBL66/lU3zZuTEd0LrRn5+jZzr4+pnsy
bLpuJHfuF8B4wVNi/PQHFbrk6mRfRmIPBSS9hl3I5y+k72AfBY/2g+oYh9DDpjt7
aUkMDx1Npt9bIgvnwe2x3RB53JpJPe0a5ks3hCGagRmjb++uhl0J0OmTKI7EGFdv
85FzNKGu5/CaV8mdasokCE/XYVVFE5UfhDSFjzCqWqQXHWjNgWZmNyYQHEbs5qXy
i66PTQYZUQOv3N8ZUo+U+RQNFbFfrYq4Y8K90gXv/rxa9S7G0U7ld+3a+9awObtg
Gq9fJWPlNsZ7V1g/S88GIk3er/OV/g==
=TYOA
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 13 Nov 2019 23:26
87pnhvifar.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (17 lines)
>> > +audio and MIDI plugins that can also run as standalone JACK
>> > applications.")
>> > + (home-page "https://x42-plugins.com/x42/")
>> > + (license license:gpl2+)))
>>
>> I notice in the FAQ that "Some binaries are provided as demo. A
>> license/signature file is required to remove the evaluation
>> restrictions".
>>
>> If there are such binaries in the source tarball, they must be
>> removed
>> with a source 'snippet' to ensure 'guix build --source' contains only
>> free software.
> This tarball only contains sources and is specifically targeted at
> distro packagers (see https://github.com/x42/x42-plugins). I believe
> the binaries are provided as separate downloads on the website.

OK, that's reassuring. Thanks for checking!

Toggle quote (7 lines)
> From 05ffc94c834f99b3cb56a9ebc97096958a07981e Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:54:00 +0000
> Subject: [PATCH] gnu: Add x42-plugins.
>
> * gnu/packages/music.scm: (x42-plugins): New variable.

[...]

Toggle quote (6 lines)
> + (inputs
> + `(("cairo" ,cairo)
> + ("fftwf" ,fftwf)
> + ("jack" ,jack-1)
> + ("fftw" ,fftw)

I removed 'fftw', since it appeared unused. Let me know if that was
mistaken. I also sorted these alphabetically out of preference.

Applied!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3MgwwACgkQoqBt8qM6
VPoQ+wf+IfXzbt2Ci3BXEiwAVpJlG6zfouvTR1/1QwLhGFcjEH2xnZSYsCp6BaM9
sOaWNEMpSdKcyFeh+J7NTktl6utrnQ4pXbiAw46ninB2qtryhk0Uecu0D5bvBdE5
57MRc+xMXK877GYGwHgfxHK0Uy72Ovg2pDAcbtcBnjG4pZrgCgUsxSkI9CirXB1J
6vdROaKLyY5Q20iBGm0Z/hPIu6W+XlDmX2rDRNZqb5B97IndpMByADIcmTp+uFNP
6BCa42y0kG5d5ld+eNRtkNzwOyRyKlsUrEn7vg/pVtnDO3s3XqZbrcC3mC2BTbtB
prwJnwnaJOvjaLN3pYXxuyDqu0C5rQ==
=enmQ
-----END PGP SIGNATURE-----

Closed
?