[PATCH] gnu: Add zam-plugins.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal
A
A
Alexandros Theodotou wrote on 8 Nov 2019 11:39
(name . Guix patches)(address . guix-patches@gnu.org)
8371d54f6514ae6eef11caceb0f08182@posteo.net
NOTE: This patch depends on

From 03620d73893a4eb53cc294f653c72df0e945f9d5 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:35:27 +0000
Subject: [PATCH] gnu: Add zam-plugins.

* gnu/packages/music.scm: (zam-plugins): New variable.
---
gnu/packages/music.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..616b4dc370 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,50 @@ You can also get metadata about the playing track
such as the artist and title
for integration into status line generators or other command-line
tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public zam-plugins
+ (package
+ (name "zam-plugins")
+ (version "3.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zamaudio/zam-plugins.git")
+ (commit version)
+ (recursive? #t))) ; for DPF
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "HAVE_ZITA_CONVOLVER=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("fftwf" ,fftwf)
+ ("jack" ,jack-1)
+ ("liblo" ,liblo)
+ ("libsamplerate" ,libsamplerate)
+ ("mesa" ,mesa)
+ ("zita-convolver" ,zita-convolver)))
+ (native-inputs
+ `(("ladspa" ,ladspa)
+ ("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Collection of LADSPA/LV2/VST2/JACK audio processing
plugins")
+ (description
+ "Zam plugins is a collection of audio processing plugins in the
LADSPA,
+LV2 and VST2 formats, as well as standalone JACK versions. The
collection
+includes ZaMaximX2, ZamAutoSat, ZamComp, ZamCompX2, ZamEQ2, ZamGEQ31,
+ZamHeadX2, ZamPhono, ZamGate, ZamGateX2, ZamTube, ZamDelay,
ZamDynamicEQ,
+ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
+ (home-page "http://www.zamaudio.com/?p=976")
+ (license license:gpl2+)))
--
2.24.0
M
M
Marius Bakke wrote on 10 Nov 2019 23:10
874kzbl6w6.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (10 lines)
> NOTE: This patch depends on
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=38121
>
> From 03620d73893a4eb53cc294f653c72df0e945f9d5 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:35:27 +0000
> Subject: [PATCH] gnu: Add zam-plugins.
>
> * gnu/packages/music.scm: (zam-plugins): New variable.

Like the other patches, please resend it (preferably through 'git
send-email') after adjusting the indentation.

[...]

Toggle quote (12 lines)
> +(define-public zam-plugins
> + (package
> + (name "zam-plugins")
> + (version "3.11")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/zamaudio/zam-plugins.git")
> + (commit version)
> + (recursive? #t))) ; for DPF

Can you describe what DPF is? Is it possible to package it separately?

Toggle quote (29 lines)
> + (file-name (string-append name "-" version))
> + (sha256
> + (base32
> + "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; no "check" target
> + #:make-flags
> + (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
> + "HAVE_ZITA_CONVOLVER=true")
> + #:phases
> + (modify-phases %standard-phases
> + (add-before 'build 'set-CC-variable
> + (lambda _ (setenv "CC" "gcc") #t))
> + (delete 'configure))))
> + (inputs
> + `(("fftwf" ,fftwf)
> + ("jack" ,jack-1)
> + ("liblo" ,liblo)
> + ("libsamplerate" ,libsamplerate)
> + ("mesa" ,mesa)
> + ("zita-convolver" ,zita-convolver)))
> + (native-inputs
> + `(("ladspa" ,ladspa)
> + ("lv2" ,lv2)
> + ("pkg-config" ,pkg-config)))
> + (synopsis "Collection of LADSPA/LV2/VST2/JACK audio processing
> plugins")

Maybe just "Audio processing plugins"? I suppose even more will be
supported in the future :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IitkACgkQoqBt8qM6
VPpcbgf/bA2qnCZu4whGKt5tu7sfK16QT0tSOgHI6G2m+izORMFeJ8DEpYQDZ/FP
fPO+4LTbde5bX2u5PG/EsFaFxP/49TIrkfqE6QiL090pOasWOXuIEbaXl5qrsszt
6MRUzhSSkQWSTn/lzeaSvKPnSHNd3gPbn/k2wemuJiRmpzc8PLxeD9uoF3c0GpVT
3OErp0Ajz0iSnPxlpshpMPUOfq8CPmpFXDdRWYwpU9m9VOuHGbcit5KFEwcZ1npQ
8v6atJY4ZZIoLte3O4/KiPxza5nOPzaH4twg5opop31zJBsQDcbedF5FshrjkXmC
TP0BOESCfCV21qM1IvwlGjf5+zNzxg==
=KoZJ
-----END PGP SIGNATURE-----

A
A
Alexandros Theodotou wrote on 11 Nov 2019 04:06
cb45fcab16216bcf02e34e4e876b98f5669883ea.camel@zrythm.org
Updated and clarified on DPF
From 10b8905b8e117d68e6b8b8f86087111a1fb5dae8 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:35:27 +0000
Subject: [PATCH] gnu: Add zam-plugins.

* gnu/packages/music.scm: (zam-plugins): New variable.
---
gnu/packages/music.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2f023685df..17288f845f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,55 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public zam-plugins
+ (package
+ (name "zam-plugins")
+ (version "3.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/zamaudio/zam-plugins.git")
+ (commit version)
+ ;; Recursive to fetch the DISTRHO plugin framework. This
+ ;; framework is intended to be included in the sources
+ ;; and not to be used as a library
+ (recursive? #t)))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "0jlbxm0g93plgd3g4r9rsr0c7868ms49bs0ljpqb6kw6132hsapp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "HAVE_ZITA_CONVOLVER=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable
+ (lambda _
+ (setenv "CC" "gcc") #t))
+ (delete 'configure))))
+ (inputs
+ `(("fftwf" ,fftwf)
+ ("jack" ,jack-1) ; for the standalone JACK application
+ ("liblo" ,liblo)
+ ("libsamplerate" ,libsamplerate)
+ ("mesa" ,mesa)
+ ("zita-convolver" ,zita-convolver)))
+ (native-inputs
+ `(("ladspa" ,ladspa)
+ ("lv2" ,lv2)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Collection of audio processing plugins")
+ (description
+ "Zam plugins is a collection of audio processing plugins in the LADSPA,
+LV2 and VST2 formats, as well as standalone JACK versions. The collection
+includes ZaMaximX2, ZamAutoSat, ZamComp, ZamCompX2, ZamEQ2, ZamGEQ31,
+ZamHeadX2, ZamPhono, ZamGate, ZamGateX2, ZamTube, ZamDelay, ZamDynamicEQ,
+ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
+ (home-page "http://www.zamaudio.com/?p=976")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I0BsACgkQAi6uQjE9
cPMIDgf9GuXo6efP/VMYjZxWKkejMRvxLiidDycSJz7zOQzosg3KIEQGtVZkCoVU
ORbVbl9gfhBsobjOpafRcOWqn5SrHhYwlGitfsbEdO73whH39D3dNgF9Yn5qFwe9
I1WmaSVsMxz4ol6OjWZ1Ji2B4Deqg44I/PfujltiOP7e9oFf6SVz7y7Wd+0rUJrC
BpmUL3FfL9P+JTcShX5JuUzTi+2IRAZdiMlu1lwWJ/XBsZW89Xsihsa3kV3d0Mdn
7KercXsHtELPPWAGAVyczoSnWtqI+e0Uwlvt2IpIj3skE2Fb5qBOZwENQyTgAfVM
oXK72eui6EvSX8H6KkQnTW+qOObcGQ==
=sFms
-----END PGP SIGNATURE-----


M
M
Marius Bakke wrote on 13 Nov 2019 23:26
87o8xfif9o.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 10b8905b8e117d68e6b8b8f86087111a1fb5dae8 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:35:27 +0000
> Subject: [PATCH] gnu: Add zam-plugins.
>
> * gnu/packages/music.scm: (zam-plugins): New variable.

Applied after changing indentation and adjusting description to appease
`guix lint`.

[...]

Toggle quote (2 lines)
> + (file-name (string-append name "-" version))

I also changed this to use 'git-file-name'.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3MgzQACgkQoqBt8qM6
VPoOkAf8C6AFXn/PmeZB6MgLCaF6pVLYYDUxFjOJXSmxpIOObGpuG+fKQoxaGzz6
/7lhhKsjIIAUQs1sQKeD4TPTy+oaTEfXdMoGZthbCaQWkHrzB9ildB6J1On2AFHh
R3fs+Zp+3alPgxdCyaNTPG8jBI+rBaPBiKAAQNBN9CON7rfKslfFs8HT5/fG86JF
0KbGTa2tASC3cQ+vwh5nZA/yijf9NYxzqGJGvDf42sub2kYVskm9ae6tdgVBO4NX
yAna+70ZBn545HcXgsO6q3yfyFFTmIuCrdrTDnnIEwk6KjpEZx/1hOLbTFCaWrbC
9CcOO22YTHSvg0dKN54mTf/JcduNmA==
=MmxI
-----END PGP SIGNATURE-----

Closed
?