[PATCH] gnu: git: Add PCRE support to "git grep".

  • Done
  • quality assurance status badge
Details
2 participants
  • Pierre Neidhardt
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 30 Oct 2019 17:19
(address . guix-patches@gnu.org)
20191030161913.17691-1-mail@ambrevar.xyz
* gnu/packages/version-control.scm (git)[inputs]: Add pcre2.
[arguments]: Add "USE_LIBPCRE2" to make-flags.
(git-minimal)[arguments]: Do not inherit "USE_LIBPCRE2" in make-flags.
---
gnu/packages/version-control.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 573fa6f8cc..1dad351ba1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -183,6 +183,9 @@ as well as the classic centralized workflow.")
;; a problem in 'patch-shebangs'; see <https://bugs.gnu.org/31952>.
("bash-for-tests" ,bash)
+ ;; For PCRE support in git grep (USE_LIBPCRE2)
+ ("pcre" ,pcre2)
+
;; For 'gitweb.cgi'
("perl-cgi" ,perl-cgi)
@@ -216,6 +219,8 @@ as well as the classic centralized workflow.")
(assoc-ref %build-inputs "bash-for-tests")
"/bin/bash")
+ "USE_LIBPCRE2=yes"
+
;; By default 'make install' creates hard links for
;; things in 'libexec/git-core', which leads to huge
;; nars; see <https://bugs.gnu.org/21949>.
@@ -505,6 +510,8 @@ everything from small to very large projects with speed and efficiency.")
(delete-file-recursively
(string-append out "/share/gitweb"))
#t)))))
+ ((#:make-flags flags)
+ `(delete "USE_LIBPCRE2=yes" ,flags))
((#:configure-flags flags)
''())
((#:disallowed-references lst '())
--
2.23.0
T
T
Tobias Geerinckx-Rice wrote on 30 Oct 2019 18:15
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 37994@debbugs.gnu.org)
874kzqw3wc.fsf@nckx
Pierre,

Pierre Neidhardt ???
Toggle quote (5 lines)
> * gnu/packages/version-control.scm (git)[inputs]: Add pcre2.
> [arguments]: Add "USE_LIBPCRE2" to make-flags.
> (git-minimal)[arguments]: Do not inherit "USE_LIBPCRE2" in
> make-flags.

What do you think of removing pcre2 from INPUTS as well?

I'm a bit worried that upstream will grow auto-detection and/or
change the default value of USE_LIBPCRE2 one day, and that would
go unnoticed.

Toggle quote (2 lines)
> + ;; For PCRE support in git grep (USE_LIBPCRE2)

Missing ‘.’.

Otherwise GTM!

T G-R
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl25xUMACgkQ2Imw8BjF
STzrKg//YxF0KWIH7kFbN7yqtFhPhaSm4dTVCuuTL+IjY+7QPe4CHP+t8Mk7GrXQ
ArOmTbQQM3y9KAApq0jStNpTPOCuSI0f5gjRQ0SyKdzl6kCfgCmnjMx0GRn8HrAC
63JL6dPZfbhEbbSJU9CfE1w0EnlitzLEzkAvhOl8TXiGtpQr+tBNHovTQSEaq9Bx
le3V7ZQ/31sNz26GJnMaA5tM7Z+TxL3MDBqSD4ZFuuwJB4N/rEErrG5AG214z19A
PNd0wwni3LiPHEaB55a6zDQ0Rl797EPZ7WzTkfocFC4S2np5a2dh2M/7aS5LI9Jk
WwHiGIUnfFTOSG26N4kz7vqL8qjPKTBvie/Loosp9Cj7f9OZiJCICDrImMpoSw82
8ACESQ8A2CbimQXeqePF4DA/6aH3nIsLp0tN9IePs2aCX1/Cm7AAfrfuG+EY/hF7
PAC+ZQ+4il/wB0IvcoWQfo5SEnfKpHtCIeJ9qNTKpGqp3Fp5X1ZvtkpOIrzh/QCh
N+MGutS6gkdl42v4ksIkxOmyXTQHfe7b743KFbFJucmGRgSJCYICgxEgwmDn9+Hc
2DbHEsS9kJiZ4/JuvGHFRbOQFWdRhaPV/UnZCZdiWZo5/Yo48zkpCENMxSYCWiMu
+Y792AV6wQhoySISH2I+3ObEn4tKBIlXuWWoXEH6hX/jSZ8eGJA=
=BH+/
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 30 Oct 2019 20:53
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 37994@debbugs.gnu.org)
87d0ee6mdo.fsf@ambrevar.xyz
Tobias Geerinckx-Rice <me@tobias.gr> writes:

Toggle quote (10 lines)
> Pierre,
>
> Pierre Neidhardt ???
>> * gnu/packages/version-control.scm (git)[inputs]: Add pcre2.
>> [arguments]: Add "USE_LIBPCRE2" to make-flags.
>> (git-minimal)[arguments]: Do not inherit "USE_LIBPCRE2" in
>> make-flags.
>
> What do you think of removing pcre2 from INPUTS as well?

git-minimal's input is defined explicitly, no need to remove pcre2 since
it's not there.

Toggle quote (4 lines)
> I'm a bit worried that upstream will grow auto-detection and/or
> change the default value of USE_LIBPCRE2 one day, and that would
> go unnoticed.

Looks like the compile flags are here to stay :)

Toggle quote (4 lines)
>> + ;; For PCRE support in git grep (USE_LIBPCRE2)
>
> Missing ‘.’.

You mean the trailing period? Actually I just noticed that about half
of those comments in Git have trailing periods. I can fix it.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl256jMACgkQm9z0l6S7
zH9dyAgApT8lTYb7bet9WGsz6aH6pTyV7+dnMsWbJ28qfk9Bi9IOuQvFIFACSUbf
cv1LboUE5S1ow3RcaOAqM2OBZOlSfib+ZFV1bJliDcmJ7qMFiEIf0kMbxffVGHnc
hzxPYx7+Fm9K2UNqFqXlU0B1q/Kqlvcgvdaxgxowmis+hiRqDi6jYBMx7CqQK1Kb
itGvTppRaVjEBWt53tVipUw6MvV2cMD5h6l+Ta7LRqemxPvocEwsKtlPSHV9TlRE
Z12LbXtgxhaX0KCgmqgsqjD/nGL0eaTCmf19Pbb8s1KyCPEK1NzVlo+A6sNPjGBX
KOCB0kTReptMzqH9u7WsCiql3qHkLw==
=0BqG
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 2 Nov 2019 12:52
control message for bug #37994
(address . control@debbugs.gnu.org)
87o8xua418.fsf@ambrevar.xyz
close 37994
quit
?