[PATCH 0/4] Some fixes for ecl-* Common Lisp packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Pierre Neidhardt
Owner
unassigned
Submitted by
Guillaume Le Vaillant
Severity
normal
G
G
Guillaume Le Vaillant wrote on 17 Oct 2019 16:37
(address . guix-patches@gnu.org)
87pnivsajn.fsf@yamatai
Patches:
- build-system/asdf: Fix package transform.
- gnu: sbcl-trivial-mimes: Fix 'fix-paths' phase.
- gnu: Add ecl-trivial-mimes.
- gnu: Add ecl-dexador.
G
G
Guillaume Le Vaillant wrote on 17 Oct 2019 16:43
[PATCH 1/4] build-system/asdf: Fix package transform.
(address . 37791@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191017144312.13121-1-glv@posteo.net
* guix/build-system/asdf.scm (package-with-build-system):
[find-input-package]: New function.
[rewrite]: Use it.
---
guix/build-system/asdf.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (45 lines)
diff --git a/guix/build-system/asdf.scm b/guix/build-system/asdf.scm
index af04084c86..f794bf006b 100644
--- a/guix/build-system/asdf.scm
+++ b/guix/build-system/asdf.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Andy Patterson <ajpatter@uwaterloo.ca>
+;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (ice-9 regex)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
+ #:use-module (gnu packages)
#:export (%asdf-build-system-modules
%asdf-build-modules
asdf-build
@@ -160,13 +162,22 @@ set up using CL source package conventions."
(define (has-from-build-system? pkg)
(eq? from-build-system (package-build-system pkg)))
+ (define (find-input-package pkg)
+ (let* ((name (package-name pkg))
+ (new-name (transform-package-name name))
+ (pkgs (find-packages-by-name new-name)))
+ (if (null? pkgs) #f (list-ref pkgs 0))))
+
(define transform
(mlambda (pkg)
(define rewrite
(match-lambda
((name content . rest)
(let* ((is-package? (package? content))
- (new-content (if is-package? (transform content) content)))
+ (new-content (if is-package?
+ (or (find-input-package content)
+ (transform content))
+ content)))
`(,name ,new-content ,@rest)))))
;; Special considerations for source packages: CL inputs become
--
2.23.0
G
G
Guillaume Le Vaillant wrote on 17 Oct 2019 16:43
[PATCH 2/4] gnu: sbcl-trivial-mimes: Fix 'fix-paths' phase.
(address . 37791@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191017144312.13121-2-glv@posteo.net
* gnu/packages/lisp.scm (sbcl-trivial-mimes)[arguments]: Use '(%lisp-type)'
instead of hard coded 'sbcl' in 'fix-paths' phase.
---
gnu/packages/lisp.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2bdebed04e..310522984d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5130,7 +5130,9 @@ performance and simplicity in mind.")
((anchor all)
(string-append
anchor "\n"
- "(asdf:system-relative-pathname :trivial-mimes \"../../share/common-lisp/sbcl-source/trivial-mimes/mime.types\")")))))))))
+ "(asdf:system-relative-pathname :trivial-mimes "
+ "\"../../share/common-lisp/" (%lisp-type)
+ "-source/trivial-mimes/mime.types\")")))))))))
(native-inputs
`(("stefil" ,sbcl-hu.dwim.stefil)))
(inputs
--
2.23.0
G
G
Guillaume Le Vaillant wrote on 17 Oct 2019 16:43
[PATCH 3/4] gnu: Add ecl-trivial-mimes.
(address . 37791@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191017144312.13121-3-glv@posteo.net
* gnu/packages/lisp.scm (ecl-trivial-mimes): New variable.
---
gnu/packages/lisp.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 310522984d..a8293dad3a 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5147,6 +5147,9 @@ mime-type of a file.")
(define-public cl-trivial-mimes
(sbcl-package->cl-source-package sbcl-trivial-mimes))
+(define-public ecl-trivial-mimes
+ (sbcl-package->ecl-package sbcl-trivial-mimes))
+
(define-public sbcl-lack-middleware-static
(let ((commit "abff8efeb0c3a848e6bb0022f2b8b7fa3a1bc88b")
(revision "1"))
--
2.23.0
G
G
Guillaume Le Vaillant wrote on 17 Oct 2019 16:43
[PATCH 4/4] gnu: Add ecl-dexador.
(address . 37791@debbugs.gnu.org)(name . Guillaume Le Vaillant)(address . glv@posteo.net)
20191017144312.13121-4-glv@posteo.net
* gnu/packages/lisp.scm (ecl-dexador): New variable.
---
gnu/packages/lisp.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index a8293dad3a..e42a806ff4 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6256,6 +6256,9 @@ cookie headers, cookie creation, cookie jar creation and more.")
neat APIs and connection-pooling. It is meant to supersede Drakma.")
(license license:expat))))
+(define-public ecl-dexador
+ (sbcl-package->ecl-package sbcl-dexador))
+
(define-public sbcl-lisp-namespace
(let ((commit "28107cafe34e4c1c67490fde60c7f92dc610b2e0")
(revision "1"))
--
2.23.0
P
P
Pierre Neidhardt wrote on 21 Oct 2019 11:06
control message for bug #37791
(address . control@debbugs.gnu.org)
87ftjmbh72.fsf@ambrevar.xyz
close 37791
quit
?