[PATCH] gnu: Add emacs-dimmer.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brian Leung
  • Nicolas Goaziou
  • Stephen Webber
Owner
unassigned
Submitted by
Stephen Webber
Severity
normal
S
S
Stephen Webber wrote on 13 Oct 2019 06:30
(address . guix-patches@gnu.org)(name . Stephen Webber)(address . montokapro@gmail.com)
20191013043008.21293-1-montokapro@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-dimmer): New variable.
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a55282a0a9..330b96de47 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18945,3 +18946,29 @@ Emacs that integrate with major modes like Org-mode.")
"Elixir-Mode Provides font-locking, indentation and navigation support
for the Elixir programming language.")
(license license:gpl3+)))
+
+(define-public emacs-dimmer
+ (let ((commit "12fc52a6570ec25020281735f5a0ca780a9105af"))
+ (package
+ (name "emacs-dimmer")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gonewest818/dimmer.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jv9rrv15nb5hpwcaqlpjj932gyisrkwbv11czkg3v0bn7qn6yif"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/gonewest818/dimmer.el")
+ (synopsis "Incremental completion and selection narrowing
+framework for Emacs")
+ (description "Dimmer provides a minor mode that indicates which buffer is
+currently active by dimming the faces in the other buffers. It
+does this nondestructively, and computes the dimmed faces
+dynamically such that your overall color scheme is shown in a muted
+form without requiring you to define what is a \"dim\" version of
+every face.")
+ (license license:gpl3+))))
--
2.23.0
N
N
Nicolas Goaziou wrote on 13 Oct 2019 09:14
(name . Stephen Webber)(address . montokapro@gmail.com)(address . 37727@debbugs.gnu.org)
87lftpce24.fsf@nicolasgoaziou.fr
Hello,

Stephen Webber <montokapro@gmail.com> writes:

Thank you for the patch!

Toggle quote (4 lines)
> * gnu/packages/emacs-xyz.scm (emacs-dimmer): New variable.
> + (synopsis "Incremental completion and selection narrowing
> +framework for Emacs")

The synopsis is wrong, could you fix it?

Otherwise, LGTM.


Regards,

--
Nicolas Goaziou
B
B
Brian Leung wrote on 18 Oct 2019 19:14
closing duplicate
(address . 37727-done@debbugs.gnu.org)
CAAc=MEy5mgNY_GNXKyUxuFQpBL7WAL1pGFHdAvZ81EZ+tMCa3A@mail.gmail.com

Attachment: file
Closed
?