[PATCH] python-build-system: Fix build of packages without sbin directory.

  • Done
  • quality assurance status badge
Details
One participant
  • Jonathan Frederickson
Owner
unassigned
Submitted by
Jonathan Frederickson
Severity
normal
J
J
Jonathan Frederickson wrote on 13 Oct 2019 00:54
(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
20191012225404.11901-1-jonathan@terracrypt.net
Prior to this change, some packages (at least Ansible for example) would fail
to build with an error like:

starting phase `wrap'
find-files: /gnu/store/va1qkgv1qwv1hy6iynzjafqshakqkjs7-ansible-2.8.1/sbin: No
such file or directory

That directory in the store contained a 'bin' directory, but not an 'sbin
directory, and 'find-files' throws an error in that case.

* guix/build/python-build-system.scm (list-of-files): Handle case in which
directory passed as argument does not exist.
---
guix/build/python-build-system.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 09bd8465c8..15c7d2e613 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -188,9 +188,11 @@ when running checks after installing the package."
(define* (wrap #:key inputs outputs #:allow-other-keys)
(define (list-of-files dir)
- (find-files dir (lambda (file stat)
- (and (eq? 'regular (stat:type stat))
- (not (wrapper? file))))))
+ (if (not (directory-exists? dir))
+ '()
+ (find-files dir (lambda (file stat)
+ (and (eq? 'regular (stat:type stat))
+ (not (wrapper? file)))))))
(define bindirs
(append-map (match-lambda
--
2.23.0
J
J
Jonathan Frederickson wrote on 13 Oct 2019 00:59
Re: bug#37722: Acknowledgement ([PATCH] python-build-system: Fix build of packages without sbin directory.)
(address . 37722-close@debbugs.gnu.org)
09d33762-6b0d-6480-5726-e3ad7cb6e35e@terracrypt.net
On 10/12/19 6:55 PM, GNU bug Tracking System wrote:

Toggle quote (17 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 37722@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
Ah, my apologies, I seem to have been a bit too trigger-happy with this
patch - it doesn't entirely solve the issue I was running into. The
'wrap' phase succeeds at this point but the 'fix-symlinks' phase still
fails. I'm not sure what the underlying issue here is yet, but
*something* changed recently as Ansible builds succeeded not too long
ago... closing this one out though.
Attachment: signature.asc
?