[PATCH] gnu: Add emacs-ssh-agency.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brian Leung
  • LaFreniere, Joseph
  • Kyle Meyer
Owner
unassigned
Submitted by
LaFreniere, Joseph
Severity
normal
L
L
LaFreniere, Joseph wrote on 9 Oct 2019 03:34
(address . guix-patches@gnu.org)
87y2xuya5t.fsf@lafreniere.xyz
Please find the patch attached.

--
Joseph LaFreniere
From 9060255351353a2933d236992654c9dea52b026a Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 25 Aug 2019 15:38:42 -0500
Subject: [PATCH] gnu: Add emacs-ssh-agency.

* gnu/packages/emacs-xyz.scm (emacs-ssh-agency): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1b8ae47fc2..5a68f6417c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18741,6 +18741,34 @@ JIRA issue servers.")
keybindings for skipping from host section to host section.")
(license license:gpl3+))))
+(define-public emacs-ssh-agency
+ (package
+ (name "emacs-ssh-agency")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/ssh-agency.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0895n7bss4wdydic1gflr03f2cwdyqywl16gvb599lpn288jhwvz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("dash" ,emacs-dash)))
+ (home-page "https://github.com/magit/ssh-agency")
+ (synopsis "Manage @code{ssh-agent} from Emacs")
+ (description
+ "This package provides functions to startup @code{ssh-agent}, set the
+needed environment variables in Emacs, prompt for passphrases from within
+Emacs, and so that pushes and pulls from @code{magit} will not require
+entering any passphrase.
+
+It can also be useful on Unix-like platforms to delay having to enter your
+passphrase until the first time you push to a remote.")
+ (license license:gpl3+)))
+
(define-public emacs-tao-theme
(let ((commit "c5107fbe7e752f4e58c2d2147ff18a1ebb12937c")
(revision "0"))
--
2.22.0
K
K
Kyle Meyer wrote on 9 Oct 2019 04:06
87k19e8yg0.fsf@kyleam.com
Hi Joseph,

"LaFreniere\, Joseph" <joseph@lafreniere.xyz> writes:

Toggle quote (5 lines)
> + "This package provides functions to startup @code{ssh-agent}, set the
> +needed environment variables in Emacs, prompt for passphrases from within
> +Emacs, and so that pushes and pulls from @code{magit} will not require
> +entering any passphrase.

I think the "and" before "so" should be moved before "prompt".

LGTM otherwise. Thanks.

--
Kyle
L
L
LaFreniere, Joseph wrote on 9 Oct 2019 08:19
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 37670@debbugs.gnu.org)
87v9syxwy4.fsf@lafreniere.xyz
Kyle Meyer <kyle@kyleam.com> writes:
Toggle quote (2 lines)
> I think the "and" before "so" should be moved before "prompt".

Thank you for pointing that out. I have attached an updated
patch.

--
Joseph LaFreniere
From 13d6be8a178888274120497186b9494040406fcc Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 25 Aug 2019 15:38:42 -0500
Subject: [PATCH] gnu: Add emacs-ssh-agency.

* gnu/packages/emacs-xyz.scm (emacs-ssh-agency): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1b8ae47fc2..a4a804fe8b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18741,6 +18741,34 @@ JIRA issue servers.")
keybindings for skipping from host section to host section.")
(license license:gpl3+))))
+(define-public emacs-ssh-agency
+ (package
+ (name "emacs-ssh-agency")
+ (version "0.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/ssh-agency.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0895n7bss4wdydic1gflr03f2cwdyqywl16gvb599lpn288jhwvz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("dash" ,emacs-dash)))
+ (home-page "https://github.com/magit/ssh-agency")
+ (synopsis "Manage @code{ssh-agent} from Emacs")
+ (description
+ "This package provides functions to startup @code{ssh-agent}, set the
+needed environment variables in Emacs, and prompt for passphrases from within
+Emacs so that pushes and pulls from @code{magit} will not require entering any
+passphrase.
+
+It can also be useful on Unix-like platforms to delay having to enter your
+passphrase until the first time you push to a remote.")
+ (license license:gpl3+)))
+
(define-public emacs-tao-theme
(let ((commit "c5107fbe7e752f4e58c2d2147ff18a1ebb12937c")
(revision "0"))
--
2.22.0
B
B
Brian Leung wrote on 9 Oct 2019 21:13
Done
CAAc=MEz+txqA+HepX9A+XUN6gd4KxO-uRuAbpkd029xYdS8H-w@mail.gmail.com
Merged, thanks.
Attachment: file
Closed
?