[PATCH] gnu: python2-tqdm: Depend on python2-functools32.

DoneSubmitted by Pierre Langlois.
Details
2 participants
  • Marius Bakke
  • Pierre Langlois
Owner
unassigned
Severity
normal
P
P
Pierre Langlois wrote on 8 Oct 2019 15:58
(address . guix-patches@gnu.org)(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
87y2xvnxta.fsf@gmx.com
Hi Guix!
This fixes the python2-tqdm package which failed to build for me sincecore-updates was merged:
```starting phase `check'running "python setup.py" with command "test" and parameters ()running testSearching for functools32Reading https://pypi.org/simple/functools32/Download error on https://pypi.org/simple/functools32/:[Errno -2] Name or service not known -- Some packages may not be found!Couldn't find index page for 'functools32' (maybe misspelled?)Scanning index of all packages (this may take a while)Reading https://pypi.org/simple/Download error on https://pypi.org/simple/:[Errno -2] Name or service not known -- Some packages may not be found!No local packages or working download links found for functools32error: Could not find suitable distribution for Requirement.parse('functools32')command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1builder for `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed with exit code 1build of /gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv failedView build log at '/var/log/guix/drvs/p3/v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv.bz2'.guix build: error: build of `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed```
Adding python2-functools32 as a native-input fixes the issue.
From 13a97fe6bda3aee5bc61a0d0de3459069bc947e1 Mon Sep 17 00:00:00 2001From: Pierre Langlois <pierre.langlois@gmx.com>Date: Tue, 8 Oct 2019 14:38:32 +0100Subject: [PATCH] gnu: python2-tqdm: Depend on python2-functools32.
* gnu/packages/python-xyz.scm (python-tqdm)[properties]: Add python2-variant.(python2-tqdm): Use 'strip-python2-variant'.[native-inputs]: Add python2-functools32.--- gnu/packages/python-xyz.scm | 9 +++++++-- 1 file changed, 7 insertions(+), 2 deletions(-)
Toggle diff (22 lines)diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scmindex b0f5ec7588..c30532266c 100644--- a/gnu/packages/python-xyz.scm+++ b/gnu/packages/python-xyz.scm@@ -13746,10 +13746,15 @@ ignoring formatting changes.") "Make loops show a progress bar on the console by just wrapping any iterable with @code{|tqdm(iterable)|}. Offers many options to define design and layout.")- (license (list license:mpl2.0 license:expat))))+ (license (list license:mpl2.0 license:expat))+ (properties `((python2-variant . ,(delay python2-tqdm))))))
(define-public python2-tqdm- (package-with-python2 python-tqdm))+ (let ((tqdm (package-with-python2+ (strip-python2-variant python-tqdm))))+ (package (inherit tqdm)+ (native-inputs `(("python2-functools32" ,python2-functools32)+ ,@(package-native-inputs tqdm))))))
(define-public python-pkginfo (package
--2.23.0
Thanks,Pierre
M
M
Marius Bakke wrote on 8 Oct 2019 23:19
(name . Pierre Langlois)(address . pierre.langlois@gmx.com)
871rvn540g.fsf@devup.no
Pierre Langlois <pierre.langlois@gmx.com> writes:
Toggle quote (27 lines)> Hi Guix!>> This fixes the python2-tqdm package which failed to build for me since> core-updates was merged:>> ```> starting phase `check'> running "python setup.py" with command "test" and parameters ()> running test> Searching for functools32> Reading https://pypi.org/simple/functools32/> Download error on https://pypi.org/simple/functools32/: [Errno -2] Name or service not known -- Some packages may not be found!> Couldn't find index page for 'functools32' (maybe misspelled?)> Scanning index of all packages (this may take a while)> Reading https://pypi.org/simple/> Download error on https://pypi.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!> No local packages or working download links found for functools32> error: Could not find suitable distribution for Requirement.parse('functools32')> command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with status 1> builder for `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed with exit code 1> build of /gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv failed> View build log at '/var/log/guix/drvs/p3/v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv.bz2'.> guix build: error: build of `/gnu/store/p3v9nnxsk9bl0lxcd2zfzkgx56sv1q11-python2-tqdm-4.19.6.drv' failed> ```>> Adding python2-functools32 as a native-input fixes the issue.
Thanks! Pushed in f875d76f16.
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2c/W8ACgkQoqBt8qM6VPoIkQf/YgFttFC5n4zA6GDZK2SAzPm0/h1QciFDdOTlutUBdTMNfP6qk7NJexn/q3qF7CkBtNKYfrfxsjxNlhvpfNk+KK66SOVVLOIYtGJlLP/pPLt2wSBvpie4dytDH5vdfgVYJOn5cxvAyYqxz9W4FE2V9cqM5WW2z8SyD1G2msTnL52W2Z6vZ4EJ4QBh7jjU8SoBxDd0UH12+fW8Y37euzkuXOG0ur6FIWPkrzxjkswPT7q1h4idCj9dkQnxeoHt8wU/oEgsxJwnOdpgvf23TF7yvE/6jV6GJjOhUk+QvukxQVzBDGeL7mS1m2vEzkYqw82Fum1Veec4KqdStPCVJbYaAA===MoSP-----END PGP SIGNATURE-----
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 37661@debbugs.gnu.org