[PATCH] gnu: Add r-oai.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 3 Oct 2019 15:51
(address . guix-patches@gnu.org)
20191003135130.12579-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-oai): new variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3a9a605efe..479f5f4e46 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15637,3 +15637,29 @@ unique identifiers, and whether it is a certain length. In addition,
files and to efficiently import multiple tabular data files into one
data.table.")
(license license:gpl3)))
+
+(define-public r-oai
+ (package
+ (name "r-oai")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "oai" version))
+ (sha256
+ (base32
+ "1ipw9bq3ra66d1ddj1rylyyd20mlcb2i7phzhywra53s1fdifq1g"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-xml2" ,r-xml2)
+ ("r-httr" ,r-httr)
+ ("r-plyr" ,r-plyr)
+ ("r-stringr" ,r-stringr)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/ropensci/oai/")
+ (synopsis "General purpose OAI-PMH services client")
+ (description "@code{oai} provides a general purpose client to work with
+any @dfn{Open Archives Initiative Protocol for 'Metadata' Harvesting} (OAI-PMH)
+service. Functions are provided to work with the OAI-PMH verbs:
+@code{GetRecord}, @code{Identify}, @code{ListIdentifiers},
+@code{ListMetadataFormats}, @code{ListRecords}, and @code{ListSets}.")
+ (license license:expat)))
--
2.23.0
M
M
Marius Bakke wrote on 21 Mar 2020 21:18
878sjt5umm.fsf@devup.no
Wiktor ?elazny <wz@freeshell.de> writes:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-oai): new variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl52drEACgkQoqBt8qM6
VPoaqQf8DFO4VtECa2EX9J+PyOa/2Q5g7Jj2k9qrg5Vjq9xmdbdp8PRbstTGGlMO
mEdK8cO2owRV0iDblIaqduPG3MK+BBojncRliu8sMTIo/0XIl7JB5zN+F2Valk6u
cUBlz0HB/rxAWbD+5ia8jMVy71nFViyA3YtDz/JHRi+EK/LmYvNC7NmnmNpv6hcy
q5y4g1+Izt4fvPtp+SZVeqM8BvqAV5hwuLhd+c3t0VWjJqxS9ErD0Bi8hKFZ87ML
j3YLpoO4LVctLpZgcQ18yINHoZ4XElGQbjLgYlJ7svV69fBeT7/ubLwfJgDjQ68a
xH375g+z+TgZ9FhpZg0pO2C/GqxS4A==
=ccxk
-----END PGP SIGNATURE-----

Closed
?