[PATCH] gnu: Add makeself-safeextract.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Pierre Neidhardt
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 19 Sep 2019 12:35
(address . guix-patches@gnu.org)
20190919103552.1415-1-mail@ambrevar.xyz
* gnu/packages/compression.scm (makeself-safeextract): New variable.
---
gnu/packages/compression.scm | 49 +++++++++++++++++++++++++++++++++++-
1 file changed, 48 insertions(+), 1 deletion(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index bda43bfd18..9785fa7a60 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
-;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
@@ -48,6 +48,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages assembly)
#:use-module (gnu packages autotools)
@@ -2000,3 +2001,49 @@ external compressors: the compressor to be used for each format is configurable
at run time, and must be installed separately.")
(license (list license:bsd-2 ; arg_parser.{cc,h}
license:gpl2+)))) ; the rest
+
+(define-public makeself-safeextract
+ (let ((commit "1a95e121fa8e3c02d307ae37b9b7834e616c3683"))
+ (package
+ (name "makeself-safeextract")
+ (version (git-version "0.0.0" "1" commit))
+ (home-page "https://github.com/ssokolow/makeself_safeextract")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1anlinaj9lvfi8bn00wp11vzqq0f9sig4fm9yrspisx31v0z4a2c"))))
+ (build-system trivial-build-system)
+ (inputs
+ `(("python" ,python-2)
+ ("p7zip" ,p7zip)
+ ("unzip" ,unzip)))
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let* ((name "makeself_safeextract")
+ (source (string-append (assoc-ref %build-inputs "source")
+ "/" name ".py"))
+ (bin (string-append (assoc-ref %outputs "out") "/bin"))
+ (target (string-append bin "/" name))
+ (python (string-append (assoc-ref %build-inputs "python") "/bin"))
+ (7z (string-append (assoc-ref %build-inputs "p7zip") "/bin/7z"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip") "/bin/unzip")))
+ (setenv "PATH" (string-append (getenv "PATH") ":" python))
+ (mkdir-p bin)
+ (copy-file source target)
+ (substitute* target
+ (("'7z'") (format #f "'~a'" 7z))
+ (("'unzip'") (format #f "'~a'" unzip)))
+ (patch-shebang target)))))
+ (synopsis "Extract makeself and mojo archives without running untrusted code")
+ (description "A simple script to unpack makeself-generated
+self-extractors without running the possibly untrusted shell script.")
+ (license license:gpl3+))))
--
2.23.0
L
L
Ludovic Courtès wrote on 26 Sep 2019 23:09
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 37457@debbugs.gnu.org)
87k19uix2h.fsf@gnu.org
Hello,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (2 lines)
> * gnu/packages/compression.scm (makeself-safeextract): New variable.

[...]

Toggle quote (4 lines)
> + (synopsis "Extract makeself and mojo archives without running untrusted code")
> + (description "A simple script to unpack makeself-generated
> +self-extractors without running the possibly untrusted shell script.")

What about:

This package provides a script to unpack self-extracting archives
generated by @command{makeself} or @command{mojo} without running the
possibly untrusted extraction shell script.

?

(I didn’t know about these things.)

Otherwise LGTM, thanks!

Ludo’.
P
P
Pierre Neidhardt wrote on 27 Sep 2019 09:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37457@debbugs.gnu.org)
87y2yab27b.fsf@ambrevar.xyz
Done, thanks!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2NwRgACgkQm9z0l6S7
zH+9UAf9G4FAOBi5K9ISABNNNgxxWgzEkRT2JgAd+i0wct9MsCxFJDFbCM2+IwGO
v9P+vG3GOzvil5H0/S2+8j2YsTUxarJ226ImwSDRXC0k6DRn4dqkQ/JFG5dfpT/3
uREVzML7UVTi1aC2W9MbP+IUbv40wmcbE2kXD5VNuu/aXhET70cpbaaOR5MxtlLi
EaAGY7hAFoemoB+5YvRqHgVxWf78BsLGtFWfsOzH2HIilMGTnmFbARxpTzw661A/
6UQrzWdFhQjXDDEzFk0xcAhc6znKdlXm5S8vAHOJ4dL1a/NQXZV9pBQVOFUakct3
eJAx2aAyMUrDj7KttiszN54h+A3beA==
=sFnf
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 27 Sep 2019 09:58
control message for bug #37457
(address . control@debbugs.gnu.org)
87v9teb26i.fsf@ambrevar.xyz
close 37457
quit
R
R
Ricardo Wurmus wrote on 27 Sep 2019 22:01
Re: [bug#37457] [PATCH] gnu: Add makeself-safeextract.
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87zhipfr07.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (2 lines)
> Done, thanks!

Thanks, closing.

--
Ricardo
Closed
P
P
Pierre Neidhardt wrote on 27 Sep 2019 22:07
(name . Ricardo Wurmus)(address . rekado@elephly.net)
871rw1bj08.fsf@ambrevar.xyz
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (2 lines)
> Thanks, closing.

Hmm? I had already closed it, hadn't I?
I received a confirmation from control@debbugs.gnu.org.

Toggle snippet (11 lines)
Processing commands for control@debbugs.gnu.org:

> close 37457
bug#37457: [PATCH] gnu: Add makeself-safeextract.
bug closed, send any further explanations to
37457@debbugs.gnu.org and Pierre Neidhardt <mail@ambrevar.xyz>

> quit
Stopping processing here.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2ObAcACgkQm9z0l6S7
zH9lFgf+LBDaHHgFcT+EL+rG42JNtxKWC+8PJBplca9C5jC6Q1dnNKnH6Oy4XUA/
ENR2DhCx4fAZx0zubdVbpfuLn7aGs0gYU1K3NbDpOg7wjRq/dsGTzFk6q9AfkGtc
z4aFD9FbX+BuF6d9oQgza4odAm+cByq2vJNglmHVG+qvpmkgQcfxPdWBzZUTBCmS
u9ZIQR0I1yRDcLxJJETqVNBO/pkL0Xm/x0Z/X8IdPtRsyy4Or8Mhin+gAq1mXi7C
BPMldS4jaEtoQPfyokTHetyiJkydPuKSxkqfn/o01ylNKjNM/rehVmyR9Q2cbjKt
qtxQc7juoA0I7+0EdhHM1arM7v/4Tw==
=vlN7
-----END PGP SIGNATURE-----

Closed
R
R
Ricardo Wurmus wrote on 27 Sep 2019 23:58
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87r241flkp.fsf@elephly.net
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (7 lines)
> Ricardo Wurmus <rekado@elephly.net> writes:
>
>> Thanks, closing.
>
> Hmm? I had already closed it, hadn't I?
> I received a confirmation from control@debbugs.gnu.org.

Oh, my bad. I only saw a last email without message to
*-done@debbugs.gnu.org; didn’t stop to check the current status of the
issue first.

--
Ricardo
Closed
?