[PATCH] gnu: Add python-bibtexparser.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 16 Sep 2019 18:19
(address . guix-patches@gnu.org)
20190916161939.26079-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/python-xyz.scm (python-bibtexparser): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4541604873..21fed40cc3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2019 Wiktor ?elazny <wzelazny@vurv.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16265,3 +16266,24 @@ ElementTree library and for the @uref{http://lxml.de, lxml.etree} library.
For lxml.etree this package can be useful for providing XPath 2.0 selectors,
because lxml.etree already has it's own implementation of XPath 1.0.")
(license license:expat)))
+
+(define-public python-bibtexparser
+ (package
+ (name "python-bibtexparser")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bibtexparser" version))
+ (sha256
+ (base32
+ "0zwhfkrzf3n5847dbnfng92k7ak199l9v6x6ax3dgdidfpm6d2fz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyparsing" ,python-pyparsing)))
+ (native-inputs
+ `(("python-future" ,python-future)))
+ (home-page "https://github.com/sciunto-org/python-bibtexparser")
+ (synopsis "Python library to parse bibtex files")
+ (description "BibtexParser is a python library to parse bibtex files.")
+ (license (list license:bsd-3 license:lgpl3))))
--
2.23.0
L
L
Ludovic Courtès wrote on 20 Sep 2019 22:49
(name . Wiktor ?elazny)(address . wz@freeshell.de)(address . 37431-done@debbugs.gnu.org)
8736gqpubn.fsf@gnu.org
Wiktor ?elazny <wz@freeshell.de> skribis:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/python-xyz.scm (python-bibtexparser): New variable.

Applied with the minor changes below, thanks!

Ludo’.
Toggle diff (13 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a9ca56aeed..69c8e63ecf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16395,6 +16395,6 @@ because lxml.etree already has it's own implementation of XPath 1.0.")
(native-inputs
`(("python-future" ,python-future)))
(home-page "https://github.com/sciunto-org/python-bibtexparser")
- (synopsis "Python library to parse bibtex files")
- (description "BibtexParser is a python library to parse bibtex files.")
+ (synopsis "Python library to parse BibTeX files")
+ (description "BibtexParser is a Python library to parse BibTeX files.")
(license (list license:bsd-3 license:lgpl3))))
Closed
?