[PATCH] Update python-language-server - current version not compat with python-jedi 0.15.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Brian Leung
Severity
normal
B
B
Brian Leung wrote on 11 Sep 2019 20:00
(address . guix-patches@gnu.org)
CAAc=MExrtJ32TR0M_Fi2Mhz9_Mk2-Cwvq8Y8eH9TGY6c1sKXSg@mail.gmail.com
See attached.
Attachment: file
From d0649cf203fa02b33842a54afd990745d9b1fb93 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Wed, 11 Sep 2019 19:15:22 +0200
Subject: [PATCH] gnu: python-language-server: Update to 0.28.3-1.c3cab77.

* gnu/packages/python-xyz.scm (python-language-server): Update to 0.28.3-1.c3cab77.
---
gnu/packages/python-xyz.scm | 62 ++++++++++++++++++++-----------------
1 file changed, 34 insertions(+), 28 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 819b3045a3..0be212fb4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2984,38 +2984,44 @@ Language (TOML) configuration files.")
Server (PLS).")
(license license:expat)))
+;; XXX: We must use a non-release version since the latest release version
+;; requires python-jedi version < 0.15.
(define-public python-language-server
- (package
- (name "python-language-server")
- (version "0.28.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-language-server" version))
- (sha256
- (base32
- "1qbiij208l6g1l5hzihx8badhmqkxdk0spn7gm7564yg54zdp2g2"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-pluggy" ,python-pluggy)
- ("python-jsonrpc-server" ,python-jsonrpc-server)
- ("python-jedi" ,python-jedi)
- ("python-yapf" ,python-yapf)
- ("python-pyflakes" ,python-pyflakes)
- ("python-pydocstyle" ,python-pydocstyle)
- ("python-pycodestyle" ,python-pycodestyle)
- ("python-mccabe" ,python-mccabe)
- ("python-rope" ,python-rope)
- ("python-autopep8" ,python-autopep8)
- ("python-pylint" ,python-pylint)))
- (home-page "https://github.com/palantir/python-language-server")
- (synopsis "Python implementation of the Language Server Protocol")
- (description
- "The Python Language Server (pyls) is an implementation of the Python 3
+ (let ((commit "c3cab77a85b1de4af1aec1bafea6a7320d6baec5")
+ (revision "1"))
+ (package
+ (name "python-language-server")
+ (version (git-version "0.28.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/palantir/python-language-server.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1q0xdwgln09sh58j0ryygj92hfgdhwcs57zjvqihya23jr5v0bz4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pluggy" ,python-pluggy)
+ ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-jedi" ,python-jedi)
+ ("python-yapf" ,python-yapf)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-mccabe" ,python-mccabe)
+ ("python-rope" ,python-rope)
+ ("python-autopep8" ,python-autopep8)
+ ("python-pylint" ,python-pylint)))
+ (home-page "https://github.com/palantir/python-language-server")
+ (synopsis "Python implementation of the Language Server Protocol")
+ (description
+ "The Python Language Server (pyls) is an implementation of the Python 3
language specification for the Language Server Protocol (LSP). This tool is
used in text editing environments to provide a complete and integrated
feature-set for programming Python effectively.")
- (license license:expat)))
+ (license license:expat))))
(define-public python-black
(package
--
2.23.0
B
B
Brian Leung wrote on 12 Sep 2019 00:39
CAAc=MEw11vKDboSdKD7dGmf8nNzt2eNYt92VCD6W2SZYoTZnvQ@mail.gmail.com
Hi Maxim,

Thanks for updating python-jedi. Currently, only the latest commit of
python-language server is compatible with jedi > 0.15, so I thought I'd
make the appropriate changes to our version of python-language-server.

Best,
Brian
Attachment: file
From d0649cf203fa02b33842a54afd990745d9b1fb93 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Wed, 11 Sep 2019 19:15:22 +0200
Subject: [PATCH] gnu: python-language-server: Update to 0.28.3-1.c3cab77.

* gnu/packages/python-xyz.scm (python-language-server): Update to 0.28.3-1.c3cab77.
---
gnu/packages/python-xyz.scm | 62 ++++++++++++++++++++-----------------
1 file changed, 34 insertions(+), 28 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 819b3045a3..0be212fb4f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2984,38 +2984,44 @@ Language (TOML) configuration files.")
Server (PLS).")
(license license:expat)))
+;; XXX: We must use a non-release version since the latest release version
+;; requires python-jedi version < 0.15.
(define-public python-language-server
- (package
- (name "python-language-server")
- (version "0.28.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-language-server" version))
- (sha256
- (base32
- "1qbiij208l6g1l5hzihx8badhmqkxdk0spn7gm7564yg54zdp2g2"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-pluggy" ,python-pluggy)
- ("python-jsonrpc-server" ,python-jsonrpc-server)
- ("python-jedi" ,python-jedi)
- ("python-yapf" ,python-yapf)
- ("python-pyflakes" ,python-pyflakes)
- ("python-pydocstyle" ,python-pydocstyle)
- ("python-pycodestyle" ,python-pycodestyle)
- ("python-mccabe" ,python-mccabe)
- ("python-rope" ,python-rope)
- ("python-autopep8" ,python-autopep8)
- ("python-pylint" ,python-pylint)))
- (home-page "https://github.com/palantir/python-language-server")
- (synopsis "Python implementation of the Language Server Protocol")
- (description
- "The Python Language Server (pyls) is an implementation of the Python 3
+ (let ((commit "c3cab77a85b1de4af1aec1bafea6a7320d6baec5")
+ (revision "1"))
+ (package
+ (name "python-language-server")
+ (version (git-version "0.28.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/palantir/python-language-server.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1q0xdwgln09sh58j0ryygj92hfgdhwcs57zjvqihya23jr5v0bz4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pluggy" ,python-pluggy)
+ ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-jedi" ,python-jedi)
+ ("python-yapf" ,python-yapf)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-mccabe" ,python-mccabe)
+ ("python-rope" ,python-rope)
+ ("python-autopep8" ,python-autopep8)
+ ("python-pylint" ,python-pylint)))
+ (home-page "https://github.com/palantir/python-language-server")
+ (synopsis "Python implementation of the Language Server Protocol")
+ (description
+ "The Python Language Server (pyls) is an implementation of the Python 3
language specification for the Language Server Protocol (LSP). This tool is
used in text editing environments to provide a complete and integrated
feature-set for programming Python effectively.")
- (license license:expat)))
+ (license license:expat))))
(define-public python-black
(package
--
2.23.0
M
M
Maxim Cournoyer wrote on 12 Sep 2019 02:49
(name . Brian Leung)(address . bkleung89@gmail.com)(address . 37383-done@debbugs.gnu.org)
87mufa9w41.fsf@gmail.com
Hello Brian,

Brian Leung <bkleung89@gmail.com> writes:

Toggle quote (6 lines)
> Hi Maxim,
>
> Thanks for updating python-jedi. Currently, only the latest commit of
> python-language server is compatible with jedi > 0.15, so I thought I'd
> make the appropriate changes to our version of python-language-server.

Eh, thanks for the quick heads-up, and sorry for the breakage!

I just pushed your fix to master, after reviewing this was indeed the
appropriate course of action.

Thanks again,

Maxim
Closed
?