[PATCHES] Add rust-constant-time-eq, Update rust-unicode-xid to 0.2.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • goodoldpaul
  • Ivan Petkov
Owner
unassigned
Submitted by
goodoldpaul
Severity
normal
G
G
goodoldpaul wrote on 3 Sep 2019 01:29
(address . guix-patches@gnu.org)
bb1aa08bb273a6a02922fbae44b5b4ae@autistici.org
From a371d35c4de3f60b4d9475a7c29eb507cd747d85 Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Tue, 3 Sep 2019 01:06:40 +0200
Subject: [PATCH 1/2] gnu: Add rust-constant-time-eq.

* gnu/packages/crates-io.scm (rust-constant-time-eq): New variable.
---
gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6f2a002a2f..3fbe0c748a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -251,6 +252,28 @@ colorization.")
"Low level interface to CloudABI. Contains all syscalls and related types.")
(license license:bsd-2)))
+(define-public rust-constant-time-eq
+ (package
+ (name "rust-constant-time-eq")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "constant_time_eq" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "083icpr9xb72rrdxw3p4068dcspn6ai22jy7rhl2a8grfz448nlr"))))
+ (build-system cargo-build-system)
+ (home-page "https://crates.io/crates/constant_time_eq")
+ (synopsis
+ "Compares two equal-sized byte strings in constant time")
+ (description
+ "This package compares two equal-sized byte strings in constant time. Inspired
+by the Linux kernel's @code{crypto_memneq}.")
+ (license license:cc0)))
+
(define-public rust-core-foundation-sys
(package
(name "rust-core-foundation-sys")
--
2.23.0
From 8a6313282c6651f24da4a70c2d633b74fdcebea0 Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Tue, 3 Sep 2019 01:16:29 +0200
Subject: [PATCH 2/2] gnu: rust-unicode-xid: Update to 0.2.0.

* gnu/packages/crates-io.scm (rust-unicode-xid): Update to 0.2.0.
---
gnu/packages/crates-io.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3fbe0c748a..a837d97d53 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2431,7 +2431,7 @@ with the Unicode character database.")
(define-public rust-unicode-xid
(package
(name "rust-unicode-xid")
- (version "0.1.0")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
@@ -2440,7 +2440,7 @@ with the Unicode character database.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1z57lqh4s18rr4x0j4fw4fmp9hf9346h0kmdgqsqx0fhjr3k0wpw"))))
+ "0z09fn515xm7zyr0mmdyxa9mx2f7azcpv74pqmg611iralwpcvl2"))))
(build-system cargo-build-system)
(home-page
"https://github.com/unicode-rs/unicode-xid")
--
2.23.0
I
I
Ivan Petkov wrote on 3 Sep 2019 04:53
(address . goodoldpaul@autistici.org)(address . 37291@debbugs.gnu.org)
0723EE3B-D38B-4FFB-A2F4-A7909F416233@gmail.com
Hi!

Toggle quote (2 lines)
> On Sep 2, 2019, at 4:29 PM, goodoldpaul@autistici.org wrote:

Have you checked that bumping rust-unicode-xid to 0.2.0 doesn’t break any other rust
crates which depend on it? I’m not sure if all the imported versions allow building
with both 0.1.0 and 0.2.0!

—Ivan
E
E
Efraim Flashner wrote on 3 Sep 2019 10:21
(name . Ivan Petkov)(address . ivanppetkov@gmail.com)
20190903082130.GR13917@E5400
On Mon, Sep 02, 2019 at 07:53:09PM -0700, Ivan Petkov wrote:
Toggle quote (9 lines)
> Hi!
>
> > On Sep 2, 2019, at 4:29 PM, goodoldpaul@autistici.org wrote:
>
> Have you checked that bumping rust-unicode-xid to 0.2.0 doesn’t break any other rust
> crates which depend on it? I’m not sure if all the imported versions allow building
> with both 0.1.0 and 0.2.0!
>

It likely does, I'm pretty sure I have some stuff that needs 0.1.

On the other hand, it looks good and rust-constant-time-eq was one I
meant to push anyway. So two patches pushed, and a new
rust-unicode-xid-0.1 variable created. I've also checked the ones that
need 0.1 and changed those respectively.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl1uIooACgkQQarn3Mo9
g1Fn7Q//fZbm1Vy/zd/Jg2ULgN3zdeBZjxwcgd5jciLmFswN7M8TSQtYTf5Lbb22
hP25eyhp6wkIXdvX69C7T/BPba9980DpzxSUYNEXY+GQ/EnlSQnsAowwwhhuTFds
SXlj0neP++RwerigEJsZOOgnKBzzn7KoRAuF+3lCPMcwkAwu6H8DvdXUwPdwkfml
uRyj6NaANOyrgFA2ZURjtveUqilgIqkYd4y7PWNV0MwhbMFrVLN3sS6UhLZbiEVV
5w/TEQ4RK3dAHjHQTx862jWbnbeQmvcQDm11Fww+RBH5jiarkbd6v1rlPa0AeVo9
VIGd2ZOK+h3wuA4mD1KNyEU/WeWSeRX0KL1fS27/AYMrri1FrzupbcMK5ejiQ3w3
u3b8tcox2Bw2tdN51LowoXQic7l8MHDcpM3GnMihepNUbfJxuvcffMn9aoVQSLBB
xEDfQqfqqha08cHPDQgo2cI0iB2aEvfYzgR4dOKJ7UJ3dK977H81xVwNvhlm5U3D
FItcsXqJf93dEOZJAUeLC4REwzf9NHsJo5T9BLpePdBxc57TNrxaQPrudbiba4m7
WtrpsbYLaJfc+KnY4+jPAPtgW4bXQPKUbql4iKXahuQtETT2tzYC5ycD7caeW9Yh
Iv7PXC3Enx6fN730fwXZRmP6ehUULdCnAdlGpgToAlbwrzSPNKg=
=VWKl
-----END PGP SIGNATURE-----


Closed
?