[PATCH] gnu: Add opencsg.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Steve Sprang
Owner
unassigned
Submitted by
Steve Sprang
Severity
normal
S
S
Steve Sprang wrote on 24 Aug 2019 02:25
(address . guix-patches@gnu.org)
CA+xn8YAknYJYx9XYxr7qgNuKJzuaTzPTOPa=_0WONOtO4bd5Wg@mail.gmail.com

From 796d4013b78bb596690f254bdc08f89143805ace Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Fri, 23 Aug 2019 15:38:42 -0700
Subject: [PATCH] gnu: Add opencsg.

* gnu/packages/graphics.scm (opencsg): New variable.
---
gnu/packages/graphics.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ee56dae54e..9071884a3c 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1018,3 +1019,41 @@ requirements.")
performance subdivision surface (subdiv) evaluation on massively parallel CPU
and GPU architectures.")
(license license:asl2.0)))
+
+(define-public opencsg
+ (package
+ (name "opencsg")
+ (version "1.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/floriankirsch/OpenCSG/"
+ "archive/opencsg-"
+ (string-map
+ (lambda (c)
+ (if (char=? c #\.) #\- c)) version)
+ "-release.tar.gz"))
+ (sha256
+ (base32
+ "0b18gb7w9rpwkrjrkxx9apy17v5infgh2hnbzg9y3f54rxcjwx1c"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/Makefile"
+ (("/usr/local") (assoc-ref outputs "out")))
+ #t))
+ (add-before 'build 'skip-example
+ (lambda _ (chdir "src") #t)))))
+ (inputs
+ `(("glew" ,glew)
+ ("freeglut" ,freeglut)))
+ (synopsis "Library for rendering Constructive Solid Geometry (CSG)")
+ (description
+ "OpenCSG is a library for rendering Constructive Solid Geometry (CSG) using
+OpenGL. CSG is an approach for modeling complex 3D-shapes using simpler ones.
+For example, two shapes can be combined by uniting them, by intersecting them,
+or by subtracting one shape from the other.")
+ (home-page "http://www.opencsg.org/")
+ (license license:gpl2)))
--
2.23.0
S
S
Steve Sprang wrote on 29 Aug 2019 22:44
Re: bug#37170: Acknowledgement ([PATCH] gnu: Add opencsg.)
(address . 37170@debbugs.gnu.org)
CA+xn8YBe6KCuDUHxVJiHgYEyDAfti8GYRERPXM2jC9a+rsfz+Q@mail.gmail.com
Here's an updated patch. Switched from url-fetch to git-fetch and
fixed lint complaints.

On Fri, Aug 23, 2019 at 5:26 PM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
Toggle quote (22 lines)
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 37170@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 37170: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37170
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
From 76a898ef18a9d2cee77bbb1bae3fc1878d6bd1c3 Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Fri, 23 Aug 2019 15:38:42 -0700
Subject: [PATCH] gnu: Add opencsg.

* gnu/packages/graphics.scm (opencsg): New variable.
---
gnu/packages/graphics.scm | 41 +++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ee56dae54e..1f1871d4ed 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1018,3 +1019,43 @@ requirements.")
performance subdivision surface (subdiv) evaluation on massively parallel CPU
and GPU architectures.")
(license license:asl2.0)))
+
+(define-public opencsg
+ (let ((dot-to-dash (lambda (c) (if (char=? c #\.) #\- c))))
+ (package
+ (name "opencsg")
+ (version "1.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/floriankirsch/OpenCSG.git")
+ (commit (string-append "opencsg-"
+ (string-map dot-to-dash version)
+ "-release"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00m4vs6jn3scqczscc4591l1d6zg6anqp9v1ldf9ymf70rdyvm7m"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "src/Makefile"
+ (("/usr/local") (assoc-ref outputs "out")))
+ #t))
+ (add-before 'build 'skip-example
+ (lambda _ (chdir "src") #t)))))
+ (inputs
+ `(("glew" ,glew)
+ ("freeglut" ,freeglut)))
+ (synopsis "Library for rendering Constructive Solid Geometry (CSG)")
+ (description
+ "OpenCSG is a library for rendering Constructive Solid Geometry (CSG) using
+OpenGL. CSG is an approach for modeling complex 3D-shapes using simpler ones.
+For example, two shapes can be combined by uniting them, by intersecting them,
+or by subtracting one shape from the other.")
+ (home-page "http://www.opencsg.org/")
+ (license license:gpl2))))
--
2.23.0
L
L
Ludovic Courtès wrote on 10 Sep 2019 23:25
Re: [bug#37170] Acknowledgement ([PATCH] gnu: Add opencsg.)
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 37170-done@debbugs.gnu.org)
87lfuv26aa.fsf@gnu.org
Hi Steve,

Steve Sprang <steve.sprang@gmail.com> skribis:

Toggle quote (7 lines)
> From 76a898ef18a9d2cee77bbb1bae3fc1878d6bd1c3 Mon Sep 17 00:00:00 2001
> From: Steve Sprang <scs@stevesprang.com>
> Date: Fri, 23 Aug 2019 15:38:42 -0700
> Subject: [PATCH] gnu: Add opencsg.
>
> * gnu/packages/graphics.scm (opencsg): New variable.

Applied, sorry for the delay!

Ludo’.
Closed
?