[PATCH] gnu: Add speedcrunch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Steve Sprang
Owner
unassigned
Submitted by
Steve Sprang
Severity
normal
S
S
Steve Sprang wrote on 22 Aug 2019 02:25
(address . guix-patches@gnu.org)
CA+xn8YBM84b7X=6N=oq2qrgQKkvAfHRgi2HgU3P98J86E8zW+A@mail.gmail.com

From a3dfe6c0fa6f5fddc3c47e7501e37ba11902eb80 Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Wed, 21 Aug 2019 17:17:02 -0700
Subject: [PATCH] gnu: Add speedcrunch.

* gnu/packages/maths.scm (speedcrunch): New variable.
---
gnu/packages/maths.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 57deb15d7d..156ec9a954 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5136,3 +5137,33 @@ algorithm, a parametric integer programming solver, and primitives for
termination analysis via the automatic synthesis of linear ranking
functions.")
(license license:gpl3+)))
+
+(define-public speedcrunch
+ (package
+ (name "speedcrunch")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/heldercorreia/"
+ "speedcrunch/get/release-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0j70r81mkzazf0jp5fhm8vhmj1vbbknqh0jxi4gnvwbzbhrlvmlf"))))
+ (build-system cmake-build-system)
+ (inputs `(("qt" ,qt)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-to-src
+ (lambda _ (chdir "src") #t)))))
+ (synopsis "High-precision scientific calculator")
+ (description
+ "SpeedCrunch is a high-precision scientific calculator. It features a
+syntax-highlighted scrollable display and is designed to be fully used via
+keyboard. Some distinctive features are auto-completion of functions and
+variables, a formula book, and quick insertion of constants from various
+fields of knowledge.")
+ (home-page "http://speedcrunch.org/")
+ (license license:gpl2+)))
+
--
2.23.0
L
L
Ludovic Courtès wrote on 28 Aug 2019 18:33
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 37138@debbugs.gnu.org)
87a7btgsh2.fsf@gnu.org
Hello Steve,

Steve Sprang <steve.sprang@gmail.com> skribis:

Toggle quote (7 lines)
> From a3dfe6c0fa6f5fddc3c47e7501e37ba11902eb80 Mon Sep 17 00:00:00 2001
> From: Steve Sprang <scs@stevesprang.com>
> Date: Wed, 21 Aug 2019 17:17:02 -0700
> Subject: [PATCH] gnu: Add speedcrunch.
>
> * gnu/packages/maths.scm (speedcrunch): New variable.

Nice. A couple of comments:

Toggle quote (6 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "https://bitbucket.org/heldercorreia/"
> + "speedcrunch/get/release-" version
> + ".tar.gz"))

I suspect this /get URL returns a generated tarball, whose exact content
might change over time. If that is the case, could you instead use
‘git-fetch’ (or ‘hg-fetch’)?

Toggle quote (2 lines)
> + (inputs `(("qt" ,qt)))

Please use ‘qtbase’ & co., aka. the “modular Qt packages”. The ‘qt’
package is the old monolithic package and is actually deprecated.

Could you send an updated patch?

Thanks!

Ludo’.
S
S
Steve Sprang wrote on 28 Aug 2019 22:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37138@debbugs.gnu.org)
CA+xn8YCGF6GiXwptAfrnQUfXioMGgsh=yvhBnBPcg15yQfK5Cw@mail.gmail.com
Thanks for the feedback! Attached an updated patch.

-Steve

On Wed, Aug 28, 2019 at 9:33 AM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (34 lines)
>
> Hello Steve,
>
> Steve Sprang <steve.sprang@gmail.com> skribis:
>
> > From a3dfe6c0fa6f5fddc3c47e7501e37ba11902eb80 Mon Sep 17 00:00:00 2001
> > From: Steve Sprang <scs@stevesprang.com>
> > Date: Wed, 21 Aug 2019 17:17:02 -0700
> > Subject: [PATCH] gnu: Add speedcrunch.
> >
> > * gnu/packages/maths.scm (speedcrunch): New variable.
>
> Nice. A couple of comments:
>
> > + (source (origin
> > + (method url-fetch)
> > + (uri (string-append "https://bitbucket.org/heldercorreia/"
> > + "speedcrunch/get/release-" version
> > + ".tar.gz"))
>
> I suspect this /get URL returns a generated tarball, whose exact content
> might change over time. If that is the case, could you instead use
> ‘git-fetch’ (or ‘hg-fetch’)?
>
> > + (inputs `(("qt" ,qt)))
>
> Please use ‘qtbase’ & co., aka. the “modular Qt packages”. The ‘qt’
> package is the old monolithic package and is actually deprecated.
>
> Could you send an updated patch?
>
> Thanks!
>
> Ludo’.
From 6726ff51bde52459c1b27b4441c2fd070e489364 Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Wed, 21 Aug 2019 17:17:02 -0700
Subject: [PATCH] gnu: Add speedcrunch.

* gnu/packages/maths.scm (speedcrunch): New variable.
---
gnu/packages/maths.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 57deb15d7d..0f2acece3b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5136,3 +5137,36 @@ algorithm, a parametric integer programming solver, and primitives for
termination analysis via the automatic synthesis of linear ranking
functions.")
(license license:gpl3+)))
+
+(define-public speedcrunch
+ (package
+ (name "speedcrunch")
+ (version "0.12.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://bitbucket.org/heldercorreia/speedcrunch.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vh7cd1915bjqzkdp3sk25ngy8cq624mkh8c53c5bnzk357kb0fk"))))
+ (build-system cmake-build-system)
+ (inputs `(("qtbase" ,qtbase)))
+ (native-inputs `(("qttools" ,qttools)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-to-src
+ (lambda _ (chdir "src") #t)))))
+ (synopsis "High-precision scientific calculator")
+ (description
+ "SpeedCrunch is a high-precision scientific calculator. It features a
+syntax-highlighted scrollable display and is designed to be fully used via
+keyboard. Some distinctive features are auto-completion of functions and
+variables, a formula book, and quick insertion of constants from various
+fields of knowledge.")
+ (home-page "http://speedcrunch.org/")
+ (license license:gpl2+)))
+
--
2.23.0
L
L
Ludovic Courtès wrote on 31 Aug 2019 20:58
(name . Steve Sprang)(address . steve.sprang@gmail.com)(address . 37138-done@debbugs.gnu.org)
871rx1cgbw.fsf@gnu.org
Hi,

Steve Sprang <steve.sprang@gmail.com> skribis:

Toggle quote (7 lines)
> From 6726ff51bde52459c1b27b4441c2fd070e489364 Mon Sep 17 00:00:00 2001
> From: Steve Sprang <scs@stevesprang.com>
> Date: Wed, 21 Aug 2019 17:17:02 -0700
> Subject: [PATCH] gnu: Add speedcrunch.
>
> * gnu/packages/maths.scm (speedcrunch): New variable.

Perfect, applied!

Thanks,
Ludo’.
Closed
?