[PATCH] gnu: Add python-elementpath.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 20 Aug 2019 00:15
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20190819221520.7930-1-goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-elementpath): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 459d5d44e1..23227d8aef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16058,3 +16059,23 @@ one-off scripts.")
time-or-computationally-expensive properties quick and easy and works in Python
2 or 3.")
(license license:bsd-3)))
+
+(define-public python-elementpath
+ (package
+ (name "python-elementpath")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "elementpath" version))
+ (sha256
+ (base32
+ "1syn2z543brab23dskh3fjd9pqvz6npqbcicrs2d88dbg26xl08p"))))
+ (build-system python-build-system)
+ (home-page
+ "https://github.com/sissaschool/elementpath")
+ (synopsis
+ "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+ (description
+ "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+ (license license:expat)))
--
2.23.0
L
L
Ludovic Courtès wrote on 27 Aug 2019 12:43
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 37090-done@debbugs.gnu.org)
871rx6rir8.fsf@gnu.org
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-elementpath): New variable.

[...]

Toggle quote (3 lines)
> + (description
> + "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")

I copied a description from their README and committed.

Thanks,
Ludo’.
Closed
?