[PATCH] Add and update Ruby packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Leung
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brian Leung
Severity
normal
B
B
Brian Leung wrote on 13 Aug 2019 08:39
(address . guix-patches@gnu.org)
CAAc=MEwYC0gf+=2t86XRtLJx-p8+g0MAj8sSSqO-QpfzBvaD5g@mail.gmail.com
See attached.
Attachment: file
From 4f3cea946612ce06abe6daaefa0fa950762bbcac Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 13 Aug 2019 06:44:20 +0200
Subject: [PATCH 1/3] gnu: Add ruby-htmlentities.

* gnu/packages/ruby.scm (ruby-htmlentities): New variable.
---
gnu/packages/ruby.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1b70f842ae..8044c62b69 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8570,6 +8570,34 @@ characteristics.")
(home-page "https://github.com/sinatra/mustermann")
(license license:expat)))
+(define-public ruby-htmlentities
+ (package
+ (name "ruby-htmlentities")
+ (version "4.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "htmlentities" version))
+ (sha256
+ (base32
+ "1nkklqsn8ir8wizzlakncfv42i32wc0w9hxp00hvdlgjr7376nhj"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (map (lambda (file)
+ (invoke "ruby" "-Itest" file))
+ (find-files "./test" ".*_test\\.rb")))))))
+ (synopsis
+ "A module for encoding and decoding (X)HTML entities.")
+ (description
+ "This package provides a module for encoding and decoding (X)HTML entities.")
+ (home-page
+ "https://github.com/threedaymonk/htmlentities")
+ (license license:expat)))
+
(define-public ruby-sinatra
(package
(name "ruby-sinatra")
--
2.22.0
From 17a376a8a2365f7ca44358138dae036a49af7d05 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 13 Aug 2019 08:04:19 +0200
Subject: [PATCH 2/3] gnu: ruby-simplecov: Update to 0.17.0.

* gnu/packages/ruby.scm (ruby-simplecov): Update to 0.17.0.
---
gnu/packages/ruby.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8044c62b69..41bbc7d1bc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2034,13 +2034,13 @@ the SimpleCov code coverage tool for Ruby version 1.9 and above.")
(define-public ruby-simplecov
(package
(name "ruby-simplecov")
- (version "0.12.0")
+ (version "0.17.0")
(source (origin
(method url-fetch)
(uri (rubygems-uri "simplecov" version))
(sha256
(base32
- "0ffhyrfnq2zm2mc1742a4hqy475g3qa1zf6yfldwg1ldh5sn3qbx"))))
+ "0dq0nkaxvbsnl70hkimy35g4yjfs3blx4s7nbpzbvgqx72hxgv5v"))))
(build-system ruby-build-system)
;; Simplecov depends on rubocop for code style checking at build time.
;; Rubocop needs simplecov at build time.
--
2.22.0
From 2b9b07c1f551b8d2e116da37e90febe6fe04c91e Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 13 Aug 2019 08:14:16 +0200
Subject: [PATCH 3/3] gnu: ruby-nokogiri: Update to 1.10.4.

* gnu/packages/ruby.scm (ruby-nokogiri): Update to 1.10.4.
---
gnu/packages/ruby.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 41bbc7d1bc..b4f58c9110 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3648,13 +3648,13 @@ to reproduce user environments.")
(define-public ruby-nokogiri
(package
(name "ruby-nokogiri")
- (version "1.8.0")
+ (version "1.10.4")
(source (origin
(method url-fetch)
(uri (rubygems-uri "nokogiri" version))
(sha256
(base32
- "1nffsyx1xjg6v5n9rrbi8y1arrcx2i5f21cp6clgh9iwiqkr7rnn"))))
+ "0nmdrqqz1gs0fwkgzxjl4wr554gr8dc1fkrqjc2jpsvwgm41rygv"))))
(build-system ruby-build-system)
(arguments
;; Tests fail because Nokogiri can only test with an installed extension,
--
2.22.0
B
B
Brian Leung wrote on 13 Aug 2019 23:53
(address . 37017@debbugs.gnu.org)
CAAc=MEwd3R_X_YsrBwWiCfZ8S=2+BoPy+fATU8kSUfWRxp-R-g@mail.gmail.com
It turns out that one of those recipes needed something else to be updated
first, so I've redone all the commits from before.

I've also added ruby-solargraph, a LSP-compliant server for Ruby, but I'm
not very experienced with Ruby, so I can't quite figure out how to make the
test suite work on Guix.

On Tue, Aug 13, 2019 at 8:39 AM Brian Leung <bkleung89@gmail.com> wrote:

Toggle quote (2 lines)
> See attached.
>
Attachment: file
L
L
Ludovic Courtès wrote on 23 Aug 2019 23:33
Re: [bug#37017] [PATCH] Add and update Ruby packages.
(name . Brian Leung)(address . bkleung89@gmail.com)(address . 37017-done@debbugs.gnu.org)
87mufzzhw4.fsf@gnu.org
Hi Brian,

Brian Leung <bkleung89@gmail.com> skribis:

Toggle quote (7 lines)
> It turns out that one of those recipes needed something else to be updated
> first, so I've redone all the commits from before.
>
> I've also added ruby-solargraph, a LSP-compliant server for Ruby, but I'm
> not very experienced with Ruby, so I can't quite figure out how to make the
> test suite work on Guix.

Applied all the patches with minor changes to address lint warnings.

Thanks!

Ludo’.

PS: The MIME type should be “text/x-patch”, not “application/x-patch”. :-)
Closed
?