[PATCH 0/2] Add reaver

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 1 Aug 2019 16:23
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
87tvb1t157.fsf@araneo.si
Hi,

these patches add reaver and its (optional) runtime dependency pixiewps.

Timotej Lazar (2):
gnu: Add pixiewps.
gnu: Add reaver.

gnu/packages/networking.scm | 77 +++++++++++++++++++++++++++++++++++++
1 file changed, 77 insertions(+)

--
2.22.0
T
T
Timotej Lazar wrote on 1 Aug 2019 21:25
[PATCH 1/2] gnu: Add pixiewps.
(address . 36892@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20190801192559.3385-1-timotej.lazar@araneo.si
* gnu/packages/networking.scm (pixiewps): New variable.
---
gnu/packages/networking.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index fb371ed73b..6fbf5a6ebf 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2019 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -947,6 +948,34 @@ attacking, testing, and cracking. All tools are command-line driven, which
allows for heavy scripting.")
(license (list license:gpl2+ license:bsd-3))))
+(define-public pixiewps
+ (package
+ (name "pixiewps")
+ (version "1.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/wiire-a/pixiewps/releases/"
+ "download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "07nym6bqml0k9v29vnj003nrgnwrywgjvnljb7cdpsvnwilhbp64"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:tests? #f)) ; there are no tests
+ (home-page "https://github.com/wiire-a/pixiewps/")
+ (synopsis "Offline brute-force tool for Wi-Fi Protected Setup")
+ (description "Pixiewps implements the pixie-dust attack to brute
+force the Wi-Fi Protected Setup (WPS) PIN by exploiting the low or
+non-existing entropy of some access points.")
+ (license license:gpl3+)))
+
(define-public perl-danga-socket
(package
(name "perl-danga-socket")
--
2.22.0
T
T
Timotej Lazar wrote on 1 Aug 2019 21:25
[PATCH 2/2] gnu: Add reaver.
(address . 36892@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20190801192559.3385-2-timotej.lazar@araneo.si
* gnu/packages/networking.scm (reaver): New variable.
---
gnu/packages/networking.scm | 48 +++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6fbf5a6ebf..89301122b4 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -976,6 +976,54 @@ force the Wi-Fi Protected Setup (WPS) PIN by exploiting the low or
non-existing entropy of some access points.")
(license license:gpl3+)))
+(define-public reaver
+ (package
+ (name "reaver")
+ (version "1.6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/t6x/reaver-wps-fork-t6x/releases/"
+ "download/v" version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0sva3g0kwgv143n9l3lg4qp5iiqz7nk76nr0hwivsnglbhk9sbil"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; Save session files to current directory instead of /var.
+ (list "--enable-savetocurrent"
+ "--localstatedir=/tmp/dummy") ; prevent creating /var during install
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'change-directory
+ (lambda _
+ (chdir "src")
+ #t))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir "../docs")
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version))
+ (man1 (string-append out "/share/man/man1")))
+ (for-each (lambda (file) (install-file file doc))
+ (find-files "." "README.*"))
+ (install-file "reaver.1" man1)
+ #t))))
+ #:tests? #f)) ; there are no tests
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (propagated-inputs
+ `(("aircrack-ng" ,aircrack-ng)
+ ("pixiewps" ,pixiewps)))
+ (home-page "https://github.com/t6x/reaver-wps-fork-t6x/")
+ (synopsis "Attack tool for Wi-Fi Protected Setup")
+ (description "Reaver performs a brute force attack against an access
+point's Wi-Fi Protected Setup (WPS) PIN. Once the PIN is found, the WPA
+passphrase can be recovered and the AP's wireless settings can be
+reconfigured.")
+ (license license:gpl2+)))
+
(define-public perl-danga-socket
(package
(name "perl-danga-socket")
--
2.22.0
L
L
Ludovic Courtès wrote on 22 Aug 2019 17:54
Re: [bug#36892] [PATCH 0/2] Add reaver
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 36892-done@debbugs.gnu.org)
87d0gxp54f.fsf@gnu.org
Hello,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

Toggle quote (6 lines)
> these patches add reaver and its (optional) runtime dependency pixiewps.
>
> Timotej Lazar (2):
> gnu: Add pixiewps.
> gnu: Add reaver.

Applied both, thank you!

Ludo’.
Closed
?