[PATCH] added trezord package

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • mjbecze
Owner
unassigned
Submitted by
mjbecze
Severity
normal
M
M
mjbecze wrote on 31 Jul 2019 02:11
(address . guix-patches@gnu.org)
de1ab8dd18dafb7557c6765b6377dd89@riseup.net
---
gnu/packages/trezor.scm | 48 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)
create mode 100644 gnu/packages/trezor.scm

Toggle diff (60 lines)
diff --git a/gnu/packages/trezor.scm b/gnu/packages/trezor.scm
new file mode 100644
index 0000000000..6da61d7f56
--- /dev/null
+++ b/gnu/packages/trezor.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright ? 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright ? 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or
(at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages trezor)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix download)
+ #:use-module (guix build-system go)
+ #:use-module (gnu packages golang))
+
+(define-public trezord
+ (package
+ (name "trezord")
+ (version "2.0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/trezor/trezord-go/archive/v" version
+ ".tar.gz"))
+ (sha256
+ (base32
"1r68yb1q8v3vbxi95gsq1nfjw2v59sykchrbbc2kppy3cymfk411"))
+ (file-name (string-append name "-" version "-source"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/trezor/trezord-go"))
+ (home-page "https://trezor.io")
+ (synopsis "Trezor Communication Daemon aka Trezor Bridge (written
in Go)")
+ (description "This allows a Trezor hardware wallet to communicate
to the Trezor
+ wallet.")
+ (license lgpl3+)))
--
2.22.0
M
M
Martin Becze wrote on 1 Aug 2019 03:38
(address . 36866@debbugs.gnu.org)
6db309eb-5730-3a4e-d241-21124caabe54@riseup.net
heyyy does anyone know if this is the correct way to open a PR to guix?
kinda missing easy github mode here... lol
J
J
Julien Lepiller wrote on 1 Aug 2019 08:12
71E9E80C-BB07-49CE-9F27-36ED73027AAF@lepiller.eu
Le 1 août 2019 03:38:53 GMT+02:00, Martin Becze <mjbecze@riseup.net> a écrit :
Toggle quote (3 lines)
>heyyy does anyone know if this is the correct way to open a PR to guix?
>kinda missing easy github mode here... lol

Hey Martin,

You're on the right track. Now, you just have to send your patches to this bug (36866@debbugs.gnu.org) with git send-email. If there's only one patch, you may send it as an attachment instead, but send-email is the prefered way.
J
J
Julien Lepiller wrote on 1 Aug 2019 08:48
C3A23F88-E2B3-4771-B7C1-BAEE14BE6AB7@lepiller.eu
Le 1 août 2019 08:12:25 GMT+02:00, Julien Lepiller <julien@lepiller.eu> a écrit :
Toggle quote (13 lines)
>Le 1 août 2019 03:38:53 GMT+02:00, Martin Becze <mjbecze@riseup.net> a
>écrit :
>>heyyy does anyone know if this is the correct way to open a PR to
>guix?
>>kinda missing easy github mode here... lol
>
>Hey Martin,
>
>You're on the right track. Now, you just have to send your patches to
>this bug (36866@debbugs.gnu.org) with git send-email. If there's only
>one patch, you may send it as an attachment instead, but send-email is
>the prefered way.

Hi again,

For some reason I didn't see your previous email with the patch, but I do now. Can you make sure the copyright line at the beginning is correct? It should only mentionned people who worked on that file, including you.

Github tarballs are autogenerated, but get regenerated from time to time and they are not stable. We prefer to use tge git-fetch method for github, since it is more stable. There thould be plenty of examples in the repo, but we can take care of that. Otherwise, nice patch! Could you send an updated one to this bug number? Thank you!
M
M
mjbecze wrote on 1 Aug 2019 21:31
[PATCH 2/2] fixed copyright line and use git-fetch
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 36866@debbugs.gnu.org)
73768d48571cb8b832c836c848f1d2ad@riseup.net
---
gnu/packages/trezor.scm | 17 ++++++++---------
1 file changed, 8 insertions(+), 9 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/trezor.scm b/gnu/packages/trezor.scm
index 6da61d7f56..9f43d67175 100644
--- a/gnu/packages/trezor.scm
+++ b/gnu/packages/trezor.scm
@@ -1,6 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright ? 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright ? 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright ? 2019 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,16 +27,16 @@
(define-public trezord
(package
(name "trezord")
- (version "2.0.17")
+ (version "v2.0.17")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/trezor/trezord-go/archive/v" version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/trezor/trezord-go.git")
+ (commit version)))
(sha256
- (base32
"1r68yb1q8v3vbxi95gsq1nfjw2v59sykchrbbc2kppy3cymfk411"))
- (file-name (string-append name "-" version "-source"))))
+ (base32
"0nqzpq0i3crh0i4r1cppja5sn3rwi1fv9afxzwzv63096x5l30a7"))
+ (file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/trezor/trezord-go"))
--
2.22.0
J
J
Julien Lepiller wrote on 1 Aug 2019 22:16
(address . mjbecze@riseup.net)(address . 36866-done@debbugs.gnu.org)
20190801221615.01600344@sybil.lepiller.eu
Pushed as 01b37d0f74e483c1197f82b67b8575c0771bf08c, thank you! I've put
your package definition in finance.scm, along with bitcoin-core,
monero, and other trezor stuff. I also changed the version back to what
it was in your original patch ("2.0.17" instead of "v2.0.17") and used
(string-append "v" version) as the commit.

Thank you again for your contribution!
Closed
?