[PATCH] gnu: Add oshu.

  • Done
  • quality assurance status badge
Details
4 participants
  • Dan Frumin
  • Leo Prikler
  • Tobias Geerinckx-Rice
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Dan Frumin
Severity
normal
D
D
Dan Frumin wrote on 27 Jul 2019 20:18
(address . guix-patches@gnu.org)(name . Dan Frumin)(address . dfrumin@cs.ru.nl)
20190727181841.4147-1-dfrumin@cs.ru.nl
---
gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..3bb17c5735 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,40 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+ (build-system cmake-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("ffmpeg" ,ffmpeg)
+ ("cairo" ,cairo)
+ ("pango" ,pango)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; `make test' doesn't actually build the test executable
+ (add-before 'check 'zerotokei
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Clone of the Osu! rhythm game")
+ (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful videocard. Oshu! is capable
+of playing the original Osu! beatmaps (not included in this package). ")
+ (license license:gpl3)))
+
(define-public btanks
(package
(name "btanks")
--
2.17.1
D
D
Dan Frumin wrote on 28 Jul 2019 13:42
(address . 36824@debbugs.gnu.org)
a7e9ac17-c288-7882-ab84-b6c4c1d435a6@cs.ru.nl
Sorry, I forgot to do the linting.
Here is an updated version with two spaces.

Best,
Dan

On 27-07-19 20:18, Dan Frumin wrote:
Toggle quote (50 lines)
> ---
> gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
> 1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a17ac9728c..3bb17c5735 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -6374,6 +6374,40 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
> (home-page "https://www.stepmania.com")
> (license license:expat)))
>
> +(define-public oshu
> + (package
> + (name "oshu")
> + (version "2.0.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/fmang/oshu.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
> + (build-system cmake-build-system)
> + (native-inputs `(("pkg-config" ,pkg-config)))
> + (inputs `(("sdl2" ,sdl2)
> + ("sdl2-image" ,sdl2-image)
> + ("ffmpeg" ,ffmpeg)
> + ("cairo" ,cairo)
> + ("pango" ,pango)))
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + ;; `make test' doesn't actually build the test executable
> + (add-before 'check 'zerotokei
> + (lambda _ (invoke "make" "zerotokei"))))))
> + (home-page "https://github.com/fmang/oshu/")
> + (synopsis "Clone of the Osu! rhythm game")
> + (description "Oshu! is a free clone of the Osu! rhythm game, designed to
> +be run on GNU/Linux without requiring a powerful videocard. Oshu! is capable
> +of playing the original Osu! beatmaps (not included in this package). ")
> + (license license:gpl3)))
> +
> (define-public btanks
> (package
> (name "btanks")
>
From ae5604a22c196386f514b59fb81616558a2e60f1 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

---
gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..b65c842735 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,40 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+ (build-system cmake-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("ffmpeg" ,ffmpeg)
+ ("cairo" ,cairo)
+ ("pango" ,pango)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; `make test' doesn't actually build the test executable
+ (add-before 'check 'zerotokei
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Clone of the Osu! rhythm game")
+ (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful videocard. Oshu! is capable
+of playing the original Osu! beatmaps (not included in this package). ")
+ (license license:gpl3)))
+
(define-public btanks
(package
(name "btanks")
--
2.17.1
T
T
Tobias Geerinckx-Rice wrote on 28 Jul 2019 18:07
Re: [bug#36824] [PATCH] gnu: Add oshu.
(address . 36824@debbugs.gnu.org)
87y30if8i9.fsf@nckx
Dan,

Thanks! I'm deprived of Guix for the moment, so I can't review
the package itself. Looks good on first glance, though.

Dan Frumin ???
Toggle quote (4 lines)
> (synopsis "Clone of the Osu! rhythm game")
> (description "Oshu! is a free clone of the Osu! rhythm game,
> designed to

I'd rather see a 'first-class' description of what this game is
and does and drop the 'is a clone of' part entirely: 'is capable
of playing the original Osu! beatmaps' already says it all without
implying it's some kind of knock-off ;-)

If you don't have time fo' that I understand, but you're
presumably familiar with both games & in the best position to
write something accurate.

Toggle quote (3 lines)
> be run on GNU/Linux without requiring a powerful videocard.
> Oshu! is capable

s/videocard/video card/, or graphics card. Is it really tied to
the kernel? (Not entirely implausible considering the real-time
audio nature. Interesting design, by the way.)

Toggle quote (3 lines)
> of playing the original Osu! beatmaps (not included in this
> package). ")

Could we package these separately? How are they licenced?

Toggle quote (2 lines)
> (license license:gpl3)))

Ugh, no licence headers? I guess that does make it GPL 3-only,
but I'm no expert.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXT3ILgAKCRANsP+IT1Vt
eQviAQDfkLzeOYIfT7LpUkwg7ofLKytz8MEHNdREtVhrPjW/MQD/Xp4KmO+UKG4F
pHzq9L3FPCmgWlwoockysZtnYia9bA0=
=M/S0
-----END PGP SIGNATURE-----

D
D
Dan Frumin wrote on 29 Jul 2019 13:32
Re: bug#36824: [PATCH] gnu: Add oshu.
c86bdb6f-840f-6b6a-e600-6c24d8c22806@cs.ru.nl
Hi Tobias,

Thank you for your timely reply.

(As a side note, can you please CC the messages to me, because I am not subscribed to the guix-patches mailing list. Maybe I am using debbugs in some
wrong way).

> I'd rather see a 'first-class' description of what this game is
> and does and drop the 'is a clone of' part entirely: 'is capable
> of playing the original Osu! beatmaps' already says it all without
> implying it's some kind of knock-off ;-)

That's a good point. I changed the description to something more appropriate.

> s/videocard/video card/, or graphics card. Is it really tied to
> the kernel? (Not entirely implausible considering the real-time
> audio nature. Interesting design, by the way.)

Oops, I didn't mean to say that it's tied to the Linux kernel (although I don't think it's developed/tested on other platforms). I just wanted to
contrast that with the old original Osu! game which is for Windows.

> Could we package these separately? How are they licenced?

I am not sure. You basically have to download them manually from the Osu! website or from other places on the web.
I don't think they are licensed very well at all..


> Ugh, no licence headers? I guess that does make it GPL 3-only,
> but I'm no expert.

Yeah I am not sure about the headers, but the COPYING file indicates that it's GPL 3

Best,
Dan
From e54fb4dca4988747c5c41a1081d25cdae524dd55 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

---
gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a17ac9728c..78b951b702 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6374,6 +6374,41 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01w1x46hh36idjl94xd18dwppp0y30qxmb498gp7hnjzy205q6rw"))))
+ (build-system cmake-build-system)
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("ffmpeg" ,ffmpeg)
+ ("cairo" ,cairo)
+ ("pango" ,pango)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; `make test' doesn't actually build the test executable
+ (add-before 'check 'zerotokei
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Rhythm game in which you click on circles")
+ (description "Oshu! is a free clone of the Osu! rhythm game, designed to
+be run on GNU/Linux without requiring a powerful graphics card. Oshu! is
+capable of playing the original Osu! beatmaps (not included in this
+package). ")
+ (license license:gpl3)))
+
(define-public btanks
(package
(name "btanks")
--
2.17.1
R
R
Ricardo Wurmus wrote on 29 Jul 2019 15:20
Re: [bug#36824] [PATCH] gnu: Add oshu.
(address . dfrumin@cs.ru.nl)
87r2696kpj.fsf@elephly.net
Dan Frumin <dfrumin@cs.ru.nl> writes:

Toggle quote (5 lines)
> > Ugh, no licence headers? I guess that does make it GPL 3-only,
> > but I'm no expert.
>
> Yeah I am not sure about the headers, but the COPYING file indicates that it's GPL 3

Here are more details:


The license is GPL version 3 or later.

--
Ricardo
T
T
Tobias Geerinckx-Rice wrote on 29 Jul 2019 15:29
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87mugxezpr.fsf@nckx
Ricardo,

Ricardo Wurmus ???
Toggle quote (15 lines)
> Dan Frumin <dfrumin@cs.ru.nl> writes:
>
>> > Ugh, no licence headers? I guess that does make it GPL
>> > 3-only,
>> > but I'm no expert.
>>
>> Yeah I am not sure about the headers, but the COPYING file
>> indicates that it's GPL 3
>
> Here are more details:
>
> https://github.com/fmang/oshu/blob/30b316173aca8fd6b2dce8b7d425845241ae5f13/src/oshu/main.cc#L69
>
> The license is GPL version 3 or later.

Thanks! I opened about 5 files at random through the Web interfac
but not the right one…

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXT70sAAKCRANsP+IT1Vt
eXqLAQDXgy+mJgd/D1zJzRR2/tKWFrxVwF5RYfFJK5TLm1NoSwD/T294HUorDMz9
OUYdyEG1iv6iXtPdH82CiX9H1j6TCAs=
=u2JY
-----END PGP SIGNATURE-----

L
L
Leo Prikler wrote on 20 Feb 2021 20:07
43d8ddacca5f945e71f43c146197aca584ec950c.camel@student.tugraz.at
Hello everyone,

I'm reviving this old patch and hopefully address most of the issues
raised for the old one while also sneaking in a version upgrade.

Regards,
Leo
From 6c7a1d039e2678147fe1d4f7be7e59ef58a2d661 Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

* gnu/packages/games.scm (oshu): New variable.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6726cef303..0ea972419c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8413,6 +8413,45 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g598incc6zlls876slgwqblwiwiszkmqa4xpzw0z7mbjmmzsizz"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("ffmpeg" ,ffmpeg)
+ ("cairo" ,cairo)
+ ("pango" ,pango)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ ;; `make test' doesn't actually build the test executable
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Rhythm game in which you click on circles")
+ (description "@dfn{oshu!} is a minimalist variant of the osu! rhythm game,
+which is played by pressing buttons and following along sliders as they appear
+on screen. Its aim is to be able to play any beatmap even on low-end hardware.
+
+This package provides the core application, but no beatmaps. You need to
+download and unpack them separately.")
+ (license license:gpl3+)))
+
(define-public btanks
(package
(name "btanks")
--
2.30.1
L
L
Leo Prikler wrote on 21 Feb 2021 01:36
6e81d4ac2bc090d60b571e266f6c3ebd4ea147ab.camel@student.tugraz.at
Hello again,

after Nicolas gave me some feedback in IRC I've sorted the package
fields and inputs and also now use @i for "proper names". This is
somewhat consistent with other packages in Guix.

Regards,
Leo

Am Samstag, den 20.02.2021, 20:07 +0100 schrieb Leo Prikler:
Toggle quote (7 lines)
> Hello everyone,
>
> I'm reviving this old patch and hopefully address most of the issues
> raised for the old one while also sneaking in a version upgrade.
>
> Regards,
> Leo
From 52e8d36dcb0e44133048cf8f3159ebd0e415c5ee Mon Sep 17 00:00:00 2001
From: Dan Frumin <dfrumin@cs.ru.nl>
Date: Sat, 27 Jul 2019 20:18:22 +0200
Subject: [PATCH] gnu: Add oshu.

* gnu/packages/games.scm (oshu): New variable.

Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
gnu/packages/games.scm | 39 +++++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6726cef303..0d4cba471b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8413,6 +8413,45 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public oshu
+ (package
+ (name "oshu")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fmang/oshu")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g598incc6zlls876slgwqblwiwiszkmqa4xpzw0z7mbjmmzsizz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ ;; `make test' doesn't actually build the test executable
+ (lambda _ (invoke "make" "zerotokei"))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("ffmpeg" ,ffmpeg)
+ ("pango" ,pango)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)))
+ (home-page "https://github.com/fmang/oshu/")
+ (synopsis "Rhythm game in which you click on circles")
+ (description "@i{oshu!} is a minimalist variant of the @i{osu!} rhythm game,
+which is played by pressing buttons and following along sliders as they appear
+on screen. Its aim is to be able to play any beatmap even on low-end hardware.
+
+This package provides the core application, but no beatmaps. You need to
+download and unpack them separately.")
+ (license license:gpl3+)))
+
(define-public btanks
(package
(name "btanks")
--
2.30.1
L
L
Leo Prikler wrote on 24 Feb 2021 01:06
6818b8abf6272d867fff62b7338830006a5579bf.camel@student.tugraz.at
Am Sonntag, den 21.02.2021, 01:36 +0100 schrieb Leo Prikler:
Toggle quote (9 lines)
> Hello again,
>
> after Nicolas gave me some feedback in IRC I've sorted the package
> fields and inputs and also now use @i for "proper names". This is
> somewhat consistent with other packages in Guix.
>
> Regards,
> Leo

Sliding this in as 46c5ae03cef60d78463edd2e5934ed90c1cebcd7. Hope none
of you want to spin.
Closed
?