[PATCH 0/2] Add Xygrib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 14 Jul 2019 20:03
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190714180329.31051-1-efraim@flashner.co.il
Xygrib is the continuation of Zygrib, a now abandoned weather platform
which takes the weather data produced by various governments and makes
it easily available to everyone.

I wasn't sure where to put xygrib itself. I was going to put it in a new
weather.scm module, but geo seemed like it fit.

Efraim Flashner (2):
gnu: Add libnova.
gnu: Add xygrib.

gnu/packages/astronomy.scm | 35 ++++++++++++++++++++
gnu/packages/geo.scm | 68 ++++++++++++++++++++++++++++++++++++++
2 files changed, 103 insertions(+)

--
2.22.0
E
E
Efraim Flashner wrote on 14 Jul 2019 20:05
[PATCH 1/2] gnu: Add libnova.
(address . 36652@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190714180554.31307-1-efraim@flashner.co.il
* gnu/packages/astronomy.scm (libnova): New variable.
---
gnu/packages/astronomy.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4cf7c10352..2bce26a754 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -254,3 +254,38 @@ accurately in real time at any rate desired.")
(arguments
`(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
#:tests? #f))))
+
+(define-public libnova
+ (package
+ (name "libnova")
+ (version "0.16")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/libnova/libnova.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0icwylwkixihzni0kgl0j8dx3qhqvym6zv2hkw2dy6v9zvysrb1b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-git-version
+ (lambda _
+ (substitute* "./git-version-gen"
+ (("/bin/sh") (which "sh")))
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (synopsis "Celestial mechanics, astrometry and astrodynamics library")
+ (description "Libnova is a general purpose, double precision, Celestial
+Mechanics, Astrometry and Astrodynamics library.")
+ (home-page "http://libnova.sourceforge.net/")
+ (license (list license:lgpl2.0
+ license:gpl2)))) ; examples/transforms.c & lntest/*.c
+
--
2.22.0
E
E
Efraim Flashner wrote on 14 Jul 2019 20:05
[PATCH 2/2] gnu: Add xygrib.
(address . 36652@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
20190714180554.31307-2-efraim@flashner.co.il
* gnu/packages/geo.scm (xygrib): New variable.
---
gnu/packages/geo.scm | 68 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 68 insertions(+)

Toggle diff (106 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 4cccd97643..e4b6a262c7 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages astronomy)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -44,6 +46,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -57,6 +60,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -902,3 +906,67 @@ given GPS coordinates,draws a GPS track, and points of interest on a moving
map display. Downloads map data from a number of websites, including
@url{https://www.openstreetmap.org}.")
(license license:gpl2+)))
+
+(define-public xygrib
+ (package
+ (name "xygrib")
+ (version "1.2.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opengribs/XyGrib.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qzaaavil2c7mkkai5mg54cv8r452i7psy7cg75qjja96d2d7rbd"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (delete-file-recursively "data/fonts") #t))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-directories
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((jpeg (assoc-ref inputs "openjpeg"))
+ (font (assoc-ref inputs "font-liberation")))
+ (substitute* "CMakeLists.txt"
+ ;; Find libjpeg.
+ (("/usr") jpeg)
+ ;; Fix install locations.
+ (("set\\(PREFIX_BIN.*") "set(PREFIX_BIN \"bin\")\n")
+ (("set\\(PREFIX_PKGDATA.*") "set(PREFIX_PKGDATA \"share/${PROJECT_NAME}\")\n")
+ ;; Skip looking for the static library.
+ (("\"libnova.a\"") ""))
+ ;; Don't use the bundled font-liberation.
+ (substitute* "src/util/Font.cpp"
+ (("Util::pathFonts\\(\\)\\+\"liberation-fonts/\"")
+ (string-append "\"" font "/share/fonts/truetype/\"")))
+ (substitute* "src/util/Util.h"
+ (("pathData\\(\\)\\+\"data/fonts/\"")
+ (string-append "\"" font "/share/fonts/\""))))
+ #t)))
+ #:tests? #f)) ; no tests
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("font-liberation" ,font-liberation)
+ ("libnova" ,libnova)
+ ("libpng" ,libpng)
+ ("openjpeg" ,openjpeg)
+ ("proj.4" ,proj.4)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (synopsis "Weather Forecast Visualization")
+ (description
+ "XyGrib is a Grib file reader and visualizes meteorological data providing
+an off-line capability to analyse weather forecasts or hindcasts. It is
+intended to be used as a capable weather work station for anyone with a serious
+interest in examining weather. This would include members of the sailing
+community, private and sport aviators, farmers, weather buffs and many more.
+XyGrib is the continuation of the zyGrib software package with a new team of
+volunteers.")
+ (home-page "https://opengribs.org")
+ (license license:gpl3+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 17 Jul 2019 15:12
Re: [bug#36652] [PATCH 1/2] gnu: Add libnova.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 36652@debbugs.gnu.org)
87woggby9t.fsf@gnu.org
Hello!

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> * gnu/packages/astronomy.scm (libnova): New variable.

[...]

Toggle quote (5 lines)
> + (synopsis "Celestial mechanics, astrometry and astrodynamics library")
> + (description "Libnova is a general purpose, double precision, Celestial
> +Mechanics, Astrometry and Astrodynamics library.")
> + (home-page "http://libnova.sourceforge.net/")
> + (license (list license:lgpl2.0
^

Extra space here and on the line before. :-)

From a quick sampling of the source file headers, it appears to be
‘lgpl2.0+’.


Toggle quote (2 lines)
> + license:gpl2)))) ; examples/transforms.c & lntest/*.c

These files are ‘gpl2+’ AFAICS.

Otherwise LGTM, thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 17 Jul 2019 15:13
Re: [bug#36652] [PATCH 2/2] gnu: Add xygrib.
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 36652@debbugs.gnu.org)
87sgr4by8w.fsf@gnu.org
Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> * gnu/packages/geo.scm (xygrib): New variable.

LGTM, thanks!
E
E
Efraim Flashner wrote on 18 Jul 2019 13:04
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36652-done@debbugs.gnu.org)
20190718110412.GC684@macbook41
On Wed, Jul 17, 2019 at 03:13:03PM +0200, Ludovic Courtès wrote:
Toggle quote (6 lines)
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
> > * gnu/packages/geo.scm (xygrib): New variable.
>
> LGTM, thanks!

Patches pushed

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl0wUiwACgkQQarn3Mo9
g1Fh/w/+MSvg+wJXGi/cGnuAMtOBuBd10u7Rit9A8Xr7M//jix41Ra2tuYB1TCDQ
Pd1LifGyCbUUtfruc41jmNqWNjWpnQfztWl76sjV+h0mgYhEDfuv693kzbbQNRGV
QRKzZiThFYSuT0OE/kftsgrFZjjS15lDBMjofXu4yXq06tqkoTIS86weEiQsRlv9
mTAYSAz6eLJtuUBHYg98c76caULsN2KYrICquprIVB6A0ou2FTDOBuX1M8wWVX23
sffpt241xTxXBDUjQGQ+vR7AzoGngwC0VlbRTA4pxBBrncZ/vc8Axxxi5K6iFYDt
6Muqh8zVcDfJo+Xtkw9JcRyZ7sMqhNsqWkZB5jUFWhqzscypXDyzB6jePmek0RxJ
+60/OBjthApS+OpXty1EGXOoLCvcbcl/wPUyVCwjKZFW7EzYSqMPxk6NcPhOcQGP
aPZJ+FwfpYzjzG5NWXKp6Kq8njPyrDNQJ/Z4Vf1ApI9hEaF03gsO99/DlKGtsqyd
EY1WNMYj2M8yVg+TfdGHmb3rkwqtTpp0fakbQG2R7c3YAW4dmKaCU9suyTPzyd1u
KjTBb7ukDglhvC6bPntusE/ddeWipP9FMqKUeQA6A/7NUpO2dlt2sMJjoH7wb+x2
T+W8n299GRBMu+7MZCUZ43RHFB9XZt3kcOlz8hu6gU7Ik/XJGb4=
=k+uF
-----END PGP SIGNATURE-----


Closed
?