[PATCH] gnu: hg-evolve: added package

  • Open
  • quality assurance status badge
Details
2 participants
  • Arne Babenhauserheide
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arne Babenhauserheide
Severity
normal
A
A
Arne Babenhauserheide wrote on 12 Jul 2019 23:38
(address . guix-patches@gnu.org)(name . Arne Babenhauserheide)(address . arne_bab@web.de)
20190712213805.23553-1-arne_bab@web.de
* gnu/packages/version-control.scm (hg-evolve): New package.
---
gnu/packages/version-control.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b1fd0195ce..722ec433ba 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1247,6 +1247,35 @@ It efficiently handles projects of any size
and offers an easy and intuitive interface.")
(license license:gpl2+)))

+(define-public hg-evolve
+ (package
+ (name "hg-evolve")
+ (version "9.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "hg-evolve" version))
+ (sha256
+ (base32
+ "1vq1pr2lx8jjsmhgvlrv32qyxair89r3sjsi8v3336r1c0zzx05l"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Restrict to Python 2, as Python 3 would require
+ ;; the argument --c2to3.
+ #:python ,python-2
+ ;; FIXME: Disabled tests because they require the nose unit
+ ;; testing framework: https://nose.readthedocs.org/en/latest/ .
+ #:tests? #f))
+ (propagated-inputs
+ `(("mercurial" ,mercurial)))
+ (synopsis "This package supplies the evolve extension for Mercurial")
+ (description "hg-evolve enables the “changeset evolution” feature of
+Mercurial core, provides a set of commands to mutate your history, issues
+several warning messages when troubles from some mutable appears in your
+repository, and provides an hg evolve command to deal with such “troubles”.")
+ (home-page "https://www.mercurial-scm.org/doc/evolution/")
+ (license license:gpl2+)))
+
(define-public neon
(package
(name "neon")
--
2.22.0
L
L
Ludovic Courtès wrote on 15 Jul 2019 12:46
(name . Arne Babenhauserheide)(address . arne_bab@web.de)(address . 36626@debbugs.gnu.org)
87muhfpobl.fsf@gnu.org
Hi Arne,

Arne Babenhauserheide <arne_bab@web.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/version-control.scm (hg-evolve): New package.

[...]

Toggle quote (5 lines)
> + (arguments
> + `(;; Restrict to Python 2, as Python 3 would require
> + ;; the argument --c2to3.
> + #:python ,python-2

Still, if it can be built with Python 3, we should do that because
Python 2 is approaching EOL.

Where does that that ‘--c2to3’ flag has to be passed?

Toggle quote (4 lines)
> + ;; FIXME: Disabled tests because they require the nose unit
> + ;; testing framework: https://nose.readthedocs.org/en/latest/ .
> + #:tests? #f))

There’s a ‘python-nose’ package though; could we use it?

Thanks,
Ludo’.
?