[PATCH] gnu: Add emacs-elpher.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 11 Jul 2019 22:34
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20190711203500.23812-1-arunisaac@systemreboot.net
* gnu/packages/emacs-xyz.scm (emacs-elpher): New variable.
---
gnu/packages/emacs-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d9f271cc8..78bd630ecf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16481,3 +16481,37 @@ it forcibly
@item Dedicated window for debugging program.
@end enumerate")
(license license:gpl3+))))
+
+(define-public emacs-elpher
+ (package
+ (name "emacs-elpher")
+ (version "1.4.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tgvaughan/elpher")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xansmhn4l0b9ghzf56vyx8cqg0q01aq3pz5ikx2i19v5f0rc66"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'build-doc
+ (lambda _
+ (invoke "makeinfo" "elpher.texi"))))))
+ (home-page "https://github.com/tgvaughan/elpher")
+ (synopsis "Gopher client for Emacs")
+ (description "Elpher is a full-featured gopher client for Emacs. Its
+features include intuitive keyboard and mouse-driven browsing, out-of-the-box
+compatibility with evil-mode, clickable web and gopher links in plain text,
+caching of visited sites, pleasant and configurable visualization of Gopher
+directories, direct visualisation of image files, jumping directly to links by
+name (with autocompletion), a simple bookmark management system and
+connections using TLS encryption.")
+ (license license:gpl3+)))
--
2.22.0
L
L
Ludovic Courtès wrote on 13 Jul 2019 14:49
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 36606@debbugs.gnu.org)
875zo69k1i.fsf@gnu.org
Hello,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-elpher): New variable.

Nice package. :-) LGTM!

Ludo’.
A
A
Arun Isaac wrote on 14 Jul 2019 16:58
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36606-done@debbugs.gnu.org)
cu7pnmcpss1.fsf@systemreboot.net
Thanks for the review! Pushed to master!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl0rQw4ACgkQLiXui2GA
K7MxsggAkCu4NZ1Of/jHvdEUJCtzQ8bqPKlayaXTtQ2/I45Q8sqk0sm7JPXN5tmP
1C4luNYnKOqEUnJWc/GqwQZOZmXYSPBZgADAi1a7Hjcj7FpRYhhzpt7GhpvOcJ0u
iE2z7s8ys8TVa7YyHC8FuHI9rF4JEF4IlfBA8vCxsTCLkrbMjS4cuZa7gcC536lJ
cFXJ3X3H7jdb54EMLyMorNKSmM+QZfsEI3f4yRkM9BnIFSvip0CtJh/xsC2qSgdF
Hiz88TeH56OAkSl/MyOVGt5PuHf8/ZED0hCswSNBSf8s0ZsZnoM4kExOO4jTm7sF
AyFgQHQOmtlBgaWUI5slIHFLuQ/oCg==
=pS3O
-----END PGP SIGNATURE-----

Closed
?