[PATCH] gnu: ruby: Add ruby-backport package

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Mikhail Kirillov
Owner
unassigned
Submitted by
Mikhail Kirillov
Severity
normal
M
M
Mikhail Kirillov wrote on 3 Jul 2019 00:49
(address . guix-patches@gnu.org)(name . Mikhail Kirillov)(address . w96k.ru@gmail.com)
20190702224947.17513-1-w96k.ru@gmail.com
* gnu/packages/ruby.scm (ruby): add ruby-backport package
---
gnu/packages/ruby.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 49e0b9fe73..c779bc4e7d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8725,3 +8725,35 @@ app to deliver to smtp://127.0.0.1:1025 instead of your default SMTP server,
then check out http://127.0.0.1:1080 to see the mail.")
(home-page "https://mailcatcher.me")
(license license:expat)))
+
+(define-public ruby-backport
+ (let ((commit "5074f249cc12a95e388d2a16080fd3252013ffd4"))
+ (package
+ (name "ruby-backport")
+ (version "1.1.1")
+ (source
+ (origin
+ ;; The gem does not include test code, so fetch from the Git repository
+ ;; Repo doesn't have release tags either
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/castwide/backport.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ii3y1wx1n48nd2mhlv0v61b2m21h7dg30if9vc2idza7k4afyw8"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (inputs
+ `(("ruby-simplecov" ,ruby-simplecov)))
+ (synopsis
+ "A pure Ruby library for event-driven IO")
+ (description
+ "This package provides a pure Ruby library for event-driven IO")
+ (home-page "http://github.com/castwide/backport")
+ (license license:expat))))
--
2.22.0
M
M
Mikhail Kirillov wrote on 3 Jul 2019 19:10
(address . 36482@debbugs.gnu.org)(name . Mikhail Kirillov)(address . w96k.ru@gmail.com)
20190703171027.20512-1-w96k.ru@gmail.com
* gnu/packages/ruby.scm (ruby): add ruby-backport package
---
gnu/packages/ruby.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 49e0b9fe73..e25b527f5c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8725,3 +8725,33 @@ app to deliver to smtp://127.0.0.1:1025 instead of your default SMTP server,
then check out http://127.0.0.1:1080 to see the mail.")
(home-page "https://mailcatcher.me")
(license license:expat)))
+
+(define-public ruby-backport
+ (package
+ (name "ruby-backport")
+ (version "1.1.1")
+ (source
+ (origin
+ ;; The gem does not include test code, so fetch from the Git repository
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/castwide/backport.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ii3y1wx1n48nd2mhlv0v61b2m21h7dg30if9vc2idza7k4afyw8"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (inputs
+ `(("ruby-simplecov" ,ruby-simplecov)))
+ (synopsis
+ "A pure Ruby library for event-driven IO")
+ (description
+ "This package provides a pure Ruby library for event-driven IO")
+ (home-page "http://github.com/castwide/backport")
+ (license license:expat)))
--
2.22.0
L
L
Ludovic Courtès wrote on 4 Jul 2019 12:29
(name . Mikhail Kirillov)(address . w96k.ru@gmail.com)(address . 36482-done@debbugs.gnu.org)
87v9wi5c0b.fsf@gnu.org
Hi Mikhail,

Mikhail Kirillov <w96k.ru@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/ruby.scm (ruby): add ruby-backport package

Applied with the minor changes below. Thank you!

Ludo’.
Toggle diff (34 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e25b527f5c..5f613cfe60 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Mikhail Kirillov <w96k.ru@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8736,7 +8737,7 @@ then check out http://127.0.0.1:1080 to see the mail.")
(method git-fetch)
(uri (git-reference
(url "https://github.com/castwide/backport.git")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
@@ -8749,9 +8750,8 @@ then check out http://127.0.0.1:1080 to see the mail.")
("ruby-rspec" ,ruby-rspec)))
(inputs
`(("ruby-simplecov" ,ruby-simplecov)))
- (synopsis
- "A pure Ruby library for event-driven IO")
+ (synopsis "Pure Ruby library for event-driven IO")
(description
- "This package provides a pure Ruby library for event-driven IO")
- (home-page "http://github.com/castwide/backport")
+ "This package provides a pure Ruby library for event-driven IO.")
+ (home-page "https://github.com/castwide/backport")
(license license:expat)))
Closed
?