Guix does not match point-versions correctly

DoneSubmitted by swedebugia.
Details
3 participants
  • Danny Milosavljevic
  • Ludovic Courtès
  • swedebugia
Owner
unassigned
Severity
normal
S
S
swedebugia wrote on 1 Jul 2019 11:11
(name . Report newGuixbug)(address . bug-guix@gnu.org)
cc3ca4b0-f220-27ad-bfbb-91c09c996441@riseup.net
Hi
I'm doing the crate-adventure and stumbled on this:
starting phase `build'error: failed to select a version for the requirement `clippy = "^0.0.41"` candidate versions found which didn't match: 0.0.302 location searched: directory source `/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18/guix-vendor` (which is replacing registry `https://github.com/rust-lang/crates.io-index`)required by package `blake2-rfc v0.2.18 (/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18)`
But the version we got is way above .41.0.0.302 > 0.0.41!
WDYT?
-- Cheers Swedebugia
S
S
swedebugia wrote on 1 Jul 2019 11:30
(address . bug-guix@gnu.org)
4beb604c-046d-c6f5-4ab8-5c2ccfe16d7e@riseup.net
On 2019-07-01 11:11, swedebugia wrote:
Toggle quote (20 lines)> Hi> > I'm doing the crate-adventure and stumbled on this:> > starting phase `build'> error: failed to select a version for the requirement `clippy = "^0.0.41"`>   candidate versions found which didn't match: 0.0.302>   location searched: directory source > `/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18/guix-vendor` > (which is replacing registry > `https://github.com/rust-lang/crates.io-index`)> required by package `blake2-rfc v0.2.18 > (/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18)`> > But the version we got is way above .41.> 0.0.302 > 0.0.41!> > WDYT?>
Oops maybe this output is from cargo.
According to https://semver.npmjs.com/the ^ (hat) means: include everything greater than a particular version in the same major range. cargo should thus accept up to 0.0.999 in this case as valid but does not.
Should I relax the version requirement? To what?
-- Cheers Swedebugia
D
D
Danny Milosavljevic wrote on 1 Jul 2019 11:58
(name . swedebugia)(address . swedebugia@riseup.net)(address . 36457@debbugs.gnu.org)
20190701115812.2e255313@scratchpost.org
On Mon, 1 Jul 2019 11:11:45 +0200swedebugia <swedebugia@riseup.net> wrote:
Toggle quote (14 lines)> I'm doing the crate-adventure and stumbled on this:> > starting phase `build'> error: failed to select a version for the requirement `clippy = "^0.0.41"`> candidate versions found which didn't match: 0.0.302> location searched: directory source > `/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18/guix-vendor` > (which is replacing registry `https://github.com/rust-lang/crates.io-index`)> required by package `blake2-rfc v0.2.18 > (/tmp/guix-build-rust-blake2-rfc-0.2.18.drv-0/blake2-rfc-0.2.18)`> > But the version we got is way above .41.> 0.0.302 > 0.0.41!
Toggle quote (1 lines)> The version 0.0.x is not considered compatible with any other version.
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl0Z2TQACgkQ5xo1VCwwuqW8Tgf/RE6WS9gfA/GVEOp8hqcainZFsEmJaH8xkwrGDqcG+TPSAuRQYxepfodyfjRLy0n2T/QLtk1RtMVu8halRp8lYLov+zp5N0TCYXtCzUZsQiyPXjwZHSkPH1WhCyVrwOYk9K5X4sz2U4RoA5A8MTTgc7zJgf44mKJDQTQ8CBFND1szNiSDXFUT0R2CVtMYK3Rbzamcdn1sXERcb0AKvsysZZPwK/xk8rIouK/+sBdBCqStWc0w9x3cNDtF0diwQtKVmnWd2YPBqU48qA0P8h5DJZbEuZ9cKQioGzDs25T+bDNUPrlAIWWh6rn5Bvtdx27gaDoM0CixkcmnpbaXfmHjog===WeB0-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 5 Jul 2019 23:35
control message for bug #36457
(address . control@debbugs.gnu.org)
87a7dsi2ps.fsf@gnu.org
tags 36457 notabugclose 36457quit
?
Your comment

This issue is archived.

To comment on this conversation send email to 36457@debbugs.gnu.org