[PATCH] profiles: Adjust packages->manifest pattern for inferior packages.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal
K
K
Kyle Meyer wrote on 29 Jun 2019 07:50
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190629055015.3886-1-kyle@kyleam.com
* guix/profiles.scm (packages->manifest): Add package? predicate to `(package
output)' pattern to avoid incorrectly matching `(inferior-package output)',
which should be handled by a later clause.
---
guix/profiles.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/guix/profiles.scm b/guix/profiles.scm
index dfc9ba1ca0..f5c863945c 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
;;; Copyright © 2017 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -337,7 +338,7 @@ (define (packages->manifest packages)
(manifest
(map (match-lambda
- ((package output)
+ (((? package? package) output)
(package->manifest-entry package output))
((? package? package)
(package->manifest-entry package))
--
2.22.0
L
L
Ludovic Courtès wrote on 3 Jul 2019 11:16
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 36429-done@debbugs.gnu.org)
878stf4gwb.fsf@gnu.org
Hello Kyle,

Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (4 lines)
> * guix/profiles.scm (packages->manifest): Add package? predicate to `(package
> output)' pattern to avoid incorrectly matching `(inferior-package output)',
> which should be handled by a later clause.

Good catch. Applied, thanks!

Ludo’.
Closed
?