[PATCH] gnu: mesa: Fix detection of wayland-scanner pkg-config file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal
K
K
Kei Kebreau wrote on 26 Jun 2019 03:53
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190626015345.19432-2-kkebreau@posteo.net
* gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
---
gnu/packages/gl.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96e7fc7165..78f7401f20 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
(("'u_format_test',") ""))
#t)))
'())
+ (add-after
+ 'unpack 'patch-meson-build
+ (lambda _
+ ;; Without this, meson fails with the following error:
+ ;; Dependency "wayland-scanner" not found, tried pkgconfig.
+ (substitute* "meson.build"
+ (("dependency\\('wayland-scanner', native: true\\)")
+ "dependency('wayland-scanner')"))
+ #t))
(add-before
'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.22.0
M
M
Maxim Cournoyer wrote on 14 Nov 2021 02:22
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 36387@debbugs.gnu.org)
87k0hbil8w.fsf_-_@gmail.com
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (26 lines)
> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
> ---
> gnu/packages/gl.scm | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 96e7fc7165..78f7401f20 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
> (("'u_format_test',") ""))
> #t)))
> '())
> + (add-after
> + 'unpack 'patch-meson-build
> + (lambda _
> + ;; Without this, meson fails with the following error:
> + ;; Dependency "wayland-scanner" not found, tried pkgconfig.
> + (substitute* "meson.build"
> + (("dependency\\('wayland-scanner', native: true\\)")
> + "dependency('wayland-scanner')"))
> + #t))
> (add-before
> 'configure 'fix-dlopen-libnames
> (lambda* (#:key inputs outputs #:allow-other-keys)

Was this fixing a build failure of mesa itself? Or does it manifest
when building other packages depending on mesa?

Given the patch is 2 years old, I'm guessing it went stale?

Thanks,

Maxim
K
K
Kei Kebreau wrote on 27 Dec 2021 14:46
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 36387@debbugs.gnu.org)
ce5de4c2-f580-02d4-2b01-c0bef310d30b@posteo.net
It did in fact go stale. I vaguely remember having some trouble building
mesa locally, but this no longer seems to be the case.

On 11/13/21 8:22 PM, Maxim Cournoyer wrote:
Toggle quote (37 lines)
> Hello,
>
> Kei Kebreau<kkebreau@posteo.net> writes:
>
>> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
>> ---
>> gnu/packages/gl.scm | 9 +++++++++
>> 1 file changed, 9 insertions(+)
>>
>> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
>> index 96e7fc7165..78f7401f20 100644
>> --- a/gnu/packages/gl.scm
>> +++ b/gnu/packages/gl.scm
>> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
>> (("'u_format_test',") ""))
>> #t)))
>> '())
>> + (add-after
>> + 'unpack 'patch-meson-build
>> + (lambda _
>> + ;; Without this, meson fails with the following error:
>> + ;; Dependency "wayland-scanner" not found, tried pkgconfig.
>> + (substitute* "meson.build"
>> + (("dependency\\('wayland-scanner', native: true\\)")
>> + "dependency('wayland-scanner')"))
>> + #t))
>> (add-before
>> 'configure 'fix-dlopen-libnames
>> (lambda* (#:key inputs outputs #:allow-other-keys)
> Was this fixing a build failure of mesa itself? Or does it manifest
> when building other packages depending on mesa?
>
> Given the patch is 2 years old, I'm guessing it went stale?
>
> Thanks,
>
> Maxim
M
M
Maxim Cournoyer wrote on 28 Dec 2021 03:34
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 36387-done@debbugs.gnu.org)
87ee5xwj8a.fsf@gmail.com
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (3 lines)
> It did in fact go stale. I vaguely remember having some trouble
> building mesa locally, but this no longer seems to be the case.

Alright, thank you for the heads up. Closing.

Maxim
Closed
?