[PATCH] gnu: rust: fix building bootstrap chain

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ivan Petkov
Owner
unassigned
Submitted by
Ivan Petkov
Severity
normal
I
I
Ivan Petkov wrote on 18 Jun 2019 05:00
(address . guix-patches@gnu.org)
63B38722-EBE9-4025-92EB-D7FEC694A946@gmail.com
This patch fixes building rust versions 1.30 and onwards:

* Thanks to a newer GDB version being present, we no longer need to patch the
debug-info tests to the older (and now incorrect) format.
* Downgrade to llvm@6 for older compilers, which don't support the newer llvm@8.

—Ivan
I
I
Ivan Petkov wrote on 18 Jun 2019 05:06
(address . 36272@debbugs.gnu.org)
8A0D1483-6566-43B5-929A-5FC30F75BB96@gmail.com
I tried deleting the gnu/packages/patches/rust-1.30-gdb-llvm.patch file since
it is now unused, but after doing so the build fails with a cryptic backtrace.

Anyone have any ideas why?

--Ivan

Backtrace:
In srfi/srfi-1.scm:
592:29 19 (map1 (#<<service> type: #<service-type mingetty ced…> …))
592:29 18 (map1 (#<<service> type: #<service-type mingetty ced…> …))
592:29 17 (map1 (#<<service> type: #<service-type mingetty ced…> …))
592:29 16 (map1 (#<<service> type: #<service-type syslog 42b50…> …))
592:17 15 (map1 (#<<service> type: #<service-type guix 27825a0…> …))
In ice-9/eval.scm:
196:43 14 (_ #(#(#(#<directory (gnu tests install) c9f01e0>) #) #))
293:34 13 (_ #(#(#(#<directory (gnu tests install) c9f01e0>) #) #))
293:34 12 (_ #(#(#(#(#<directory (gnu packages package-…> …)) …) …))
174:20 11 (_ #(#(#(#(#<directory (gnu packages package-…> …)) …) …))
177:49 10 (lp (#<procedure 1839e280 at ice-9/eval.scm:282:4 (e…> …))
177:49 9 (lp (#<procedure 1839e260 at ice-9/eval.scm:282:4 (e…> …))
177:49 8 (lp (#<procedure 1839e240 at ice-9/eval.scm:282:4 (e…> …))
177:32 7 (lp (#<procedure 1839e220 at ice-9/eval.scm:182:7 (env)>))
In unknown file:
6 (force #<promise #<procedure 5b90da0 at ice-9/eval.scm:…>)
In ice-9/eval.scm:
293:34 5 (_ #(#(#<directory (gnu packages package-management…> …)))
In ice-9/boot-9.scm:
829:9 4 (catch git-error #<procedure 183a1ac0 at ice-9/eval.sc…> …)
In ice-9/eval.scm:
293:34 3 (_ #(#(#(#<directory (guix git-download) 253daa0> #)) #))
In srfi/srfi-1.scm:
466:18 2 (fold #<procedure 17fb2340 at ice-9/eval.scm:336:13 (a…> …)
In ice-9/eval.scm:
293:34 1 (_ #(#(#<directory (guix git-download) 253daa0> "/…") …))
In unknown file:
0 (lstat "/home/ivan/import/guix-rust-upgrade/gnu/package…")

ERROR: In procedure lstat:
In procedure lstat: No such file or directory: "/home/ivan/import/guix-rust-upgrade/gnu/packages/patches/rust-1.30-gdb-llvm.patch"
D
D
Danny Milosavljevic wrote on 18 Jun 2019 08:51
(name . Ivan Petkov)(address . ivanppetkov@gmail.com)
20190618085139.430895ee@scratchpost.org
Hi Ivan,

On Mon, 17 Jun 2019 20:06:37 -0700
Ivan Petkov <ivanppetkov@gmail.com> wrote:

Toggle quote (5 lines)
> I tried deleting the gnu/packages/patches/rust-1.30-gdb-llvm.patch file since
> it is now unused, but after doing so the build fails with a cryptic backtrace.
>
> Anyone have any ideas why?

Hmm, I've had spooky things like that when I didn't run "make" in the guix
directory after the change before trying to use it.
Not sure why that is--since guile is supposed to compile on demand--, but it
happened.

So try running "make" in guix.

Otherwise "grep -r gdb-llvm ." to find left-overs, if any.

If nothing else helps, rm -rf ~/.cache/guile
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl0IifsACgkQ5xo1VCww
uqXgdgf/RbkSbD0S0UbVRVi9BmKC1s8ijyefk21EjttVPDJYyWxzybjH+mCdADwd
Ki1LA+z4lJNXPZBPIJ5DNxGgf1qjA+OeiCYPlPDjAz7Y9U6BeHkaoDord+EFo5dP
qIHF2b8vUjYWqssMGwMr+LtkYBmoBByreukLb81n6rz4ERJTEcoYrNq49yTw1+nc
Un8hXrfQJqElG3D5RCACvzLqfCGQOeFB6913li0FNNtNh16tDO2RkjIH8SYaiLUQ
n/jGBMKyzrqW3qDawfZW/oYs92hUynkDuh0havFu3YAAhBSEg7+aOqxEBZr+t1yz
ajTWGlUD56bq77d84faCBYspnTIllQ==
=pDPY
-----END PGP SIGNATURE-----


I
I
Ivan Petkov wrote on 19 Jun 2019 07:43
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
6AEB6075-BD94-4235-A8E0-469934BA7A3C@gmail.com
Hi Danny,

Toggle quote (4 lines)
> On Jun 17, 2019, at 11:51 PM, Danny Milosavljevic <dannym@scratchpost.org> wrote:
>
> So try running "make" in guix.

I always run make before any ./pre-inst-env invocation, and that’s what raises the error.

Toggle quote (2 lines)
> Otherwise "grep -r gdb-llvm ." to find left-overs, if any.

No results (besides those in .git). Maybe it’s because there are items in the store which
have references to it and guix is getting confused somewhere? Unfortunately, I don’t
know enough to stipulate further...

Toggle quote (2 lines)
> If nothing else helps, rm -rf ~/.cache/guile

Unfortunately this didn’t help either :(

I’m willing to get this merged in as is for now, get rust to build again, and clean up my store
with `guix gc` before trying to delete the patch file again. Maybe things will work then.

Also attaching one more patch update, this time for bumping to llvm@8 for the latest
rust version!

—Ivan

D
D
Danny Milosavljevic wrote on 19 Jun 2019 13:10
(name . Ivan Petkov)(address . ivanppetkov@gmail.com)
20190619131033.2f69ee6d@scratchpost.org
Ah, maybe the sha checksum of the origin is used as a key to a cache for the
origin.
Try changing a digit in it (in the call to rust-bootstapped-package in rust-1.30).
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl0KGCkACgkQ5xo1VCww
uqXDLgf/faT+mu4EBChYEokkwu0A1XIbb1aL9XaYqH8vN2hksMo6uLe8Pd1u7qI6
CO1v581Npt6H+rqF+HxaNF9W8eQWCd17ve2ZzlAVQtiQD8m7DyQ2oql750OY5Ljf
5n+fL8m2DwWlz8SN+qMJQ0L2vlam2X/2XhwVJXBdymHQK181PiaflHZmmB8wMSYq
LuRWa949NYiYkcghw4F2IcYxJXCjB3k7Gd9uU0yWxsmDH4sTO9A3UPlNLTdREX8D
jyff0Toug19h2OO7/kMQhCR2xgbVWHVw6rDAx+/izT4F5GOBJ3FJszIl28xc068r
n1/FJgtIlJjKpUE9fhBeRa4m+hDGUw==
=/S3V
-----END PGP SIGNATURE-----


I
I
Ivan Petkov wrote on 19 Jun 2019 18:01
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
93C3B2FA-538D-4D61-8427-7B85134165DB@gmail.com
Toggle quote (6 lines)
> On Jun 19, 2019, at 4:10 AM, Danny Milosavljevic <dannym@scratchpost.org> wrote:
>
> Ah, maybe the sha checksum of the origin is used as a key to a cache for the
> origin.
> Try changing a digit in it (in the call to rust-bootstapped-package in rust-1.30).

Still no dice.

I even tried commenting out the rust package definitions entirely and the issue still
occurs when running `make` after `make clean`, so I don’t think its related to the
package definitions themselves...

—Ivan
I
I
Ivan Petkov wrote on 29 Jun 2019 03:46
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
DAB56933-E788-44E8-B613-556DF0862739@gmail.com
I’ve merged this in as f5de2b9a3e0070ec431e01c279192e6d93d6a1c8.
I’ll come back a bit later and see if removing the patch file works…

—Ivan
Closed
?