[PATCH] gnu: Add numix-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Ludovic Courtès
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 18 Jun 2019 01:58
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20190617235805.4300-1-goodoldpaul@autistici.org
* gnu/packages/gnome.scm (numix-theme): New variable
---
gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 875d28caee..eeca6edd4b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6880,6 +6881,39 @@ functionality and behavior.")
(home-page "https://extensions.gnome.org/")
(license license:gpl3+)))
+(define-public numix-theme
+ (package
+ (name "numix-theme")
+ (version "2.6.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/numixproject/numix-gtk-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))))
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
+ ("gnome-shell" ,gnome-shell)
+ ("gtk+" ,gtk+)
+ ("xmllint" ,libxml2)
+ ("ruby-sass" ,ruby-sass)))
+ (synopsis "Numix is a modern flat theme with a combination of light
+ and dark elements")
+ (description "A modern flat theme with a combination of light and dark elements.
+ It supports GNOME, Unity, Xfce and Openbox.")
+ (home-page "https://numixproject.github.io")
+ (license license:gpl3+)))
+
(define-public arc-theme
(package
(name "arc-theme")
--
2.22.0
L
L
Ludovic Courtès wrote on 19 Jun 2019 22:47
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)(address . 36271-done@debbugs.gnu.org)
87pnn91evx.fsf@gnu.org
Hi Giacomo,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (numix-theme): New variable

Applied with the following minor changes to match our
synopsis/description guidelines:


Thank you!

Ludo’.
Toggle diff (17 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eeca6edd4b..ad6b9203b9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6907,10 +6907,9 @@ functionality and behavior.")
("gtk+" ,gtk+)
("xmllint" ,libxml2)
("ruby-sass" ,ruby-sass)))
- (synopsis "Numix is a modern flat theme with a combination of light
- and dark elements")
- (description "A modern flat theme with a combination of light and dark elements.
- It supports GNOME, Unity, Xfce and Openbox.")
+ (synopsis "Flat theme with light and dark elements")
+ (description "Numix is a modern flat theme with a combination of light and
+dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
(home-page "https://numixproject.github.io")
(license license:gpl3+)))
Closed
?