dependency error with docker-compose

  • Done
  • quality assurance status badge
Details
2 participants
  • Edison Ibáñez
  • Björn Höfling
Owner
unassigned
Submitted by
Edison Ibáñez
Severity
normal
Merged with
E
E
Edison Ibáñez wrote on 17 Jun 2019 02:49
(address . bug-guix@gnu.org)
87k1dlm3x7.fsf@disroot.org
Regards,

When installing docker-compose note that the version is outdated and
therefore the dependencies are broken which causes the following error:

Traceback (most recent call last):
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 574, in _build_master
ws.require(__requires__)
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 892, in require
needed = self.resolve(parse_requirements(requirements))
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 783, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (jsonschema 3.0.1 (/gnu/store/1iq4qvdhl5qbw8dy7kxknky6rxi0v3wc-python-jsonschema-3.0.1/lib/python3.7/site-packages), Requirement.parse('jsonschema<3,>=2.5.1'), {'docker-compose'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/gnu/store/kf538ibrwbvmmscjb402rpf8hh369g47-docker-compose-1.24.0/bin/.docker-compose-real", line 6, in <module>
from pkg_resources import load_entry_point
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3088, in <module>
@_call_aside
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3072, in _call_aside
f(*args, **kwargs)
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3101, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 576, in _build_master
return cls._build_from_requirements(__requires__)
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 589, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/gnu/store/zm3188ipzi262s0m8bxm24br77yh9pd8-python-3.7.0/lib/python3.7/site-packages/pkg_resources/__init__.py", line 778, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'jsonschema<3,>=2.5.1'
distribution was not found and is required by docker-compose

Try to update it as seen in the following link:


but I keep getting the same error

I hope you can help me
B
B
Björn Höfling wrote on 18 Jun 2019 11:02
merge docker_compose
(address . control@debbugs.gnu.org)
20190618110242.4db5f0de@alma-ubu
merge 36256 35779
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXQiosgAKCRC/KGy2WT5f
/YzpAJ9sFJ4O9ZwoywzRf2YZ65eTlOZDugCgi7ELVB2k/3c7xCCgyZuqlyi3vFo=
=hTDM
-----END PGP SIGNATURE-----


B
B
Björn Höfling wrote on 18 Jun 2019 11:08
Re: bug#36256: dependency error with docker-compose
(name . Edison Ibáñez)(address . arkhan@disroot.org)(address . 36256-done@debbugs.gnu.org)
20190618110839.6e8f93e8@alma-ubu
This bug was fixed by Tobias on commit:

914bba28096c1b85e368537c02e9841258887acb

Please use "guix pull", "guix package -u" and try again.

Further note: The current docker_compose cannot use jsonschema 3.x, it
must use 2.x. There is a bug-report and a pull-request about that, so
it is expected to compatible with the 3.x version soon:



Björn
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXQiqFwAKCRC/KGy2WT5f
/azJAJ9hteUpETpn6iCcrPmVF0HuN6alXgCfezPkoGZQ6dFe7ZPqu/wBGDsg7BE=
=8QRe
-----END PGP SIGNATURE-----


Closed
?