[PATCH] gnu: Add crispy-doom.

  • Done
  • quality assurance status badge
Details
2 participants
  • Dan Frumin
  • Ludovic Courtès
Owner
unassigned
Submitted by
Dan Frumin
Severity
normal
D
D
Dan Frumin wrote on 8 Jun 2019 15:30
(address . guix-patches@gnu.org)(name . Dan Frumin)(address . dfrumin@cs.ru.nl)
20190608133033.21069-1-dfrumin@cs.ru.nl
---
gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7a433a0bfd..32ce2c6050 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5596,6 +5596,40 @@ affect gameplay).")
(home-page "https://www.chocolate-doom.org/wiki/index.php/Chocolate_Doom")
(license license:gpl2)))
+(define-public crispy-doom
+ (package
+ (inherit chocolate-doom)
+ (name "crispy-doom")
+ (version "5.5.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fabiangreffrath/crispy-doom.git")
+ (commit (string-append "crispy-doom-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a60ns0blhvml6gzj9qx18c18pbf02rq7vypaajd6nqy5h4fz3cn"))))
+ (native-inputs
+ (append
+ (package-native-inputs chocolate-doom)
+ `(("automake" ,automake)
+ ("autoreconf" ,autoconf))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ ;; the autogen.sh script in the source tree doesn't work
+ (lambda _ (invoke "autoreconf" "-vif"))))))
+ (synopsis "Limit-removing enhanced-resolution Doom source port based on
+Chocolate Doom")
+ (description
+ "Crispy Doom is a friendly fork of Chocolate Doom that provides a higher
+display resolution, removes the static limits of the Doom engine and offers
+further optional visual, tactical and physical enhancements while remaining
+entirely config file, savegame, netplay and demo compatible with the
+original.")
+ (home-page "https://www.chocolate-doom.org/wiki/index.php/Crispy_Doom")))
+
(define-public fortune-mod
(package
(name "fortune-mod")
--
2.17.1
L
L
Ludovic Courtès wrote on 19 Jun 2019 22:57
(name . Dan Frumin)(address . dfrumin@cs.ru.nl)(address . 36138-done@debbugs.gnu.org)
87h88l1ef7.fsf@gnu.org
Hi Dan,

Dan Frumin <dfrumin@cs.ru.nl> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
> 1 file changed, 34 insertions(+)

I added a commit log and a copyright line for you and committed.

Thanks!

Ludo’.
Closed
?