[PATCH] gnu: Add emacs-excorporate

  • Done
  • quality assurance status badge
Details
5 participants
  • Brett Gilio
  • Oleg Pykhalov
  • Nicolas Goaziou
  • phodina
  • TK
Owner
unassigned
Submitted by
TK
Severity
normal
T
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
n_YztFw412lx5VOCWh9kbK1K-3vlVj0Na5mHSEyssAoeogh2jfjsh_jF45h7BkvsQ_3ogOou9tFM5dfUFksumlwP5UCMnCLwE_cLx_dRRmw=@protonmail.com
Empty Message
Attachment: file
O
O
Oleg Pykhalov wrote on 5 Jun 2019 08:33
(name . TK)(address . tkprom@protonmail.com)(address . 36091@debbugs.gnu.org)
87lfygwngi.fsf@gmail.com
Hello,

First of all thank you for a contribution!

Could you split this patch to make a single patch per package, please?

Also several notes about current patch below.

TK <tkprom@protonmail.com> writes:

Toggle quote (10 lines)
> Empty Message
> From 73a918c84f1a25c2def96b6830e68b3b6368e06e Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Todor=20Kondi=C4=87?= <tk.code@protonmail.com>
> Date: Tue, 4 Jun 2019 13:15:52 +0200
> Subject: [PATCH] gnu: Add emacs-excorporate
>
> * gnu/packages/emacs-xyz.scm (emacs-ntlm, emacs-ntlm): New variables.
> (emacs-url-http-ntlm, emacs-soap-client): New variables.
> (emacs-fsm,emacs-excorporate): New variables.

This could be in a single (emacs-ntlm, emacs-url-http-ntlm,
emacs-soap-client, &): New variables., but after splitting the patch
it will be not relevant.

Toggle quote (34 lines)
> ---
> gnu/packages/emacs-xyz.scm | 189 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 189 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f9f0b2156f..81880886d3 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -47,6 +47,7 @@
> ;;; Copyright ? 2019 mikadoZero <mikadozero@yandex.com>
> ;;; Copyright ? 2019 Gabriel Hondet <gabrielhondet@gmail.com>
> ;;; Copyright ? 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
> +;;; Copyright ? 2019 Todor Kondi? <tk.code@protonmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -15669,3 +15670,191 @@ verb commands which would are normally destructive (such as deletion) are
> provided. Those alternative commands are and bound by default to their
> corresponding Evil keys.")
> (license license:expat))))
> +
> +
> +(define-public emacs-ntlm
> + (package
> + (name "emacs-ntlm")
> + (version "2.1.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/ntlm-"
> + version
> + ".el"))

Last three lines could be on a single line.

Toggle quote (7 lines)
> + (sha256
> + (base32
> + "01d0bcmh8a36qf871w6bc05kjk9bmnh843m9869xw06zyvqwg9mv"))))
> + (build-system emacs-build-system)
> + (home-page
> + "http://elpa.gnu.org/packages/ntlm.html")

Toggle quote (3 lines)
> + (synopsis
> + "NTLM (NT LanManager) authentication support")

Could be one line.

Toggle quote (18 lines)
> + (description
> + "This library is a direct translation of the Samba release 2.2.0
> +implementation of Windows NT and LanManager compatible password
> +encryption.")
> + (license license:gpl3+)))
> +
> +(define-public emacs-nadvice
> + (package
> + (name "emacs-nadvice")
> + (version "0.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/nadvice-"
> + version
> + ".el"))

One line.

Toggle quote (7 lines)
> + (sha256
> + (base32
> + "0gi3csnxbs8h7iy0scsl35sic3gv90swa89hhdjwb7qvpirfdcgw"))))
> + (build-system emacs-build-system)
> + (home-page
> + "http://elpa.gnu.org/packages/nadvice.html")

One line and https.

Toggle quote (3 lines)
> + (synopsis
> + "Forward compatibility for Emacs-24.4's nadvice")

One line.

Toggle quote (25 lines)
> + (description
> + "This package tries to re-implement some of nadvice.el's functionality
> +on top of the old defadvice system, to help users of defadvice
> +move to the new advice system without dropping support for Emacs<24.4.")
> + (license license:gpl3+)))
> +
> +(define-public emacs-url-http-ntlm
> + (package
> + (name "emacs-url-http-ntlm")
> + (version "2.0.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/url-http-ntlm-"
> + version
> + ".el"))
> + (sha256
> + (base32
> + "1cakq2ykraci7d1gl8rnpv4f2f5ffyaidhqb1282g7i72adwmb98"))))
> + (build-system emacs-build-system)
> + (propagated-inputs `(("emacs-ntlm" ,emacs-ntlm)))
> + (home-page
> + "http://elpa.gnu.org/packages/url-http-ntlm.html")

One line and https.

Toggle quote (3 lines)
> + (synopsis
> + "NTLM authentication for the url library")

One line.

Toggle quote (3 lines)
> + (description
> + "This package provides a NTLM handler for the URL package.")

One line.

Toggle quote (20 lines)
> + (license license:gpl3+)))
> +
> +(define-public emacs-soap-client
> + (package
> + (name "emacs-soap-client")
> + (version "3.1.5")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/soap-client-"
> + version
> + ".tar"))
> + (sha256
> + (base32
> + "0nnf075ywxmsfd6vmzk2yg3khx6sycl5l6qrgp5rqqmw0wzhxlh0"))))
> + (build-system emacs-build-system)
> + (home-page
> + "http://elpa.gnu.org/packages/soap-client.html")

One line and https.

Toggle quote (15 lines)
> + (synopsis "Access SOAP web services")
> + (description
> + "To use the SOAP client, you first need to load the WSDL document for the
> +service you want to access, using `soap-load-wsdl-from-url'. A WSDL
> +document describes the available operations of the SOAP service, how their
> +parameters and responses are encoded. To invoke operations, you use the
> +`soap-invoke' method passing it the WSDL, the service name, the operation
> +you wish to invoke and any required parameters.
> +
> +Ideally, the service you want to access will have some documentation about
> +the operations it supports. If it does not, you can try using
> +`soap-inspect' to browse the WSDL document and see the available operations
> +and their parameters.")
> + (license license:gpl3+)))

I think we should replace this instruction with a package description
instead, because we have the same tutorial in soap-client.el file.

Toggle quote (12 lines)
> +(define-public emacs-fsm
> + (package
> + (name "emacs-fsm")
> + (version "0.2.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/fsm-"
> + version
> + ".el"))

One line.

Toggle quote (7 lines)
> + (sha256
> + (base32
> + "1jyxyqdbfl8nv7c50q0sg3w5p7whp1sqgi7w921k5hfar4d11qqp"))))
> + (build-system emacs-build-system)
> + (home-page
> + "http://elpa.gnu.org/packages/fsm.html")

One line and https.

Toggle quote (2 lines)
> + (synopsis "state machine library")

Linter has some warnings:

$ ./pre-inst-env guix lint emacs-fsm
gnu/packages/emacs-xyz.scm:15903:14: emacs-fsm@0.2.1: synopsis should
start with an upper-case letter or digit

Also, State machine Emacs library will be better for guix search.

Toggle quote (5 lines)
> + (description
> + "fsm.el is an exercise in metaprogramming inspired by gen_fsm of
> +Erlang/OTP. It aims to make asynchronous programming in Emacs Lisp
> +easy and fun.

I think it's enough for the description.

gnu/packages/emacs-xyz.scm:15905:6: emacs-fsm@0.2.1: description should
start with an upper-case letter or digit

The warning above could be fixed by @code{fsm.el}.

Toggle quote (25 lines)
> By \"asynchronous\" I mean that long-lasting tasks don't interfer
> with normal editing.
> +
> +Some people say that it would be nice if Emacs Lisp had threads
> +and/or continuations. They are probably right, but there are few
> +things that can't be made to run in the background using facilities
> +already available: timers, filters and sentinels. As the code can
> +become a bit messy when using such means, with callbacks everywhere
> +and such things, it can be useful to structure the program as a
> +state machine.")
>
> + (license license:gpl3+)))
> +
> +(define-public emacs-excorporate
> + (package
> + (name "emacs-excorporate")
> + (version "0.8.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://elpa.gnu.org/packages/excorporate-"
> + version
> + ".tar"))

One line.

Toggle quote (12 lines)
> + (sha256
> + (base32
> + "1k89472x80wsn14y16km5bgynmmd2kbdfhylb3cc17jvdn1xr53y"))))
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-fsm" ,emacs-fsm)
> + ("emacs-soap-client" ,emacs-soap-client)
> + ("emacs-url-http-ntlm" ,emacs-url-http-ntlm)
> + ("emacs-nadvice" ,emacs-nadvice)))
> + (home-page
> + "http://elpa.gnu.org/packages/excorporate.html")

One line and https.

Toggle quote (2 lines)
> + (synopsis "Exchange integration")

Maybe Exchange integration for Emacs as in description.

Toggle quote (3 lines)
> + (description
> + "Excorporate provides Exchange integration for Emacs.

That's enough, we will have the following after installing a package.

Toggle quote (22 lines)
> +To create a connection to a web service:
> +
> +M-x excorporate
> +
> +Excorporate will prompt for an email address that it will use to
> +automatically discover settings. Then it will prompt you for your
> +credentials two or three times depending on the server configuration.
> +
> +You should see a message indicating that the connection is ready
> +either in the minibuffer or in the *Messages* buffer.
> +
> +Finally, run M-x calendar, and press @code{e} to show today's meetings.
> +
> +If autodiscovery fails, customize @code{excorporate-configuration} to skip
> +autodiscovery.
> +
> +For further information including connection troubleshooting, see the
> +Excorporate Info node at C-h i d m Excorporate.
> +")
> + (license license:gpl3+)))
> +

Regards,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAlz3YksACgkQFn+OpQAa
+pzjNw/6AmA861dcrwyCoMSnV0mvU3ZtREgTnqzQwxHYfWt1Azcp9qdiBXSSYQ0y
vcKfGgV+blpBm7PLGE4PCirNqF1TkTvnY1Q79k5i1o/hjJFJq52toZ3mYROU/Cfh
xq51B4+5GzPidcleLhIeZ93B4cMf12t7UipO0lvLgM0khmzJY+pTuKdjR1t1BXOn
+3M686y3gLc7sRE8/boImTJTpfT3h05ZPZat7CfLtowdkFmOKiLnnPnDrrB2EQJr
ho+rLUN603jIx7W0rnHEe4ddOaFhvLkxYUlLPZU8PaAAQ66iPPQ6Aml17SFzawVa
4gNm71tlLGwFduqQv+9UgxssWH+5jf64Y7NXsriO/j26q9yGJEGZ7ECAkGBtby38
4VaDjRyxk9Guh8Q+i8tHmvYn/KNxEha9X2oauwruc+gZb9zbEbSxZSQGL70lh/+d
72kqvhD9jozZuLcYjnfChC+UT7+1QwBwqPRhPtk8SvhMUKATol3hqu6WN+oZgn3L
kpQ2gkUrF0lllmkZEz4c7sEiyuvF8D3qHitVl+xH9bI5r//i8KKb5oqqSv7tKzAt
F8HyGaknnvimt+x6psR3dFq0P170mpcsAL4g/u0R3la5W2W+HnmeTxsMreiE5UMS
gnL4z81mH/0GE15ok2DdI8pGjWWlhoB2QK7V16FmkJSDoiru5J0=
=tli3
-----END PGP SIGNATURE-----

B
B
Brett Gilio wrote on 10 Dec 2019 06:31
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
87v9qolpal.fsf@posteo.net
Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (306 lines)
> Hello,
>
> First of all thank you for a contribution!
>
> Could you split this patch to make a single patch per package, please?
>
> Also several notes about current patch below.
>
> TK <tkprom@protonmail.com> writes:
>
>> Empty Message
>> From 73a918c84f1a25c2def96b6830e68b3b6368e06e Mon Sep 17 00:00:00 2001
>> From: =?UTF-8?q?Todor=20Kondi=C4=87?= <tk.code@protonmail.com>
>> Date: Tue, 4 Jun 2019 13:15:52 +0200
>> Subject: [PATCH] gnu: Add emacs-excorporate
>>
>> * gnu/packages/emacs-xyz.scm (emacs-ntlm, emacs-ntlm): New variables.
>> (emacs-url-http-ntlm, emacs-soap-client): New variables.
>> (emacs-fsm,emacs-excorporate): New variables.
>
> This could be in a single (emacs-ntlm, emacs-url-http-ntlm,
> emacs-soap-client, &): New variables., but after splitting the patch
> it will be not relevant.
>
>> ---
>> gnu/packages/emacs-xyz.scm | 189 +++++++++++++++++++++++++++++++++++++
>> 1 file changed, 189 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index f9f0b2156f..81880886d3 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -47,6 +47,7 @@
>> ;;; Copyright 2019 mikadoZero <mikadozero@yandex.com>
>> ;;; Copyright 2019 Gabriel Hondet <gabrielhondet@gmail.com>
>> ;;; Copyright 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
>> +;;; Copyright 2019 Todor Kondi? <tk.code@protonmail.com>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -15669,3 +15670,191 @@ verb commands which would are normally destructive (such as deletion) are
>> provided. Those alternative commands are and bound by default to their
>> corresponding Evil keys.")
>> (license license:expat))))
>> +
>> +
>> +(define-public emacs-ntlm
>> + (package
>> + (name "emacs-ntlm")
>> + (version "2.1.0")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/ntlm-"
>> + version
>> + ".el"))
>
> Last three lines could be on a single line.
>
>> + (sha256
>> + (base32
>> + "01d0bcmh8a36qf871w6bc05kjk9bmnh843m9869xw06zyvqwg9mv"))))
>> + (build-system emacs-build-system)
>> + (home-page
>> + "http://elpa.gnu.org/packages/ntlm.html")
>
> Use https://elpa.gnu.org/packages/ntlm.html and on single line.
>
>> + (synopsis
>> + "NTLM (NT LanManager) authentication support")
>
> Could be one line.
>
>> + (description
>> + "This library is a direct translation of the Samba release 2.2.0
>> +implementation of Windows NT and LanManager compatible password
>> +encryption.")
>> + (license license:gpl3+)))
>> +
>> +(define-public emacs-nadvice
>> + (package
>> + (name "emacs-nadvice")
>> + (version "0.3")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/nadvice-"
>> + version
>> + ".el"))
>
> One line.
>
>> + (sha256
>> + (base32
>> + "0gi3csnxbs8h7iy0scsl35sic3gv90swa89hhdjwb7qvpirfdcgw"))))
>> + (build-system emacs-build-system)
>> + (home-page
>> + "http://elpa.gnu.org/packages/nadvice.html")
>
> One line and https.
>
>> + (synopsis
>> + "Forward compatibility for Emacs-24.4's nadvice")
>
> One line.
>
>> + (description
>> + "This package tries to re-implement some of nadvice.el's functionality
>> +on top of the old defadvice system, to help users of defadvice
>> +move to the new advice system without dropping support for Emacs<24.4.")
>> + (license license:gpl3+)))
>> +
>> +(define-public emacs-url-http-ntlm
>> + (package
>> + (name "emacs-url-http-ntlm")
>> + (version "2.0.4")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/url-http-ntlm-"
>> + version
>> + ".el"))
>> + (sha256
>> + (base32
>> + "1cakq2ykraci7d1gl8rnpv4f2f5ffyaidhqb1282g7i72adwmb98"))))
>> + (build-system emacs-build-system)
>> + (propagated-inputs `(("emacs-ntlm" ,emacs-ntlm)))
>> + (home-page
>> + "http://elpa.gnu.org/packages/url-http-ntlm.html")
>
> One line and https.
>
>> + (synopsis
>> + "NTLM authentication for the url library")
>
> One line.
>
>> + (description
>> + "This package provides a NTLM handler for the URL package.")
>
> One line.
>
>> + (license license:gpl3+)))
>> +
>> +(define-public emacs-soap-client
>> + (package
>> + (name "emacs-soap-client")
>> + (version "3.1.5")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/soap-client-"
>> + version
>> + ".tar"))
>> + (sha256
>> + (base32
>> + "0nnf075ywxmsfd6vmzk2yg3khx6sycl5l6qrgp5rqqmw0wzhxlh0"))))
>> + (build-system emacs-build-system)
>> + (home-page
>> + "http://elpa.gnu.org/packages/soap-client.html")
>
> One line and https.
>
>> + (synopsis "Access SOAP web services")
>> + (description
>> + "To use the SOAP client, you first need to load the WSDL document for the
>> +service you want to access, using `soap-load-wsdl-from-url'. A WSDL
>> +document describes the available operations of the SOAP service, how their
>> +parameters and responses are encoded. To invoke operations, you use the
>> +`soap-invoke' method passing it the WSDL, the service name, the operation
>> +you wish to invoke and any required parameters.
>> +
>> +Ideally, the service you want to access will have some documentation about
>> +the operations it supports. If it does not, you can try using
>> +`soap-inspect' to browse the WSDL document and see the available operations
>> +and their parameters.")
>> + (license license:gpl3+)))
>
> I think we should replace this instruction with a package description
> instead, because we have the same tutorial in soap-client.el file.
>
>> +(define-public emacs-fsm
>> + (package
>> + (name "emacs-fsm")
>> + (version "0.2.1")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/fsm-"
>> + version
>> + ".el"))
>
> One line.
>
>> + (sha256
>> + (base32
>> + "1jyxyqdbfl8nv7c50q0sg3w5p7whp1sqgi7w921k5hfar4d11qqp"))))
>> + (build-system emacs-build-system)
>> + (home-page
>> + "http://elpa.gnu.org/packages/fsm.html")
>
> One line and https.
>
>> + (synopsis "state machine library")
>
> Linter has some warnings:
>
> $ ./pre-inst-env guix lint emacs-fsm
> gnu/packages/emacs-xyz.scm:15903:14: emacs-fsm@0.2.1: synopsis should
> start with an upper-case letter or digit
>
> Also, State machine Emacs library will be better for guix search.
>
>> + (description
>> + "fsm.el is an exercise in metaprogramming inspired by gen_fsm of
>> +Erlang/OTP. It aims to make asynchronous programming in Emacs Lisp
>> +easy and fun.
>
> I think it's enough for the description.
>
> gnu/packages/emacs-xyz.scm:15905:6: emacs-fsm@0.2.1: description should
> start with an upper-case letter or digit
>
> The warning above could be fixed by @code{fsm.el}.
>
>> By \"asynchronous\" I mean that long-lasting tasks don't interfer
>> with normal editing.
>> +
>> +Some people say that it would be nice if Emacs Lisp had threads
>> +and/or continuations. They are probably right, but there are few
>> +things that can't be made to run in the background using facilities
>> +already available: timers, filters and sentinels. As the code can
>> +become a bit messy when using such means, with callbacks everywhere
>> +and such things, it can be useful to structure the program as a
>> +state machine.")
>>
>> + (license license:gpl3+)))
>> +
>> +(define-public emacs-excorporate
>> + (package
>> + (name "emacs-excorporate")
>> + (version "0.8.1")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "https://elpa.gnu.org/packages/excorporate-"
>> + version
>> + ".tar"))
>
> One line.
>
>> + (sha256
>> + (base32
>> + "1k89472x80wsn14y16km5bgynmmd2kbdfhylb3cc17jvdn1xr53y"))))
>> + (build-system emacs-build-system)
>> + (propagated-inputs
>> + `(("emacs-fsm" ,emacs-fsm)
>> + ("emacs-soap-client" ,emacs-soap-client)
>> + ("emacs-url-http-ntlm" ,emacs-url-http-ntlm)
>> + ("emacs-nadvice" ,emacs-nadvice)))
>> + (home-page
>> + "http://elpa.gnu.org/packages/excorporate.html")
>
> One line and https.
>
>> + (synopsis "Exchange integration")
>
> Maybe Exchange integration for Emacs as in description.
>
>> + (description
>> + "Excorporate provides Exchange integration for Emacs.
>
> That's enough, we will have the following after installing a package.
>
>> +To create a connection to a web service:
>> +
>> +M-x excorporate
>> +
>> +Excorporate will prompt for an email address that it will use to
>> +automatically discover settings. Then it will prompt you for your
>> +credentials two or three times depending on the server configuration.
>> +
>> +You should see a message indicating that the connection is ready
>> +either in the minibuffer or in the *Messages* buffer.
>> +
>> +Finally, run M-x calendar, and press @code{e} to show today's meetings.
>> +
>> +If autodiscovery fails, customize @code{excorporate-configuration} to skip
>> +autodiscovery.
>> +
>> +For further information including connection troubleshooting, see the
>> +Excorporate Info node at C-h i d m Excorporate.
>> +")
>> + (license license:gpl3+)))
>> +
>
> Regards,
> Oleg.
>

Hello Oleg and TK,

I'd like to see these changes get pushed to master. TK, we are just
needing you to split these packages and follow the revisions that Oleg
proposed which I agree with. Depending on the age of these packages they
now likely lag behind its dependent packages so some version adjustments
may be indicated.

If you need some help, please do not hesitate to ask!

--
Brett M. Gilio
Homepage -- https://scm.pw/
P
P
phodina wrote on 4 Nov 2021 22:34
[PATCH v2 1/6] gnu: Add emacs-ntlm.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
TvhoMHsJFd5QgFKaV25ehP_0_ToQAw0V3MYBitNmllKAyWJ5HoB7DL24rXUfcxqI-3d0YOGN81qpmJtMNY_nJgjFFxiVNwXm8cSfVlGzN_o=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-ntlm): New variable.

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 624fe957e3..f4aa3259db 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019, 2020, 2021 Joseph LaFreniere <joseph@lafreniere.xyz>
+;;; Copyright © 2019 Todor Kondi? <tk.code@protonmail.com>15669
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -25643,6 +25644,25 @@ (define-public emacs-evil-cleverparens
corresponding Evil keys.")
(license license:expat))))

+(define-public emacs-ntlm
+ (package
+ (name "emacs-ntlm")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/ntlm-" version ".el"))
+ (sha256
+ (base32
+ "01d0bcmh8a36qf871w6bc05kjk9bmnh843m9869xw06zyvqwg9mv"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/ntlm.html")
+ (synopsis "NTLM (NT LanManager) authentication support")
+ (description "This library is a direct translation of the Samba release
+2.2.0 implementation of Windows NT and LanManager compatible password
+encryption.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:35
[PATCH v2 2/6] gnu: Add emacs-nadvice.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
AoXAW4jY57UR3rA04fqEynjIpGjr3dMra2_55DMKrqG3E2Dd0qBz-Xgi5fRwh7Yp8x25OurmhS9KSEkIFDFdI0ojYxN-GEyquwphfWx3ROQ=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-nadvice): New variable.

Toggle diff (30 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f4aa3259db..ff8fbc3130 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25663,6 +25663,25 @@ (define-public emacs-ntlm
encryption.")
(license license:gpl3+)))

+(define-public emacs-nadvice
+ (package
+ (name "emacs-nadvice")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/nadvice-" version ".el"))
+ (sha256
+ (base32
+ "0gi3csnxbs8h7iy0scsl35sic3gv90swa89hhdjwb7qvpirfdcgw"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/nadvice.html")
+ (synopsis "Forward compatibility for Emacs-24.4's nadvice")
+ (description "This package tries to re-implement some of nadvice.el's
+functionality on top of the old defadvice system, to help users of defadvice
+move to the new advice system without dropping support for Emacs<24.4.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:35
[PATCH v2 3/6] gnu: Add emacs-url-http-ntlm.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
iAZWQ-DIt4LW0xxyYFJOzpLYnOuyIYFNgySkE3XxUux1oPmUwexZP0MGXUswBynUPXzMBO7_Bc60pgNYi84UXXVtsVBRHYoVFzZU1Hk12MI=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-url-http-ntlm): New variable.

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ff8fbc3130..74bcbc7ba2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25682,6 +25682,24 @@ (define-public emacs-nadvice
move to the new advice system without dropping support for Emacs<24.4.")
(license license:gpl3+)))

+(define-public emacs-url-http-ntlm
+ (package
+ (name "emacs-url-http-ntlm")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/url-http-ntlm-" version ".el"))
+ (sha256
+ (base32
+ "1cakq2ykraci7d1gl8rnpv4f2f5ffyaidhqb1282g7i72adwmb98"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-ntlm" ,emacs-ntlm)))
+ (home-page "https://elpa.gnu.org/packages/url-http-ntlm.html")
+ (synopsis "NTLM authentication for the url library")
+ (description "This package provides a NTLM handler for the URL package.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:36
[PATCH v2 4/6] gnu: Add emacs-soap-client.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
Kwoo8mXptPnJV3PIUc-hZ9AWKiWHoctzGhuBoFFFTnFQwGGge7v6alA-sgmMXLyY9brMds4P2q2UA5439bLTMgXIH6do3j-aPQkdlfx4Y_c=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-soap-client): New variable.

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 74bcbc7ba2..896fa724d8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25700,6 +25700,24 @@ (define-public emacs-url-http-ntlm
(description "This package provides a NTLM handler for the URL package.")
(license license:gpl3+)))

+(define-public emacs-soap-client
+ (package
+ (name "emacs-soap-client")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/soap-client-" version ".tar"))
+ (sha256
+ (base32
+ "1s0bwnip22nj6kgjadd4zlj9j729hiyyjb66sr51i2mddnf9i95s"))))
+ (build-system emacs-build-system)
+ (home-page "httpa://elpa.gnu.org/packages/soap-client.html")
+ (synopsis "Access SOAP web services")
+ (description
+ "This package provides a SOAP client to access web services.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:36
[PATCH v2 5/6] gnu: Add emacs-fsm.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
zqCeKCDsVucK0S3iP2tWmniJm8dH1-VWkDSOYdi7dWhRswkq5ECdDK0epGIQ4XANWPt2LiPeYQXYvl6YKN2rZoZyBC1J93Y-nuH8ajj5rzA=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-fsm): New variable.

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 896fa724d8..ba33974e1b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25718,6 +25718,24 @@ (define-public emacs-soap-client
"This package provides a SOAP client to access web services.")
(license license:gpl3+)))

+(define-public emacs-fsm
+ (package
+ (name "emacs-fsm")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/fsm-" version ".el"))
+ (sha256
+ (base32
+ "1jyxyqdbfl8nv7c50q0sg3w5p7whp1sqgi7w921k5hfar4d11qqp"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/fsm.html")
+ (synopsis "Finite State Machine library")
+ (description "This package provides Finite State Machine library to
+make asynchronous programming in Emacs Lisp easy and fun.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:37
[PATCH v2 6/6] gnu: Add emacs-excorporate.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
kQrB3DngJoySo7fqAAWlp4GYmZAO_Z8Bj9JoJ90NfA3Fit9YC9IBE5L51jmPvgLNnJ0A2LpZ7-6ptc5eIcmLEixJyQxzJ9TYysBQF8XdBP8=@protonmail.com
* gnu/packages/emacs-xyz.scm (emacs-excorporate): New variable.

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ba33974e1b..c1fd6018d0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25736,6 +25736,29 @@ (define-public emacs-fsm
make asynchronous programming in Emacs Lisp easy and fun.")
(license license:gpl3+)))

+(define-public emacs-excorporate
+ (package
+ (name "emacs-excorporate")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/excorporate-" version ".tar"))
+ (sha256
+ (base32
+ "1g0wc2kp15ra323b4rxvdh58q9c4h7m20grw6a0cs53m7l9xi62f"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-fsm" ,emacs-fsm)
+ ("emacs-soap-client" ,emacs-soap-client)
+ ("emacs-url-http-ntlm" ,emacs-url-http-ntlm)
+ ("emacs-nadvice" ,emacs-nadvice)))
+ (home-page "https://elpa.gnu.org/packages/excorporate.html")
+ (synopsis "Exchange integration")
+ (description "This package provides Exchange integration
+for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))
--
2.33.1
P
P
phodina wrote on 4 Nov 2021 22:39
RE: gnu: Add emacs-excorporate.
(name . 36091@debbugs.gnu.org)(address . 36091@debbugs.gnu.org)
NS2p4swMQN1YhdmTJu1T04nO2CnwirUD3VsPWKCB01RQqMwzlGRMazGMGPyyMDJ5e0Zqs7S3cqfMh4DqIZd6NoC5BIhFqsWoMKBdqIeCQmw=@protonmail.com
Hello Oleg, Brett and TK,

here are the modified patches. Hope all the issues are fixed.

Petr
N
N
Nicolas Goaziou wrote on 6 Nov 2021 10:45
Re: [bug#36091] gnu: Add emacs-excorporate.
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
87y261pqh9.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> here are the modified patches. Hope all the issues are fixed.

Applied. Thank you.

Note that the indentation was off in most of the package definitions.
You may want to double-check how you indent the code, using ,e.g.,
etc/indent-code.el.

Regards,
--
Nicolas Goaziou
P
P
phodina wrote on 6 Nov 2021 17:19
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
l-lvnsaQl7rxnB7TrthKBxLy4_muoJ4j7_TyDtFPUD5k5JgY7d7LvOnCg6CAnswY0lFi1CB2LW_bk5N3I_HB8JGUoIn0cJPjgTBbSo5kdPA=@protonmail.com
Hi Nicolas,

On Saturday, November 6th, 2021 at 10:45 AM, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (19 lines)
> Hello,
>
> phodina via Guix-patches via guix-patches@gnu.org writes:
>
> > here are the modified patches. Hope all the issues are fixed.
>
> Applied. Thank you.
>
> Note that the indentation was off in most of the package definitions.
>
> You may want to double-check how you indent the code, using ,e.g.,
>
> etc/indent-code.el.
>
> Regards,
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
> Nicolas Goaziou

Sorry for the indentation and additional effort. I sometimes forget to run it.

Do you now some git hook that would do that?

My thinking was to parse the first line in git commit and extract the package name, then run the script.

Petr
N
N
Nicolas Goaziou wrote on 7 Nov 2021 21:27
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
878rxzognt.fsf@nicolasgoaziou.fr
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> Do you now some git hook that would do that?

I just hit M-q in Emacs out of habit.

I guess you could use pre-commit hook, grab the package name, and call
indent-code.el on it.

Regards,
--
Nicolas Goaziou
?