[PATCH] sawfish.scm - update sawfish to 1.12

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Benjamin Slade
Owner
unassigned
Submitted by
Benjamin Slade
Severity
normal
B
B
Benjamin Slade wrote on 3 Jun 2019 01:35
(address . guix-patches@gnu.org)
87imtnsgqb.fsf@jnanam.net
From 59c8784ffb33cdce08574d13ac8675c5e3c50b1d Mon Sep 17 00:00:00 2001
From: Benjamin Slade <slade@jnanam.net>
Date: Sun, 2 Jun 2019 17:21:21 -0600
Subject: [PATCH] sawfish.scm - update sawfish to 1.12

---
gnu/packages/sawfish.scm | 16 ++++++++--------
1 file changed, 8 insertions(+), 8 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index 1ac72f2baa..4a475eb06e 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Benjamin Slade <slade@jnanam.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,7 +42,7 @@
(version "0.92.7")
(source (origin
(method url-fetch)
- (uri (string-append "http://download.tuxfamily.org/" name "/"
+ (uri (string-append "https://download.tuxfamily.org/" name "/"
name "_" version ".tar.xz"))
(sha256
(base32
@@ -50,7 +51,6 @@
(native-inputs
`(("makeinfo" ,texinfo)
("pkg-config" ,pkg-config)
-
("autoconf" ,autoconf-wrapper)
("automake" ,automake)
("libtool" ,libtool)))
@@ -63,7 +63,7 @@
(list (search-path-specification
(variable "REP_DL_LOAD_PATH")
(files '("lib/rep")))))
- (home-page "http://sawfish.wikia.com/wiki/Librep")
+ (home-page "https://sawfish.wikia.com/wiki/Librep")
(synopsis "Lisp system for sawfish")
(description
"Librep is a dialect of Lisp, designed to be used both as an extension
@@ -77,7 +77,7 @@ implementing both small and large scale systems.")
(define-public rep-gtk
(package
(name "rep-gtk")
- (version "0.90.8.2")
+ (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.
(source (origin
(method url-fetch)
(uri (string-append "http://download.tuxfamily.org/librep/"
@@ -111,14 +111,14 @@ backend of Sawfish.")
(define-public sawfish
(package
(name "sawfish")
- (version "1.11")
+ (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.
(source (origin
(method url-fetch)
- (uri (string-append "http://download.tuxfamily.org/sawfish/"
+ (uri (string-append "https://download.tuxfamily.org/sawfish/"
name "_" version ".tar.xz"))
(sha256
(base32
- "0wp4m0p836a0rysbcdqb6z5hxlxqj3rgdbks3bs44rlssx0mcvyg"))
+ "1z7awzgw8d15aw17kpbj460pcxq8l2rhkaxk47w7yg9qrmg0xja4"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -172,7 +172,7 @@ backend of Sawfish.")
("libxrandr" ,libxrandr)
("libxtst" ,libxtst)
("rep-gtk" ,rep-gtk)))
- (home-page "http://sawfish.wikia.com/wiki/Main_Page")
+ (home-page "https://sawfish.wikia.com/wiki/Main_Page")
(synopsis "Configurable window manager")
(description
"Sawfish is an extensible window manager using a Lisp-based scripting
--
2.21.0
--
Dr Benjamin Slade - https://slade.jnanam.net/ https://babbagefiles.xyz
`(pgp_fp: ,(21BA 2AE1 28F6 DF36 110A 0E9C A320 BBE8 2B52 EE19))
'(sent by mu4e on Emacs running under GNU/Linux . https://gnu.org)
A
A
Arun Isaac wrote on 4 Jun 2019 15:00
cu7lfyha4jw.fsf@systemreboot.net
Thanks for contributing to Guix!

Please split this into three separate patches -- one each for librep,
rep-gtk and sawfish. For the commit messages, please use the
conventional Guix update commit message. If you use Emacs, this can be
done easily using the update yasnippet in etc/snippets of the Guix
source tree.

Toggle quote (3 lines)
> + (home-page "https://sawfish.wikia.com/wiki/Librep")

Shouldn't https://sawfish.tuxfamily.org/be the home-page for all three
packages? Why are we listing the wiki as the home-page?

Toggle quote (6 lines)
> (define-public rep-gtk
> (package
> (name "rep-gtk")
> - (version "0.90.8.2")
> + (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.

We don't usually package beta releases. So, there is no need to mention
this as a comment. But, the current release is 0.90.8.3. Please update
to that.

Toggle quote (6 lines)
> (define-public sawfish
> (package
> (name "sawfish")
> - (version "1.11")
> + (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.

We don't usually package beta releases. So, there is no need to mention
this as a comment.

Toggle quote (3 lines)
> + (home-page "https://sawfish.wikia.com/wiki/Main_Page")

See above for comment on home-page.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAlz2a3MACgkQLiXui2GA
K7PkCQf/W1g3nigcaWAs/XEEeieJy+gz1/SGvEBAkG54lYvwPqzQI1uHkiACVv50
5dCXfHVlvqpqut2va/gHSqdfqZe9A4PRjJXy8uC06jHg/Cto7k8xweqN5I9qa3AW
gG4K+Pml20NnCU9iU9we4j+hCCPVmmRotyw7ahK14bX5fEnrBFjxLk+VzklrGX1e
B2wX6ai/y9pqnKw1bbjj8TsDkmRn2RGyyued7SwW045m/scmhKsHLj+NrL7M30QT
Uyk6xa0gt65Rk9IiAmic/+NbLqXitnz6c78NSekgNLRy6LcpyoiNG2XD2ifdGa8Y
aRPGKmLuCZYtd1WTdEKBuHFV+rsgKg==
=hoTB
-----END PGP SIGNATURE-----

B
B
Benjamin Slade wrote on 10 Jun 2019 08:36
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 36064@debbugs.gnu.org)
87imtevteu.fsf@jnanam.net
On 2019-06-04T07:00:35-0600, Arun Isaac <arunisaac@systemreboot.net> wrote:
> Thanks for contributing to Guix!

Hi Arun,

Thanks for the feedback.

> Please split this into three separate patches -- one each for librep,
> rep-gtk and sawfish. For the commit messages, please use the
> conventional Guix update commit message. If you use Emacs, this can
> be done easily using the update yasnippet in etc/snippets of the Guix
> source tree.

I'll do so.


> Shouldn't https://sawfish.tuxfamily.org/be the home-page for all
> three packages? Why are we listing the wiki as the home-page?

I just followed the previous version, updating to 'https'. But
https://sawfish.tuxfamily.org/doesn't actually have information
directly about Librep, while the wiki page the previous commit linked to
does provide information about the package.

> > (define-public rep-gtk
> > (package
> > (name "rep-gtk")
> > - (version "0.90.8.2")
> > + (version "0.90.8.2") ; next point release hasn't been distributed; requires autoconf etc.

> We don't usually package beta releases. So, there is no need to
> mention this as a comment. But, the current release is
> 0.90.8.3. Please update to that.

0.90.8.3 isn't packaged for distribution though, so it may be
beta-ish. In any case, I don't know how to get it to build, given that
it's not packaged for distribution at this point.

> > (define-public sawfish
> > (package
> > (name "sawfish")
> > - (version "1.11")
> > + (version "1.12.0") ; point release 1.12.90 hasn't been distributed; requires autoconf etc.

> We don't usually package beta releases. So, there is no need to
> mention this as a comment.


> See above for comment on home-page.

Effectively, then, I'm just updating `sawfish` itself, given the lack of
a need for the comments I had made about versions, so I'll resubmit a
patch just updating the sawfish package.

--
Dr Benjamin Slade - https://babbagefiles.xyz
`(pgp_fp: ,(21BA 2AE1 28F6 DF36 110A 0E9C A320 BBE8 2B52 EE19))
'(sent by mu4e on Emacs running under GNU/Linux . https://gnu.org)
A
A
Arun Isaac wrote on 27 Jun 2019 08:58
(name . Benjamin Slade)(address . slade@jnanam.net)(address . 36064-done@debbugs.gnu.org)
cu7o92jfray.fsf@systemreboot.net
Toggle quote (4 lines)
> 0.90.8.3 isn't packaged for distribution though, so it may be
> beta-ish. In any case, I don't know how to get it to build, given that
> it's not packaged for distribution at this point.

The sawfish website lists 0.90.8.3 as current. So, I think we should
update. I did this, and pushed my changes to master.

Toggle quote (4 lines)
> Effectively, then, I'm just updating `sawfish` itself, given the lack of
> a need for the comments I had made about versions, so I'll resubmit a
> patch just updating the sawfish package.

I edited your earlier patch to only update sawfish, and pushed it to
master.

Thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl0UaQUACgkQLiXui2GA
K7NsEgf/Vbtc/QrVxRHBA0LiUCxoMRGovbJU803ZWVExHax9JoSN2E6Mr9PC4zxS
dgken61K6QBQsNsgHAhh/uyGiI2OArh+M3kTYjQ8lPh8T9n9uwM3IueiHHcqH1Di
gsnS0aM+PWJzhKH0oDBvNOPTr2iJLHIjMtl4G1BUmWaO2O08HjCPAYK9wEexF+Yf
wNIJ+kzcTA2Qhp0rdLEfTMGOaZjg+3v1/BGy/vZe4DmVVPnvCZmYybkWRKiuuqcz
wkKBtDH1c4VLxDR1bs9BsRVuU1wj6BNF+7UcUkiSaHpiT3HXuj/H5P5ZBPbU5mwM
ezJOmBo+bE+wku89eIHf1g0K4TKQiQ==
=jG2K
-----END PGP SIGNATURE-----

Closed
?