[PATCH] services: cups: Create /var/cache on activation.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Griffin
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Griffin
Severity
normal
A
A
Alex Griffin wrote on 2 Jun 2019 23:31
(address . guix-patches@gnu.org)
573c52c2-ec82-44ff-b543-af3be78e877b@www.fastmail.com
I recently ran into the situation where CUPS wouldn't start because /var/cache didn't exist yet. This patch just creates /var/cache on CUPS activation.

--
Alex Griffin
From 4a2335d70088ad485ca2f91d5f21a4e7078fb927 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 2 Jun 2019 16:26:47 -0500
Subject: [PATCH] services: cups: Create /var/cache on activation.

* gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
exist yet.
---
gnu/services/cups.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 9125139ef3..4cdc83452f 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -897,6 +898,7 @@ IPP specifications.")
(mkdir-p/perms "/var/log/cups" user #o755)
(mkdir-p/perms "/etc/cups" user #o755)
(mkdir-p/perms "/etc/cups/ssl" user #o700)
+ (mkdir-p "/var/cache")
;; This certificate is used for HTTPS connections to the CUPS web
;; interface.
(create-self-signed-certificate-if-absent
--
2.21.0
A
A
Alex Griffin wrote on 3 Jun 2019 21:57
(address . 36060@debbugs.gnu.org)
dc9c7b56-8f4e-47be-a65c-cffd7c331f91@www.fastmail.com
Maybe this patch fits in a little better. I used mkdir-p/perms like the surrounding code instead of just mkdir-p.

--
Alex Griffin
From b09759e4a2a348d6bdd1fef9593871e9e0a75a68 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 2 Jun 2019 16:26:47 -0500
Subject: [PATCH] services: cups: Create /var/cache on activation.

* gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
exist yet.
---
gnu/services/cups.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 9125139ef3..5d9e373117 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -897,6 +898,7 @@ IPP specifications.")
(mkdir-p/perms "/var/log/cups" user #o755)
(mkdir-p/perms "/etc/cups" user #o755)
(mkdir-p/perms "/etc/cups/ssl" user #o700)
+ (mkdir-p/perms "/var/cache" user #o770)
;; This certificate is used for HTTPS connections to the CUPS web
;; interface.
(create-self-signed-certificate-if-absent
--
2.21.0
A
A
Alex Griffin wrote on 3 Jun 2019 22:01
(address . 36060@debbugs.gnu.org)
6814c5b5-f2a1-4a9f-99bf-a37be2af1427@www.fastmail.com
Maybe this patch fits in a little better. I used mkdir-p/perms like the surrounding code instead of just mkdir-p.

--
Alex Griffin
From 2ef61ab79cb387e00317cda54d893c061d9a1206 Mon Sep 17 00:00:00 2001
From: Alex Griffin <a@ajgrf.com>
Date: Sun, 2 Jun 2019 16:26:47 -0500
Subject: [PATCH] services: cups: Create /var/cache on activation.

* gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
exist yet.
---
gnu/services/cups.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/services/cups.scm b/gnu/services/cups.scm
index 9125139ef3..9d21b6e70c 100644
--- a/gnu/services/cups.scm
+++ b/gnu/services/cups.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -895,6 +896,7 @@ IPP specifications.")
(mkdir-p/perms "/var/spool/cups" user #o755)
(mkdir-p/perms "/var/spool/cups/tmp" user #o755)
(mkdir-p/perms "/var/log/cups" user #o755)
+ (mkdir-p/perms "/var/cache/cups" user #o770)
(mkdir-p/perms "/etc/cups" user #o755)
(mkdir-p/perms "/etc/cups/ssl" user #o700)
;; This certificate is used for HTTPS connections to the CUPS web
--
2.21.0
L
L
Ludovic Courtès wrote on 5 Jun 2019 17:17
(name . Alex Griffin)(address . a@ajgrf.com)(address . 36060-done@debbugs.gnu.org)
8736ko12pp.fsf@gnu.org
Hi Alex,

"Alex Griffin" <a@ajgrf.com> skribis:

Toggle quote (8 lines)
> From 2ef61ab79cb387e00317cda54d893c061d9a1206 Mon Sep 17 00:00:00 2001
> From: Alex Griffin <a@ajgrf.com>
> Date: Sun, 2 Jun 2019 16:26:47 -0500
> Subject: [PATCH] services: cups: Create /var/cache on activation.
>
> * gnu/services/cups.scm (%cups-activation): Create /var/cache if it doesn't
> exist yet.

Applied, thanks!

Ludo'.
Closed
?