[PATCH 47/47] gnu: Add python-takethetime.

  • Open
  • quality assurance status badge
Details
One participant
  • h.nasajpour
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:37
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003724.3464-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-takethetime): New variable.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2ebc79283..2ca5dbae4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15574,3 +15574,22 @@ by Igor Pavlov.")
With JSON we can make our logs more readable by machines and we can stop writing custom parsers for syslog type records.")
(license license:expat)))
+(define-public python-takethetime
+ (package
+ (name "python-takethetime")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "TakeTheTime" version))
+ (sha256 (base32 "1y9gzqb9l1f2smx8783ccjzjvby5mphshgrfks7s75mml59h9qyv"))))
+ (build-system python-build-system)
+ (arguments
+ `(
+ #:tests? #f
+ ))
+ (inputs
+ `(("python-typing" ,python-typing)))
+ (home-page "https://github.com/ErikBjare/TakeTheTime")
+ (synopsis "Take The Time, a time-taking library for Python")
+ (description "Take The Time, a time-taking library for Python.")
+ (license license:expat)))
--
2.17.1
?