[PATCH 46/47] gnu: Add python-json-logger.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • h.nasajpour
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:36
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003636.3364-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-json-logger): New variable.
---
gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e47e5bbcd2..b2ebc79283 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15555,3 +15555,22 @@ by Igor Pavlov.")
"persist-queue implements a file-based queue and a serial of sqlite3-based queues")
(license license:bsd-2)))
+(define-public python-json-logger
+ (package
+ (name "python-json-logger")
+ (version "0.1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-json-logger" version))
+ (sha256 (base32 "10g2ya6nsvn5vxzvq2wb8q4d43i3d7756i5rxyjna6d0y9i138xp"))))
+ (build-system python-build-system)
+ (arguments
+ `(
+ #:tests? #f
+ ))
+ (home-page "https://github.com/madzak/python-json-logger")
+ (synopsis "A python library adding a json log formatter.")
+ (description "This library is provided to allow standard python logging to output log data as json objects.
+ With JSON we can make our logs more readable by machines and we can stop writing custom parsers for syslog type records.")
+ (license license:expat)))
+
--
2.17.1
B
B
Brett Gilio wrote on 25 Jul 2020 03:32
Close 35978
(address . control@debbugs.gnu.org)
87y2n84bwo.fsf@gnu.org
close 35978
?