[PATCH 45/47] gnu: Add python-strict-rfc3339.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • h.nasajpour
  • Jelle Licht
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:36
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003621.3314-1-h.nasajpour@pantherx.org
* gnu/packages/time.scm (python-strict-rfc3339): New variable
---
gnu/packages/time.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 1363843b31..9e23ffae14 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -440,3 +440,21 @@ datetime type.")
modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
calls.")
(license gpl2)))
+
+(define-public python-strict-rfc3339
+ (package
+ (name "python-strict-rfc3339")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "strict-rfc3339" version))
+ (sha256 (base32 "0xqjbsn0g1h88rayh5yrpdagq60zfwrfs3yvk6rmgby3vyz1gbaw"))))
+ (build-system python-build-system)
+ (arguments
+ `(
+ #:tests? #f
+ ))
+ (home-page "https://github.com/danielrichman/strict-rfc3339")
+ (synopsis "Strict, simple, lightweight RFC3339 functions.")
+ (description "Convert unix timestamps to and from RFC3339.")
+ (license license:gpl3+)))
--
2.17.1
B
B
Brett Gilio wrote on 10 Dec 2019 07:47
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35977@debbugs.gnu.org)
87lfrkk770.fsf@posteo.net
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

Toggle quote (32 lines)
> * gnu/packages/time.scm (python-strict-rfc3339): New variable
> ---
> gnu/packages/time.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)
>
> diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
> index 1363843b31..9e23ffae14 100644
> --- a/gnu/packages/time.scm
> +++ b/gnu/packages/time.scm
> @@ -440,3 +440,21 @@ datetime type.")
> modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
> calls.")
> (license gpl2)))
> +
> +(define-public python-strict-rfc3339
> + (package
> + (name "python-strict-rfc3339")
> + (version "0.7")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "strict-rfc3339" version))
> + (sha256 (base32 "0xqjbsn0g1h88rayh5yrpdagq60zfwrfs3yvk6rmgby3vyz1gbaw"))))
> + (build-system python-build-system)
> + (arguments
> + `(
> + #:tests? #f
> + ))
> + (home-page "https://github.com/danielrichman/strict-rfc3339")
> + (synopsis "Strict, simple, lightweight RFC3339 functions.")
> + (description "Convert unix timestamps to and from RFC3339.")
> + (license license:gpl3+)))

Hi,

Again, we are needing some revisions before this package is ready to be
merged. Spare my brevity, but here is a list.

1. The commit message does not follow our style guide.
2. The indentation for the hash is incorrect. See surrounding packages
for an idea of how to do this.
3. Parens should not go on lines by themselves.
4. Disabled tests should either be disabled with reason, but only if
they fail for reasons we can not control.
5. Synopsis/Description does not follow our style guide.

As before, if you need help please do let me know :).

--
Brett M. Gilio
Homepage -- https://scm.pw/
J
J
Jelle Licht wrote on 20 Jun 2023 23:22
Re: bug#35977: [PATCH 45/47] gnu: Add python-strict-rfc3339.
(address . 35977-done@debbugs.gnu.org)
87wmzx6d7t.fsf@fsfe.org
This package can be found in guix master. Closing.
- Jelle
Closed
?