[PATCH 43/47] gnu: Add python-mypy.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • h.nasajpour
  • zimoun
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:35
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003550.3213-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-mypy): New variable
* gnu/packages/python-xyz.scm (python-mypy_extensions): New variable
---
gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93783d17ee..298a59f59f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15495,4 +15495,45 @@ by Igor Pavlov.")
as they are based on the CPython 2.7 and 3.6 parsers.")
(license license:expat)))
+(define-public python-mypy_extensions
+ (package
+ (name "python-mypy_extensions")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mypy_extensions" version))
+ (sha256 (base32 "04h8brrbbx151dfa2cvvlnxgmb5wa00mhd2z7nd20s8kyibfkq1p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "http://www.mypy-lang.org/")
+ (synopsis "Experimental type system extensions for programs checked with the mypy typechecker.")
+ (description
+ "The “mypy_extensions” module defines experimental extensions to the standard “typing” module that are supported by the mypy typechecker..")
+ (license license:expat)))
+
+(define-public python-mypy
+ (package
+ (name "python-mypy")
+ (version "0.701")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "mypy" version))
+ (sha256 (base32 "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs `(
+ ("python-typed-ast" , python-typed-ast)
+ ("python-mypy_extensions" , python-mypy_extensions)
+ ("python-typed-ast" , python-typed-ast)
+ ))
+ (home-page "http://www.mypy-lang.org/")
+ (synopsis "Optional static typing for Python (mypyc-compiled version)")
+ (description
+ "Add type annotations to your Python programs, and use mypy to type check them.
+ Mypy is essentially a Python linter on steroids, and it can catch many programming errors by analyzing your program,
+ without actually having to run it. Mypy has a powerful type system with features such as type inference,
+ gradual typing, generics and union types.")
+ (license license:expat)))
--
2.17.1
B
B
Brett Gilio wrote on 10 Dec 2019 07:42
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35975@debbugs.gnu.org)
87r21ck7ft.fsf@posteo.net
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

Toggle quote (56 lines)
> * gnu/packages/python-xyz.scm (python-mypy): New variable
> * gnu/packages/python-xyz.scm (python-mypy_extensions): New variable
> ---
> gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
> 1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 93783d17ee..298a59f59f 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15495,4 +15495,45 @@ by Igor Pavlov.")
> as they are based on the CPython 2.7 and 3.6 parsers.")
> (license license:expat)))
>
> +(define-public python-mypy_extensions
> + (package
> + (name "python-mypy_extensions")
> + (version "0.4.1")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "mypy_extensions" version))
> + (sha256 (base32 "04h8brrbbx151dfa2cvvlnxgmb5wa00mhd2z7nd20s8kyibfkq1p"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))
> + (home-page "http://www.mypy-lang.org/")
> + (synopsis "Experimental type system extensions for programs checked with the mypy typechecker.")
> + (description
> + "The “mypy_extensions” module defines experimental extensions to the standard “typing” module that are supported by the mypy typechecker..")
> + (license license:expat)))
> +
> +(define-public python-mypy
> + (package
> + (name "python-mypy")
> + (version "0.701")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "mypy" version))
> + (sha256 (base32 "05479r3gbq17r22hyhxjg49smx5q864pgx8ayy23rsdj4w6z2r2p"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))
> + (inputs `(
> + ("python-typed-ast" , python-typed-ast)
> + ("python-mypy_extensions" , python-mypy_extensions)
> + ("python-typed-ast" , python-typed-ast)
> + ))
> + (home-page "http://www.mypy-lang.org/")
> + (synopsis "Optional static typing for Python (mypyc-compiled version)")
> + (description
> + "Add type annotations to your Python programs, and use mypy to type check them.
> + Mypy is essentially a Python linter on steroids, and it can catch many programming errors by analyzing your program,
> + without actually having to run it. Mypy has a powerful type system with features such as type inference,
> + gradual typing, generics and union types.")
> + (license license:expat)))

Hi,

This package requires a few revisions before it can be merged to master.

If you could separate the packages out either as separate patches in a
series or by having the extensions package as a native input defined
inline of the `python-mypy' package that would be terrific!

Additionally, there are several issues with indentation. Generally we do
not like open and close parenthesis along on lines by
themselves. Additionally there are some issues with your
description. Make sure to run `guix lint` to catch some of these issues.

Lastly, this package has a new version upstream.

If you need help let me know! Thanks!

--
Brett M. Gilio
Homepage -- https://scm.pw/
Z
Z
zimoun wrote on 7 Apr 2022 15:04
Re: bug#35975: [PATCH 43/47] gnu: Add python-mypy.
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35975-done@debbugs.gnu.org)
86wng111u7.fsf_-_@gmail.com
Hi,

Thanks for your submission. Guix currently provides MyPy added by
4fae4f9aab806451535db032b43cba558668cf64 therefore I am closing.


On Wed, 29 May 2019 at 05:05, "h.nasajpour" <h.nasajpour@pantherx.org> wrote:

Toggle quote (5 lines)
> +(define-public python-mypy
> + (package
> + (name "python-mypy")
> + (version "0.701")

Toggle snippet (6 lines)
$ guix show python-mypy | recsel -p name,version
name: python-mypy
version: 0.931


Cheers,
simon
Closed
?