[PATCH 40/47] gnu: Add python-xlib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • h.nasajpour
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:34
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003429.3007-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-xlib): New variable
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30a7c3c6ad..b9bfc1be14 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5786,6 +5786,37 @@ falling into the Python interpreter.")
(define-public python2-q
(package-with-python2 python-q))
+(define-public python-xlib
+ (package
+ (name "python-xlib")
+ (version "0.25")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/python-xlib/python-xlib")
+ (commit "84219d5043a63eab219fcb59f3590f7b3b6a7e91")))
+ (sha256
+ (base32 "0zdwfgzq7qz8fk0qgwg3gz2h04fad7bynp8wiq1q2y5v6ns09q9n"))
+ (file-name (git-file-name name version))
+ ))
+ (build-system python-build-system)
+ (arguments
+ `(
+ #:tests? #f))
+ (native-inputs
+ `(
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-six" ,python-six)
+ ))
+ (home-page "https://github.com/python-xlib/python-xlib")
+ (synopsis "Python X11 client library")
+ (description
+ "The Python X Library is intended to be a fully functional X client
+library for Python programs. It is useful to implement low-level X clients.
+It is written entirely in Python.")
+ (license license:lgpl2.1)))
+
(define-public python2-xlib
(package
(name "python2-xlib")
--
2.17.1
B
B
Brett Gilio wrote on 25 Jul 2020 03:36
(address . control@debbugs.gnu.org)
87v9ic4bql.fsf@gnu.org
close 35972
?