[PATCH 39/47] gnu: Add python-relativetimebuilder.

  • Open
  • quality assurance status badge
Details
One participant
  • h.nasajpour
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:33
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003355.2951-1-h.nasajpour@pantherx.org
* gnu/packages/time.scm (python-relativetimebuilder): New variable
---
gnu/packages/time.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 9bbfe07803..1363843b31 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -381,6 +381,28 @@ datetime type.")
(define-public python2-aniso8601
(package-with-python2 python-aniso8601))
+(define-public python-relativetimebuilder
+ (package
+ (name "python-relativetimebuilder")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "relativetimebuilder" version))
+ (sha256 (base32 "0dxj2jci4jsqv0w4alhj9lbrw9qdxkdl2y7mnk0xns7i2ps0i1jn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(
+ ("python-aniso8601",python-aniso8601)
+ ("python-dateutil",python-dateutil)
+ ))
+ (home-page "https://bitbucket.org/nielsenb/relativetimebuilder/src/master/")
+ (synopsis "aniso8601 builder for dateutil relativedeltas")
+ (description
+ "A library for using the dateutil relativedeltas for calendar precision with aniso8601")
+ (license license:expat)))
+
(define-public datefudge
(package
(name "datefudge")
--
2.17.1
?