[PATCH 3/3] gnu: Add python-flask-cors.

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • Danny Milosavljevic
  • h.nasajpour
  • zimoun
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 28 May 2019 12:57
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190528105743.3749-1-h.nasajpour@pantherx.org
* gnu/packages/python-web.scm (python-flask-cors): New variable.
---
gnu/packages/python-web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 79f4ec3565..ab11119f07 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2095,6 +2095,26 @@ SlimIt also provides a library that includes a JavaScript parser, lexer,
pretty printer and a tree visitor.")
(license license:expat)))
+(define-public python-flask-cors
+ (package
+ (name "python-flask-cors")
+ (version "3.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Cors" version))
+ (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-flask" ,python-flask)))
+ (home-page "https://github.com/corydolphin/flask-cors")
+ (synopsis "A Flask extension adding a decorator for CORS support")
+ (description
+ "A Flask extension adding a decorator for CORS support")
+ (license license:expat)))
+
(define-public python-flask-restful
(package
(name "python-flask-restful")
--
2.21.0
D
D
Danny Milosavljevic wrote on 28 May 2019 21:09
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35949@debbugs.gnu.org)
20190528210944.5ad9cd56@scratchpost.org
Hi,

On Tue, 28 May 2019 15:27:43 +0430
"h.nasajpour" <h.nasajpour@pantherx.org> wrote:

Toggle quote (5 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "Flask-Cors" version))
> + (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))

Strange indentation.

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f))

Please add a comment with the reason.
Toggle quote (8 lines)
> + (propagated-inputs
> + `(("python-six" ,python-six)
> + ("python-flask" ,python-flask)))
> + (home-page "https://github.com/corydolphin/flask-cors")
> + (synopsis "A Flask extension adding a decorator for CORS support")
> + (description
> + "A Flask extension adding a decorator for CORS support")

Please add text to the description that describes what CORS is.
Also, the description should be full sentences.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzth3gACgkQ5xo1VCww
uqWT+gf+L0dQ4unz4zw7Icz5eVdRAXyzjZCCykqaWNH8XvKhQGr34STM+fSSranZ
g8b6TRiBq0+3fCQeVNoAcykMqBIarDHKABRS+AyQ6OTe2f4tTsNrtbY3AR/xxZvg
fQda609kc/SGGVkMPv5hfpjjqdOzrykbu1aZZLJj0eEALRSRaT4VENWiUjEBx8kW
RdPP6ZB9V4TnBoOI0RudoVHxXNNZQ4zTbI8gJijAfJAobpiKjQkZIaL5iFm8a67W
+LVZZ4uujJwBmrIcx4Ft5v3lzn0XBYbdiXYDkiMf+hRggMeNlq4ocNA0SjPKl13a
0weAf08sq1JIc9S1kmMS5kcEovz3Sw==
=qj+H
-----END PGP SIGNATURE-----


H
H
Hamzeh Nasajpour wrote on 29 May 2019 02:58
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 35949@debbugs.gnu.org)
3bc93562-ec2c-4444-b8b0-0d9b8bc6d446@www.fastmail.com
+(define-public python-flask-cors
+ (package
+ (name "python-flask-cors")
+ (version "3.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "Flask-Cors" version))
+ (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-flask" ,python-flask)))
+ (synopsis "A Flask extension adding a decorator for CORS support")
+ (description
+ "This package has a simple philosophy, when you want to enable CORS, you wish to enable it for all use cases on a domain. This means no mucking around with different allowed headers, methods, etc. By default, submission of cookies across domains is disabled due to the security implications")
+ (license license:expat)))
+

On Tue, May 28, 2019, at 11:39 PM, Danny Milosavljevic wrote:
Toggle quote (28 lines)
> Hi,
>
> On Tue, 28 May 2019 15:27:43 +0430
> "h.nasajpour" <h.nasajpour@pantherx.org> wrote:
>
> > + (source (origin
> > + (method url-fetch)
> > + (uri (pypi-uri "Flask-Cors" version))
> > + (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
>
> Strange indentation.
>
> > + (arguments
> > + `(#:tests? #f))
>
> Please add a comment with the reason.
>
> > + (propagated-inputs
> > + `(("python-six" ,python-six)
> > + ("python-flask" ,python-flask)))
> > + (home-page "https://github.com/corydolphin/flask-cors")
> > + (synopsis "A Flask extension adding a decorator for CORS support")
> > + (description
> > + "A Flask extension adding a decorator for CORS support")
>
> Please add text to the description that describes what CORS is.
> Also, the description should be full sentences.
>
H
H
Hamzeh Nasajpour wrote on 29 Jul 2019 08:45
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 35949@debbugs.gnu.org)
5033d19b-37ca-4739-a083-2f4a092fe9d2@www.fastmail.com
Hi,

What's the status of this patch?

Regards,

On Wed, May 29, 2019, at 5:28 AM, Hamzeh Nasajpour wrote:
Toggle quote (55 lines)
> +(define-public python-flask-cors
> + (package
> + (name "python-flask-cors")
> + (version "3.0.7")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "Flask-Cors" version))
> + (sha256 (base32
> "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))
> + (propagated-inputs
> + `(("python-six" ,python-six)
> + ("python-flask" ,python-flask)))
> + (home-page "https://github.com/corydolphin/flask-cors")
> + (synopsis "A Flask extension adding a decorator for CORS support")
> + (description
> + "This package has a simple philosophy, when you want to enable
> CORS, you wish to enable it for all use cases on a domain. This means
> no mucking around with different allowed headers, methods, etc. By
> default, submission of cookies across domains is disabled due to the
> security implications")
> + (license license:expat)))
> +
>
> On Tue, May 28, 2019, at 11:39 PM, Danny Milosavljevic wrote:
> > Hi,
> >
> > On Tue, 28 May 2019 15:27:43 +0430
> > "h.nasajpour" <h.nasajpour@pantherx.org> wrote:
> >
> > > + (source (origin
> > > + (method url-fetch)
> > > + (uri (pypi-uri "Flask-Cors" version))
> > > + (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> >
> > Strange indentation.
> >
> > > + (arguments
> > > + `(#:tests? #f))
> >
> > Please add a comment with the reason.
> >
> > > + (propagated-inputs
> > > + `(("python-six" ,python-six)
> > > + ("python-flask" ,python-flask)))
> > > + (home-page "https://github.com/corydolphin/flask-cors")
> > > + (synopsis "A Flask extension adding a decorator for CORS support")
> > > + (description
> > > + "A Flask extension adding a decorator for CORS support")
> >
> > Please add text to the description that describes what CORS is.
> > Also, the description should be full sentences.
> >
B
B
Brett Gilio wrote on 10 Dec 2019 07:34
(name . Hamzeh Nasajpour)(address . h.nasajpour@pantherx.org)
87zhg0k7sc.fsf@posteo.net
"Hamzeh Nasajpour" <h.nasajpour@pantherx.org> writes:

Toggle quote (25 lines)
> +(define-public python-flask-cors
> + (package
> + (name "python-flask-cors")
> + (version "3.0.7")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "Flask-Cors" version))
> + (sha256 (base32 "1v6gq4vjgyxi8q8lxawpdfhq01adb4bznnabp08ks5nzbwibz43y"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))
> + (propagated-inputs
> + `(("python-six" ,python-six)
> + ("python-flask" ,python-flask)))
> + (home-page "https://github.com/corydolphin/flask-cors")
> + (synopsis "A Flask extension adding a decorator for CORS support")
> + (description
> + "This package has a simple philosophy, when you want to enable CORS,
> you wish to enable it for all use cases on a domain. This means no
> mucking around with different allowed headers, methods, etc. By
> default, submission of cookies across domains is disabled due to the
> security implications")
> + (license license:expat)))
> +

Hi Hamzeh,

This patch still needs some revision. Could you please send a properly
formatted [PATCH v2 x/1] with an explanation as to why the tests are
disabled, corrected indentation, and a description that matches our
style guide.


Thanks! If you need help, let me know.

--
Brett M. Gilio
Homepage -- https://scm.pw/
Z
Z
zimoun wrote on 7 Apr 2022 15:07
Re: bug#35949: [PATCH 3/3] gnu: Add python-flask-cors.
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35949-done@debbugs.gnu.org)
86tub511q2.fsf_-_@gmail.com
Hi,

Thank you for the submission. Currently, the version is
python-flask-cors is 0.3.10. Therefore, closing!


On Tue, 28 May 2019 at 15:27, "h.nasajpour" <h.nasajpour@pantherx.org> wrote:

Toggle quote (5 lines)
> +(define-public python-flask-cors
> + (package
> + (name "python-flask-cors")
> + (version "3.0.7")

Toggle snippet (6 lines)
$ guix show python-flask-cors | recsel -p name,version
name: python-flask-cors
version: 3.0.10


Cheers,
simon
Closed
?