guix describe: error: failed to determine origin (and possibly failed upgrades)

DoneSubmitted by Pronaip.
Details
3 participants
  • Ludovic Courtès
  • Marius Bakke
  • Pronaip
Owner
unassigned
Severity
normal
P
P
Pronaip wrote on 25 May 2019 23:47
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
aXtKBD162mZiz3h5osE4o8eeEAHOktW4Eja0q_B6zEc4XEPWniVbSuczsTeP3WlnA_k2QR2oW_EGcOJTV85jmtW8LFJSpravErS1EKDrmnY=@protonmail.com
I've been getting this error ever since I first installed Guix on Arch, but I have no idea why. I've ran guix pull and guix package -u both as root and as my own user several times since then but this error hasn't gone away.
Also I noticed that some functionality that works on my GuixSD install (like the `guix search` command) is simply nonexistent.
For obvious reasons I have no idea what version I'm on but I've run guix pull sometime in the last 48 hours and I originally installed it about a month or two before 1.0 came out. I also had some failed attempts at installing the AUR version but I don't know if that affected the later version that I installed straight from the offical script.
Attachment: file
P
P
Pronaip wrote on 25 May 2019 23:59
version
(name . 35908@debbugs.gnu.org)(address . 35908@debbugs.gnu.org)
EcIMkg3jAMVtmdENHV3jyXdpquTNWjV534Zl49hK8aVNeTJCbThda-kW-C94w-zM7F-eA78dcEiQtj93AM-8ngrDFW3U1M8WNM42HfFJDp0=@protonmail.com
oh wait, i found the version infoguix (GNU Guix) 0.16.0-11.f970946
Attachment: file
M
M
Marius Bakke wrote on 26 May 2019 08:37
Re: bug#35908: guix describe: error: failed to determine origin (and possibly failed upgrades)
87pno5d8mf.fsf@devup.no
Hi Pronaip,
Pronaip <pronaip@protonmail.com> writes:
Toggle quote (6 lines)> I've been getting this error ever since I first installed Guix on Arch, but I have no idea why. I've ran guix pull and guix package -u both as root and as my own user several times since then but this error hasn't gone away.>> Also I noticed that some functionality that works on my GuixSD install (like the `guix search` command) is simply nonexistent.>> For obvious reasons I have no idea what version I'm on but I've run guix pull sometime in the last 48 hours and I originally installed it about a month or two before 1.0 came out. I also had some failed attempts at installing the AUR version but I don't know if that affected the later version that I installed straight from the offical script.
It sounds like ~/.config/guix/current/bin is missing from PATH. See'4.6 Invoking guix pull' in the manual.
Make sure that directory appears first in $PATH in order to get thecorrect 'guix' executable.
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlzqNBgACgkQoqBt8qM6VProPAf/Xx2Z1O86tvEwGqESedUHNdI4kbvrWR6wbsVDZcL0O2vDdC4MYxb8L8r039BJNwx6GbejmcoitLbdIT4/CZTCr5k+0FO7fs8nAYaqpJoX6Tz+v1oebnHA8jQLXPjF10kHTrHggOTGQ/CtxCKWnTTk8rc813O/n1MMaZExdzE2/kGK3LMJ4YehJxJvjqTShv67JOrR/AUV1u6FDhFxZ2yUVdrycPiCjnRqSDeh3KIDt7GgraqZhZQ05n2Oz5zbTPXqSJez4l1s1+4PiFUqf1gxbucolqI2HCAWsAHjUxIiF+cPuj6zmXhXXdERcqb2yExlKrN0LTKLZ606eceaRCAzCA===9wpC-----END PGP SIGNATURE-----
P
P
Pronaip wrote on 26 May 2019 23:39
(name . Marius Bakke)(address . mbakke@fastmail.com)(name . 35908@debbugs.gnu.org)(address . 35908@debbugs.gnu.org)
QUX_S4vH_0QvgApOTqOPruWxh7amLjcOA2mPQKMT-_Lts5O8SPJR2iuaUloTBj9sSBUeQHwswTB3NvKEjvBDhP215uusnczp_cqQs6bdLiQ=@protonmail.com
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐On Sunday, May 26, 2019 8:37 AM, Marius Bakke <mbakke@fastmail.com> wrote:
Toggle quote (14 lines)> Hi Pronaip,>> Pronaip pronaip@protonmail.com writes:>> > I've been getting this error ever since I first installed Guix on Arch, but I have no idea why. I've ran guix pull and guix package -u both as root and as my own user several times since then but this error hasn't gone away.> > Also I noticed that some functionality that works on my GuixSD install (like the `guix search` command) is simply nonexistent.> > For obvious reasons I have no idea what version I'm on but I've run guix pull sometime in the last 48 hours and I originally installed it about a month or two before 1.0 came out. I also had some failed attempts at installing the AUR version but I don't know if that affected the later version that I installed straight from the offical script.>> It sounds like ~/.config/guix/current/bin is missing from PATH. See> '4.6 Invoking guix pull' in the manual.>> Make sure that directory appears first in $PATH in order to get the> correct 'guix' executable.
Huh, I thought sourcing `~/.config/guix/current/bin` was enough...guix stopped complaining about $PATH after I added thatmaybe there should be a warning about the .config path too...
L
L
Ludovic Courtès wrote on 28 May 2019 16:37
(name . Pronaip)(address . pronaip@protonmail.com)
87blzmzlts.fsf@gnu.org
Hello,
Pronaip <pronaip@protonmail.com> skribis:
Toggle quote (4 lines)> Huh, I thought sourcing `~/.config/guix/current/bin` was enough...> guix stopped complaining about $PATH after I added that> maybe there should be a warning about the .config path too...
‘guix pull’ does tell you to update PATH if needed.
‘guix describe’ also outputs a hint nowadays (pre-1.0.1):
Toggle snippet (5 lines)$ /run/current-system/profile/bin/guix describeguix describe: error: failed to determine originhint: Perhaps this `guix' command was not obtained with `guix pull'? Its version string is 1.0.0-1.326dcbf.
HTH,Ludo’.
L
L
Ludovic Courtès wrote on 5 Jun 2019 17:30
control message for bug #35908
(address . control@debbugs.gnu.org)
87lfygyrqo.fsf@gnu.org
tags 35908 notabugclose 35908quit
?
Your comment

This issue is archived.

To comment on this conversation send email to 35908@debbugs.gnu.org